DDNS and Web Connectivity Problem

Post your questions about myQNAPcloud service here.
macentrasher
Starting out
Posts: 15
Joined: Fri Oct 02, 2015 11:14 am

DDNS and Web Connectivity Problem

Postby macentrasher » Mon Oct 01, 2018 1:17 pm

Greetings,
Today I updated my nas to firmware version 4.3.5.0713. As of today myqnapcloud stopped working. I like many other users here am using a VPN client on my nas. Here lies the issue. When the QNAP nas starts up it connects to a VPN service. It then uses that VPN service wan address as its DDNS (myqnapcloud) address and everything fails to connect to the nas from the outside internet.

NAS BOOTS -> NAS Connects to VPN -> NAS reports to DDNS (myqnapcloud) its wan IP address (but its the VPN address not my home wan address) -> Nothing can connect to nas from outside network ie. insertnamehere.myqnapcloud.com always fails because its using VPN address instead of correct home wan address.

Unfortunately my home IP is dynamic and it does change so a static route isn't going to help me.

Is there a way to force the nas to report its real Wan ip address to myqnapcloud instead of the VPN provided address so that I can connect remotely again?

HighPG
New here
Posts: 3
Joined: Sat Sep 08, 2018 6:24 pm

Re: DDNS and Web Connectivity Problem

Postby HighPG » Tue Oct 02, 2018 4:40 am

I am experiencing a similar Issue after upgrading to 4.3.5
I cannot reach the NAS externally through insertnamehere.myqnapcloud.com any more.
If I log in to myQNAPcloud.com web portal I can reach it - but not directly.
I also have VPN set up.., and looking through the config I cant really figure out why..
VPN works fine - also with clients connected through the nas.
There must be something with the DDNS - but this also reports being up to date and connected.
The smart URL link does not work either.
Any ideas what can be the root couse?

macentrasher
Starting out
Posts: 15
Joined: Fri Oct 02, 2015 11:14 am

Re: DDNS and Web Connectivity Problem

Postby macentrasher » Tue Oct 02, 2018 5:45 am

It’s caused by the nas using the vpn wan address instead of my actual wan address and I don’t know how to correct it. As soon as I sign out of the VPN it works fine and updates with the correct ip. When I reconnect the vpn myqnapcloud sees the change and sets it back to my vpn wan address.

wastedtalent_nl
First post
Posts: 1
Joined: Thu Oct 04, 2018 3:22 pm

Re: DDNS and Web Connectivity Problem

Postby wastedtalent_nl » Thu Oct 04, 2018 3:26 pm

I now connect to my NAS using it's direct IP address. Hopefully anyone has a solution to make the DDNS work again.

wazzaworld
New here
Posts: 2
Joined: Sat Sep 02, 2017 5:49 am

Re: DDNS and Web Connectivity Problem

Postby wazzaworld » Mon Oct 08, 2018 5:57 pm

Exactly the same issue for me. VPN addresss is being used instead of the local ISP address.

I may have to switch DDNS back to my router instead, but am sure this was fine prior to 4.3.5.

wazzaworld
New here
Posts: 2
Joined: Sat Sep 02, 2017 5:49 am

Re: DDNS and Web Connectivity Problem

Postby wazzaworld » Mon Oct 08, 2018 6:11 pm

I logged a ticket with QNAP. Will see what they say and post back.....

brandonr91
First post
Posts: 1
Joined: Tue Dec 08, 2015 1:35 pm

Re: DDNS and Web Connectivity Problem

Postby brandonr91 » Sat Oct 20, 2018 12:49 am

@OP I am having similar issue. I also have a non-static wan address. However, I note mine doesn't change often. Once a month or less. It might just be worth the hassle until a fix is developed (if they can - likely need a wan detector app). Currently mine is statically set and is working without issue.

mixar
New here
Posts: 7
Joined: Fri Jan 16, 2009 11:54 am

Re: DDNS and Web Connectivity Problem

Postby mixar » Sat Oct 20, 2018 2:27 am

The top 3 posts on this sub right now are about the exact same issue.


Return to “myQNAPcloud service”

Who is online

Users browsing this forum: No registered users and 1 guest