DDNS MyNAS.myqnapcloud.com not working anymore

Post your questions about myQNAPcloud service here.
Post Reply
New here
Posts: 6
Joined: Fri Oct 30, 2015 2:20 am

DDNS MyNAS.myqnapcloud.com not working anymore

Post by jasonpackard » Fri Dec 14, 2018 5:33 am

I've been struggling with this for quite some time now. I used to have no problems with myqnapcloud DDNS and had the VPN setup with "Cloud connect". This allowed me to have NAS drives mapped to my laptop when I was connected remotely via VPN. I also had Qsync setup to automatically backup certain folders and directories on my work computer remotely. However both of these utilities require a DDNS url (http://yourNASname.myqnapcloud.com ... where the italics area is my particular NAS name). It worked great before, but now I can't use either of these utilities. I have narrowed it down to the "myqnapcloud" url not being functional anymore. If I type in http://yourNASname.myqnapcloud.com, the connection times out with an error.

I can still log in to http://myqnapcloud.com, enter my Qid and password to get to the browser interface and then to QTS through that. I can also still use the mobile apps on my phone (qfile, qmanager, etc). And I can login to the NAS directly with the local IP address when I'm on LAN.

I have read through the forum and have seen that lots of people are having issues with this starting with the update to 4.3.5... but I think my issues started before that. I have also read all the other people's suggestions on how to work around it and nothing has worked.

This is what I have done to try and fix it:
-verified and renewed my ssl certificate
-updated NAS firmware, updated apps
-got rid of the rented modem/router from my ISP and used my own personal modem/router
-verified port forwarding is correct with UPnP
-uninstalled/reinstalled myqnapcloud, cloudconnect, and qsync clients on my windows PC
-uninstalled and reinstalled myqnapcloud on my NAS
-verified my WAN IP address is the same as the qnapcloud DDNS IP address
-entered my WAN IP address (from my modem/router) manually as a static IP address in the qnapcloud DDNS settings (it did not connect)

What else should I do? Please, I need someone smarter than me to help me out :ashamed:

New here
Posts: 6
Joined: Sat Sep 08, 2018 6:24 pm

Re: DDNS MyNAS.myqnapcloud.com not working anymore

Post by HighPG » Thu Jan 24, 2019 5:27 am

I have exactly the same problem and symptoms!!
Used to work fine before 4.3.5
I investigated alle the same bulletpoints - with no success.
Let's hope we can get assistance from a larger brain out there... anyone?

Starting out
Posts: 26
Joined: Thu Mar 08, 2018 12:00 am

Re: DDNS MyNAS.myqnapcloud.com not working anymore

Post by cserl » Thu Mar 07, 2019 12:54 am

I can confirm, that on my TS-1277 I have the same issue.
This worked definitely a week ago.
What I changed since then was in Control Panel > Security > Allow/Deny list where I selected the radio button "Allow connections from the list only" and restricted it to, and the docker network:, and,

After I changed back to radio button "allow all connections" the connectivity test is green again --> solved.

Now the big question: what is needed to be added to the white list to prevent interfering with DDNS?

Post Reply

Return to “myQNAPcloud service”