Issue accessing NAS via the web

Post your questions about myQNAPcloud service here.
Post Reply
midmin
New here
Posts: 2
Joined: Fri Jan 18, 2019 8:44 am

Issue accessing NAS via the web

Post by midmin » Fri Jan 18, 2019 9:07 am

Hi there- looking to access my NAS via nasname.myqnapcloud.com.

I have tried using Auto Router Configuration feature with no luck. Also have manually open ports on the router (8080 & 20/21) with no luck either. CloudLink works however, using the Internet address doesn't allow me to connect to the NAS. Web Connectivity has all four services failed. I have tried as well to toggle UPnP on and off and result has been the same.

Current set up is:
- NAS connected to Mac via ethernet port
- Internet Sharing is enabled so NAS can access the internet via the Mac
- Mac is connected via WiFi to a router via WiFi
- All devices have static IP set up (NAS, Mac via ethernet and Mac WiFi)

Could it be to do with the fact that the NAS is connected directly to the Mac rather than the router?

Reason for wanting to be able to access via this way is to eventually set up my domain as the way to connect to NAS (for sharing files with clients across the internet)

Your help is appreciated!


NETWORK DIAGNOSTIC REPORT
------ NAT PMP Diagnostics ------
initnatpmp() returned 0 (SUCCESS)
using gateway : 192.168.2.1
sendpublicaddressrequest returned 2 (SUCCESS)
readnatpmpresponseorretry returned 0 (OK)
Public IP address : 192.168.0.8
epoch = 49962
closenatpmp() returned 0 (SUCCESS)
------ UPnP Diagnostics ------
upnpc : miniupnpc library test client. (c) 2006-2011 Thomas Bernard
Go to http://miniupnp.free.fr/ or http://miniupnp.tuxfamily.org/
for more information.
List of UPNP devices found on the network :
desc: http://192.168.2.7:8080/upnpd/cee2f5d2f5.xml
st: upnp:rootdevice

UPnP device found. Is it an IGD ? : http://192.168.2.7:8080/
Trying to continue anyway
Local LAN ip address : 192.168.2.7
GetConnectionTypeInfo failed.
Status : , uptime=72s, LastConnectionError :
Time started : Fri Jan 18 11:57:17 2019
MaxBitRateDown : 0 bps MaxBitRateUp 0 bps
GetExternalIPAddress() returned -1
GetExternalIPAddress failed.
GetGenericPortMappingEntry() returned -1 (Miniupnpc Unknown Error)
INFO: No any UPnP port mapping entry is found.
You do not have the required permissions to view the files attached to this post.

dolbyman
Guru
Posts: 12636
Joined: Sat Feb 12, 2011 2:11 am
Location: Vancouver BC , Canada

Re: Issue accessing NAS via the web

Post by dolbyman » Fri Jan 18, 2019 10:48 pm

that mac sharing probably introduces double nat .. that obviously won't work for router port forwarding at that point

midmin
New here
Posts: 2
Joined: Fri Jan 18, 2019 8:44 am

Re: Issue accessing NAS via the web

Post by midmin » Mon Jan 21, 2019 11:21 am

Thanks for the reply dolbyman- so would the only way to do this would be to directly connecting the NAS to the router?

I would like to avoid that option because as I transfer large amount of media files between my computer and the NAS it self, hard wired ethernet seem to offer the best speed with consistent reliability....

dolbyman
Guru
Posts: 12636
Joined: Sat Feb 12, 2011 2:11 am
Location: Vancouver BC , Canada

Re: Issue accessing NAS via the web

Post by dolbyman » Mon Jan 21, 2019 11:38 am

connecting to the router builtin switch should result in similar speeds
depending on the nas model you might have more than one lan port

Post Reply

Return to “myQNAPcloud service”