Many outbound connections to edge.api.myqnapcloud.com

Post your questions about myQNAPcloud service here.
Post Reply
CouchFox
First post
Posts: 1
Joined: Sun Nov 10, 2019 2:07 pm

Many outbound connections to edge.api.myqnapcloud.com

Post by CouchFox » Wed Feb 05, 2020 4:58 pm

Hi Community,

I'm writing to share what I've learned about this because I have seen this question pop up numerous times around the interwebs and I didn't find an adequate answer when I was first researching it.

I was initially quite concerned when I discovered that my TS-251B was being very chatty, reaching out to edge.api.myqnapcloud.com over 500 times a day, or about once every 100 seconds. What I've learned is that if you turn on pretty much any of the myQNAPcloud services, the device will ping home quite a bit.

For example, if you set up the DDNS service on a QNAP NAS, the device will start notifying edge.api.myqnapcloud.com of your current external IP address. It does this a lot, so there's no issue finding your device from the internet side, should your ISP change your IP address. That explanation was provided to me by QNAP support, and it makes sense. From my own experimentation though, it seems even logging into your QNAP ID in the myQNAPcloud app is enough to get the outbound communication rolling. What is weird is that when you turn off these services, the outbound communication doesn't stop.

Now that I have a better idea what that communication actually is (simply communicating the external IP address back to QNAP) I'm not so concerned about it. Still, it felt untidy that it should continue even after the services that need it are stopped.

The two possible "solutions" I found are both pretty drastic; either factory-reset the NAS, then do not ever login to myQNAPcloud (which means no DDNS, no external access, etc.) Or, as I did, delete the QNAP ID account entirely. When I did the latter, the NAS automatically disassociated itself from the myQNAPcloud services and immediately stopped the external communication. This is okay for me but won't suit everyone (for example, I can't log back in to close my support ticket - but thanks for the help QNAP team!)

So not a big deal in the end, but I thought I would share back as I've seen others be concerned about all this outbound communication from the NAS.

CouchFox

[EDIT] I should have mentioned - if you delete your QNAP ID, you will lose any licenses purchased with that account, so be aware...

Jeff8356
First post
Posts: 1
Joined: Wed Nov 11, 2020 2:56 am

Re: Many outbound connections to edge.api.myqnapcloud.com

Post by Jeff8356 » Wed Nov 11, 2020 3:12 am

@CouchFox,
Thanks for posting this. After going nuts trying to edit config files and get the cloud service to stop phoning home I finally came across this post.
My QNAP racked up over 8300 hits to edge.api.myqnapcloud.com over the last 3+ weeks or so that I have been monitoring it. And I don't remember turning the service on, but it's possible i did when I first setup the unit.

I had removed what I thought were all the offending apps, etc, but it made no difference. I had to delete my QNAP ID from their website to get it to stop. Pretty sad!!! Seems that once you initially set something up in QTS, it never goes away. Unless, of course, you are editing a config file....then it re-writes it whenever you reboot. :(

Thanks again.....

Post Reply

Return to “myQNAPcloud service”