Hiding virtualization from guest os

Post Reply
moongoose
New here
Posts: 2
Joined: Tue Feb 02, 2021 4:13 am

Hiding virtualization from guest os

Post by moongoose » Thu Feb 11, 2021 5:15 am

I want to hide virtualization from a Win10 guest os. The "Hide KVM signature" option in the virtual machine settings isn't enough to do this and Win10 can still tell that it's in a vm. Internet says there's one more thing, the hypervisor cpu flag also needs to be hidden via a command argument.

The vm config file are xml in a hidden folder where the disk image is stored. Virtualization station is qemu with qnap's custom frontend. I tried editing the vm's xml as per this link and added

Code: Select all

<feature policy='disable' name='hypervisor'/>
in the cpu section. Touching any settings with virtualization station's UI will overwrite the config so I stopped and restarted virtualization station in the app center.

After that, the Win10 guest could still detect that it's virtualized. I opened a terminal via ssh and looked at the command arguments when it starts the vm. It seems that either virtualization station didnt reload the config xml or it ignored the line i added.

The vm needs to start with

Code: Select all

-cpu host,kvm=off,-hypervisor
but virtualization station doesn't append

Code: Select all

-hypervisor
to the argument on startup.

Then I tried to just start the vm from the terminal but that didnt work. There's a bunch of python scripts controlling everything in the qvs directory but i dont want to tinker with them.

Anyone know enough about virtualization station to make this work? It needs to add one word to the startup arguments somehow. I have a TS-677.

Post Reply

Return to “Virtualization Station”