Problem with setting up Webdav

Post your questions about Web Server usage and Apache + PHP + MySQL/SQLite web applications.
aekash
First post
Posts: 1
Joined: Fri Jan 14, 2011 1:49 am

Problem with setting up Webdav

Postby aekash » Sun Oct 29, 2017 10:27 pm

I am trying to configure WebDAV on my QNAP.

Model: TVS-671
Firmware version: 4.3.3.0299

I have followed all steps listed in the following guide: https://www.qnap.com/en/how-to/tutorial ... via-webdav

When I try an access a shared WebDAVfolder called "test" with an account which has correct WebDAV folder permissions I get the following error

Forbidden
You don't have permission to access /test/ on this server.

I have tried "WebDAV permissions" and "Shared folder permissions" options and no luck :(

If you enable the following option on the folder "Allow guests to have read access to this network share (applies to web browsers only)" you are able to access the folder without encountering an issue.

Is this a bug / what am I missing here ? I have logged a support case with QNAP but the engineer assigned to the case just told me to refer to the guide above and has failed to revert back to me after I told him that I have followed the guifde :(

Anyone able to help resolve the issue?

Thank you

christiangd
First post
Posts: 1
Joined: Sun Sep 23, 2012 7:00 pm

Re: Problem with setting up Webdav

Postby christiangd » Sat Jun 30, 2018 8:24 pm

Did you find a solution on this one? I'm experiencing the same thing.
Tried both from browser (Chrome) and WebDav Client (Cyberduck).

User avatar
schumaku
Guru
Posts: 43543
Joined: Mon Jan 21, 2008 4:41 pm
Location: Kloten (Zurich), Switzerland -- Skype: schumaku
Contact:

Re: Problem with setting up Webdav

Postby schumaku » Tue Jul 03, 2018 6:58 pm

The Web browser can't be used for WebDAV access requiring authorization.

For CyberDuck - are you using the correct port as configured for the NAS Web Server (by default these are 80/TCP for http and 8081/TCP for https - don't mix with the QTS desktop which does default 8080/TCP for http, 443/TCP for https)?

robert50
New here
Posts: 4
Joined: Tue Oct 04, 2011 12:28 am
Location: Honolulu

Re: Problem with setting up Webdav

Postby robert50 » Thu Jul 26, 2018 6:05 am

Same issue here. I had to enable "Allow guests to have read access to this network share (applies to web browsers only)" and then I could access the folder via a web browser. Also, checking that box gave my backup application read\write access to the folder. Seems to be a bug no matter how you set up webdav permissions, that box needs to be checked otherwise no access whatsoever but now anyone can read the folder contents without logging in!

adam.sage
New here
Posts: 7
Joined: Wed Jun 25, 2014 8:31 pm

Re: Problem with setting up Webdav

Postby adam.sage » Tue Sep 11, 2018 8:10 pm

Seems I'm having the same problem. Why are browsers not supported?


Return to “Web Server & Applications (Apache + PHP + MySQL / SQLite)”

Who is online

Users browsing this forum: No registered users and 2 guests