libxml Upgrade

Post your questions about Web Server usage and Apache + PHP + MySQL/SQLite web applications.
mike29
New here
Posts: 2
Joined: Sun May 24, 2015 1:34 am

libxml Upgrade

Post by mike29 » Sun May 24, 2015 1:39 am

Can someone guide me on how to upgrade libxml? I have version 2.6.30.0 installed and would like to upgrad it to at least 2.7.8. The reason is I am using owncoud and one of the apps I would like to use requires the higher libxml version.
thanks

mike29
New here
Posts: 2
Joined: Sun May 24, 2015 1:34 am

Re: libxml Upgrade

Post by mike29 » Thu Oct 15, 2015 2:19 am

Did you get any feedback on this? I've been looking for months for an answer...
thanks

CylonCenturion

Re: libxml Upgrade

Post by CylonCenturion » Thu Oct 15, 2015 11:39 am

mike29 wrote:Did you get any feedback on this? I've been looking for months for an answer...
thanks


you asking this at yourself???

simply download and extract owncloud form here, and your are set.

Kodauk
New here
Posts: 7
Joined: Sun Feb 07, 2016 10:24 am

Re: libxml Upgrade

Post by Kodauk » Sat Mar 19, 2016 7:13 am

did you find a solution to upgrade libxml?

CylonCenturion wrote: simply download and extract owncloud form here, and your are set.


This isn't valid anymore as the latest owncloud (9) release requires libxml > 2.7.0
https://github.com/owncloud/core/pull/23319

CylonCenturion

Re: libxml Upgrade

Post by CylonCenturion » Sun Mar 20, 2016 5:39 pm

Kodauk wrote:did you find a solution to upgrade libxml?

CylonCenturion wrote: simply download and extract owncloud form here, and your are set.


This isn't valid anymore as the latest owncloud (9) release requires libxml > 2.7.0
https://github.com/owncloud/core/pull/23319


thanks

adissu
New here
Posts: 4
Joined: Wed Aug 10, 2011 10:19 pm

Re: libxml Upgrade

Post by adissu » Sat Mar 26, 2016 2:20 am

Hi everybody,

I have already found a newer version of libxml on my QNAP NAS (latest release).
How can I configure the apache/php server to use the newer libxml library. I could not figure that out.
There are some hints in the web, that I would need to recompile php. But I do not have any glance how to do that.

I am also a bit disapointed, that QNAP is delivering this old version on their OS. But this is a different topic. ;-)

jmadon
New here
Posts: 2
Joined: Wed Sep 30, 2015 7:20 am

Re: libxml Upgrade

Post by jmadon » Tue Apr 05, 2016 8:34 pm

Anyone got any suggestions on upgrading Libxml? Running phpinfo(); on my QNAP TS-251 running QTS 4.2.0 shows that libxml is at version 2.6.30.
I installed libxml2 v2.9.3-1 using opkg (via Entware-ng) but how do I configure PHP to use this version of libxml?
Owncloud 9.0 does require libxml > 2.7.0. https://github.com/owncloud/core/issues/23054

goodelyfe
Know my way around
Posts: 117
Joined: Tue Jul 01, 2014 5:50 pm

Re: libxml Upgrade

Post by goodelyfe » Sun Apr 10, 2016 8:17 am

+1!!!!

i tore down my 8.2.2 instance to start fresh and be able to upgrade all the way up to 9.0 with no problems.

got clear with manual installation and got this error

stiebs
Starting out
Posts: 22
Joined: Thu Oct 01, 2015 7:49 am

Re: libxml Upgrade

Post by stiebs » Sat Apr 16, 2016 10:19 pm

Same problem here.
Also installed v2.9.3 using opkg. So now I have /usr/lib/libxml.so.2.6.30 and /opt/lib/libxml.so.2.9.3

I've edited /etc/ld.so.conf so that /opt/lib appears before /usr/lib, and ran ldconfig, but "ldd php" binary still shows its linking to /usr/lib/libxml2.so.2.6.30

guppy
Getting the hang of things
Posts: 61
Joined: Tue Oct 09, 2007 4:25 am

Re: libxml Upgrade

Post by guppy » Wed Apr 20, 2016 4:46 pm

Any further word on this?

Not being able to run owncloud any longer is quite infuriating

luckymerlin
New here
Posts: 6
Joined: Thu Nov 19, 2015 1:33 am

Re: libxml Upgrade

Post by luckymerlin » Tue Apr 26, 2016 8:22 am

Same problem here and also in the (unofficial) german qnap forum it was discussed. But there seems no solution also, even though someone posted a "temporary solution". I didn't understand it, as I am not very firm using the console. I hope I am allowed to post the links here, if it is of any help, even though in german:

http://forum.qnapclub.de/viewtopic.php?t=35010 (first Post I found about it when I needed a newer libxml2 to install an Owncloud-App)
http://forum.qnapclub.de/viewtopic.php?f=424&t=38780 (A "warning" to upgrade to Owncloud v9, interesting are maybe the posts on page 2 and following)

CylonCenturion

Re: libxml Upgrade

Post by CylonCenturion » Tue Apr 26, 2016 1:24 pm

luckymerlin wrote:Same problem here and also in the (unofficial) german qnap forum it was discussed. But there seems no solution also, even though someone posted a "temporary solution". I didn't understand it, as I am not very firm using the console. I hope I am allowed to post the links here, if it is of any help, even though in german:

http://forum.qnapclub.de/viewtopic.php?t=35010 (first Post I found about it when I needed a newer libxml2 to install an Owncloud-App)
http://forum.qnapclub.de/viewtopic.php?f=424&t=38780 (A "warning" to upgrade to Owncloud v9, interesting are maybe the posts on page 2 and following)


qnap should provide either a qpkg for libxml2, or put it in a next fw, version 2.9.3 is preferrable: http://xmlsoft.org/sources/

I belief we will stuck with an outdated packages for the next coming month's, so with an outdated package of owncloud as well :S :S

Start to complain emediathly:
viewtopic.php?f=294&t=121809

luckymerlin
New here
Posts: 6
Joined: Thu Nov 19, 2015 1:33 am

Re: libxml Upgrade

Post by luckymerlin » Tue Apr 26, 2016 3:18 pm

CylonCenturion wrote:qnap should provide either a qpkg for libxml2, or put it in a next fw, version 2.9.3 is preferrable: http://xmlsoft.org/sources/

I belief we will stuck with an outdated packages for the next coming month's, so with an outdated package of owncloud as well :S :S

Start to complain emediathly:
viewtopic.php?f=294&t=121809

I believe resp. fear so too, actually. And yes, I also made a ticket, as I had found that other thread too.

As far as I understood that "temporary solution" in the german forum, there actually IS a newer libxml2 installed, but the symlinks might not be set correct?
And indeed, in my folder

Code: Select all

/usr/local/medialibrary/lib

actually is a file named libxml2.so.2.9.2, as I found using WinSCP (see screenshot attached) with last changed date on 18.04.2016, which probably came when I upgraded my firmware to the latest release (4.2.1 Build 20160419)? But anyways, also get that error during the Owncloud-Installation saying that currently only version 2.6.30 was installed. But it still makes me hope, there could be another solution, making things work until there is an official fix addressing this issue.
You do not have the required permissions to view the files attached to this post.

CylonCenturion

Re: libxml Upgrade

Post by CylonCenturion » Tue Apr 26, 2016 4:39 pm

luckymerlin wrote:
CylonCenturion wrote:qnap should provide either a qpkg for libxml2, or put it in a next fw, version 2.9.3 is preferrable: http://xmlsoft.org/sources/

I belief we will stuck with an outdated packages for the next coming month's, so with an outdated package of owncloud as well :S :S

Start to complain emediathly:
viewtopic.php?f=294&t=121809

I believe resp. fear so too, actually. And yes, I also made a ticket, as I had found that other thread too.

As far as I understood that "temporary solution" in the german forum, there actually IS a newer libxml2 installed, but the symlinks might not be set correct?
And indeed, in my folder

Code: Select all

/usr/local/medialibrary/lib

actually is a file named libxml2.so.2.9.2, as I found using WinSCP (see screenshot attached) with last changed date on 18.04.2016, which probably came when I upgraded my firmware to the latest release (4.2.1 Build 20160419)? But anyways, also get that error during the Owncloud-Installation saying that currently only version 2.6.30 was installed. But it still makes me hope, there could be another solution, making things work until there is an official fix addressing this issue.


Thanks, but i prefer to wait until qnap shows up with either a qpkg , or either a newer version in the FW.

The more people are complaining, the faster qnap responds.

People, demand more from qnap!!

hanswurstgesicht
First post
Posts: 1
Joined: Mon May 02, 2016 10:25 pm

Re: libxml Upgrade

Post by hanswurstgesicht » Tue May 03, 2016 1:11 am

It took some time, till I figured out, that my Owncloud installation needs a newer libxml version since version 9. Any news on that?

Thanks!

Post Reply

Return to “Web Server & Applications (Apache + PHP + MySQL / SQLite)”