Error Connection Time Out

Post your questions about Web Server usage and Apache + PHP + MySQL/SQLite web applications.
Post Reply
BarbaraDid
New here
Posts: 5
Joined: Tue Apr 05, 2016 9:04 pm

Error Connection Time Out

Post by BarbaraDid » Tue Apr 05, 2016 9:12 pm

Dear Community,

I need your support! :-)

I have recently (5 months ago) bought and configured a TS-251 NAS. I configured myqnapcloud, the webserver, phpmyadmin and a DDNS successfully.

It works fine since a few weeks. However, today, I can not access neither the **user**.myqnapcloud.com , nor through direct IP, nor through the DDNS. It says "connection time out"
When I log in the http://www.myqnapcloud.com, I can see the NAS, I see the IP and everything.
I can also see the shared files, also from the Web directory.

From my cellphone, I can successully see Qfile and Qmanager. Qmanager also reports that the Webserver is active.

So, as said, it seems to me that everything is working fine. BUT ! I have a connection time out.


My problem is that I am abroad this whole week, and I really the webserver - particularly the phpmyadmin, where all data are in the database.

I do not know out to solve the problem. Can any one help me? :S

thank you so much in advance!!

Best regards,
Barbara

BarbaraDid
New here
Posts: 5
Joined: Tue Apr 05, 2016 9:04 pm

Re: Error Connection Time Out

Post by BarbaraDid » Tue Apr 05, 2016 10:15 pm

so, I managed to log in through CloudLink, and I went to myqnapcloud app , in the section Automatic configuration of Router

The web connectivity Test failed. Here is the log :

Code: Select all

------ NAT PMP Diagnostics ------
initnatpmp() returned 0 (SUCCESS)
using gateway : 10.0.0.138
sendpublicaddressrequest returned 2 (SUCCESS)
readnatpmpresponseorretry returned -100 (TRY AGAIN)
readnatpmpresponseorretry returned -100 (TRY AGAIN)
readnatpmpresponseorretry returned -7 (FAILED)
------ UPnP Diagnostics ------
upnpc : miniupnpc library test client. (c) 2006-2011 Thomas Bernard
Go to http://miniupnp.free.fr/ or http://miniupnp.tuxfamily.org/
for more information.
List of UPNP devices found on the network :
 desc: http://10.0.0.138:8000/30wbv5tfmf5/IGD/upnp/IGD.xml
 st: urn:schemas-upnp-org:device:InternetGatewayDevice:1

Found valid IGD : http://10.0.0.138:8000/30wbv5tfmf5/IGD/upnp/control/igd/wanpppc_1_4_1
Local LAN ip address : 10.0.0.8
Connection Type : IP_Routed
Status : Connected, uptime=80789s, LastConnectionError : ERROR_IP_CONFIGURATION
  Time started : Mon Apr  4 17:46:06 2016
MaxBitRateDown : 123029000 bps   MaxBitRateUp 21823000 bps
ExternalIPAddress = xxx.xxx.xxx.xxx
GetGenericPortMappingEntry() returned -3 ((null))
INFO: No any UPnP port mapping entry is found.


I guess the problem is described here, but I do not know what I should do ?
Last edited by schumaku on Thu Apr 28, 2016 10:40 pm, edited 1 time in total.
Reason: removed public IP

User avatar
twiga
Starting out
Posts: 26
Joined: Tue Dec 29, 2015 2:09 pm

Re: Error Connection Time Out

Post by twiga » Wed Apr 27, 2016 7:25 am

I am having a similar problem. Has anyone found a fix or have an update, please?
Model: TS-653 Pro
Ram: 2G
4x WD Red 4TB
QTS 4.2.1
Raid 5

User avatar
schumaku
Guru
Posts: 43672
Joined: Mon Jan 21, 2008 4:41 pm
Location: Kloten (Zurich), Switzerland -- Skype: schumaku
Contact:

Re: Error Connection Time Out

Post by schumaku » Thu Apr 28, 2016 10:54 pm

twiga wrote:I am having a similar problem.
Similar == readnatpmpresponseorretry returned -7 (FAILED) and INFO: No any UPnP port mapping entry is found?

QTS firmware version and build number?

Router make, model, firmware version?

ISP providing a public rout-able IP address to the router public interface?

Output of the myQNAPcloud Debug Log?

User avatar
twiga
Starting out
Posts: 26
Joined: Tue Dec 29, 2015 2:09 pm

Re: Error Connection Time Out

Post by twiga » Fri Apr 29, 2016 5:05 am

schumaku wrote:
twiga wrote:I am having a similar problem.
Similar == readnatpmpresponseorretry returned -7 (FAILED) and INFO: No any UPnP port mapping entry is found?

QTS firmware version and build number?

Router make, model, firmware version?

ISP providing a public rout-able IP address to the router public interface?

Output of the myQNAPcloud Debug Log?


I have been in touch with QNAP and my issue is now resolved, except for still unable to access myqnapcloud.com via domain name, so have to use IP address. Not a big issue, so long as we can access :-)
Model: TS-653 Pro
Ram: 2G
4x WD Red 4TB
QTS 4.2.1
Raid 5

User avatar
schumaku
Guru
Posts: 43672
Joined: Mon Jan 21, 2008 4:41 pm
Location: Kloten (Zurich), Switzerland -- Skype: schumaku
Contact:

Re: Error Connection Time Out

Post by schumaku » Fri Apr 29, 2016 7:49 pm

twiga wrote:I have been in touch with QNAP and my issue is now resolved,
Any insight?

twiga wrote:except for still unable to access myqnapcloud.com via domain name, so have to use IP address.
Why not? What problems, messages, ..? Form where do you try this? Using a potentially restricted DNS service, ie. in a business or for whatever security? We know few ISP refuse to resolve any kind of DDNS names, why ever, too.

Using https://www.myqnapcloud.com/smarturl/[myQNAPcloudDeviceName] or https://[myQNAPcloudDeviceName].myqnapcloud.com/ ?

In https://[myQNAPcloudDeviceName].myqnapcloud.com/ myQNAPcloud DDNS is just a DDNS service, providing the current IP address, and not connection.

Is myQNAPcloud DDNS updated, and showing the correct IP address?

myDDNS Details pxl.jpg
You do not have the required permissions to view the files attached to this post.

VascoT
New here
Posts: 6
Joined: Fri Apr 15, 2016 1:24 am
Location: Geneva

Re: Error Connection Time Out

Post by VascoT » Wed May 11, 2016 1:32 am

I'm having a similar problem.
I've purchased a new TS 253A but cannot connect using remote access via a browser.

Network diagnostics give the following results:

Code: Select all

------ NAT PMP Diagnostics ------
initnatpmp() returned 0 (SUCCESS)
using gateway : 192.168.1.1
sendpublicaddressrequest returned 2 (SUCCESS)
readnatpmpresponseorretry returned -7 (FAILED)
------ UPnP Diagnostics ------
upnpc : miniupnpc library test client. (c) 2006-2011 Thomas Bernard
Go to http://miniupnp.free.fr/ or http://miniupnp.tuxfamily.org/
for more information.
List of UPNP devices found on the network :
 desc: http://192.168.1.1:60000/1660d48a/gatedesc1.xml
 st: urn:schemas-upnp-org:device:InternetGatewayDevice:1

Found valid IGD : http://192.168.1.1:60000/1660d48a/upnp/control/WANIPConn1
Local LAN ip address : 192.168.1.110
Connection Type : IP_Routed
Status : Connected, uptime=1462899728s, LastConnectionError : ERROR_NONE
  Time started : Thu Jan  1 01:02:30 1970
MaxBitRateDown : 1863163520 bps   MaxBitRateUp 3324000000 bps
ExternalIPAddress = <<removed>>
 0 TCP 54340->192.168.1.103:54340 'uTorrent (TCP)' ''
 1 UDP 54340->192.168.1.103:54340 'uTorrent (UDP)' ''
 2 TCP  8080->192.168.1.110:8080  '69c44e39ce6341d598fd38ff4efcd72c-Web Admin' ''
 3 TCP  8081->192.168.1.110:8081  '69c44e39ce6341d598fd38ff4efcd72c-Secure Web Serve' ''
 4 UDP 62344->192.168.1.103:62344 'Teredo' ''
GetGenericPortMappingEntry() returned 713 (SpecifiedArrayIndexInvalid)


Device: TS 253A
HDD: 2x2Tb WD (Red)
HDcfg: Raid 1
Version: 4.2.1-20160419

UPnP IGD is enabled on my router

Can anybody help me please?

Thanks in advance
Last edited by schumaku on Thu May 19, 2016 4:38 am, edited 1 time in total.
Reason: removed public IP

User avatar
schumaku
Guru
Posts: 43672
Joined: Mon Jan 21, 2008 4:41 pm
Location: Kloten (Zurich), Switzerland -- Skype: schumaku
Contact:

Re: Error Connection Time Out

Post by schumaku » Thu May 19, 2016 4:46 am

Bonsoir Genève,

The NAS LAN IP is 192.168.1.110, only one interface is connected, and the default gateway is configured to this interface?

Correctly added the two ports like http://[NAS]:8080/ respl https://[NAS]:8081/ - and used access from outside of the local LAN, ie. a mobile 3G/4G phone with LAN off, or another Internet access?

Salut,
-Kurt.

PS. Removed the public IP visible on the diagnostics output

BarbaraDid
New here
Posts: 5
Joined: Tue Apr 05, 2016 9:04 pm

Re: Error Connection Time Out

Post by BarbaraDid » Tue Sep 27, 2016 10:08 pm

I still could not fix my issue.... If anyone could help me... I am getting desperate. It has been almost 6 months I have this problem!


------ NAT PMP Diagnostics ------
initnatpmp() returned 0 (SUCCESS)
using gateway : 10.0.0.138
sendpublicaddressrequest returned 2 (SUCCESS)
readnatpmpresponseorretry returned -100 (TRY AGAIN)
readnatpmpresponseorretry returned -100 (TRY AGAIN)
readnatpmpresponseorretry returned -7 (FAILED)
------ UPnP Diagnostics ------
upnpc : miniupnpc library test client. (c) 2006-2011 Thomas Bernard
Go to http://miniupnp.free.fr/ or http://miniupnp.tuxfamily.org/
for more information.
List of UPNP devices found on the network :
desc: http://10.0.0.138:8000/30wbv5tfmf5/IGD/upnp/IGD.xml
st: urn:schemas-upnp-org:device:InternetGatewayDevice:1

Found valid IGD : http://10.0.0.138:8000/30wbv5tfmf5/IGD/ ... pppc_1_4_1
Local LAN ip address : 10.0.0.1
Connection Type : IP_Routed
Status : Connected, uptime=39786s, LastConnectionError : ERROR_NONE
Time started : Tue Sep 27 04:28:20 2016
MaxBitRateDown : 122305000 bps MaxBitRateUp 23964000 bps
ExternalIPAddress = xx.xxx.xxx.xx
0 TCP 8080->10.0.0.1:8080 '' ''
GetGenericPortMappingEntry() returned 606 ((null))




Image


I really do not know what I should you. Thank you in advance for your help...

Nikmartin
New here
Posts: 2
Joined: Sun May 12, 2019 1:22 am

Re: Error Connection Time Out

Post by Nikmartin » Sun May 12, 2019 10:17 pm

I am also facing same issue and Your discussion resolve my problem. Thank you contributors.

johnsonmax007
First post
Posts: 1
Joined: Tue Sep 03, 2019 5:35 pm

Re: Error Connection Time Out

Post by johnsonmax007 » Tue Sep 10, 2019 2:28 pm

This seems like an ongoing problem. I scoured the documentation but I think I am still unable to fix it. I will continue trying and I will update you all once it has been fixed. Fingers Crossed

Post Reply

Return to “Web Server & Applications (Apache + PHP + MySQL / SQLite)”