Secure access to Virtual Host(s)

Post your questions about Web Server usage and Apache + PHP + MySQL/SQLite web applications.
Erle Williams
New here
Posts: 6
Joined: Wed Jun 28, 2017 2:28 am

Secure access to Virtual Host(s)

Postby Erle Williams » Wed Aug 09, 2017 6:44 am

Hello,
I am having a problem getting SSL configured to access my virtual host.

I have successfully moved two virtual hosts from an Oracle Virtualbox that hosted my WordPress websites. I am able to access both Virtual Hosts on the QNAP but one of them (eventually both) I want to configure to use SSL certificates.

I had the original secure site configured with certbot (Letsencrypt) and would like to continue using it if possible. I installed 0.6 certbot on the QNAP successfully but get an error trying to create an ssl certificate with the following command:

Code: Select all

certbot certonly -d securesite.com --agree-tos --config-dir "share/CACHEDEV1_DATA/letsencrypt" --webroot --webroot-path "/share/CACHEDEV1_DATA/Web/vervol"

(securesite.com is a replacement for the actual domain name)

It returns the following error as part of the letsencrypt.log:
"type": "urn:acme:error:serverInternal",
"detail": "Error creating new registration",
"status": 500
Error: urn:acme:error:serverInternal :: The server experienced an internal error :: Error creating new registration

I then copied my existing certificates (privkey1.pem, chain1.pem and cert1.pem) that I created on the old platform onto the QNAP and edited apache.conf file to use them. After restarting the web service it removes my changes. I also tried editing httpd-ssl-vhosts-user.conf in the extra folder but it gets overwritten also. I don't mind making the changes manually but not sure where to make the edits without them being overwritten.

I have browsed and read many articles on this forum as well as numerous others and hope this is not a duplicate (apologies if it is :ashamed: ).


Any input is appreciated.

I have a TS-451A Version 4.3.3.0262

Sincerely,

Erle Williams

ampapa
Know my way around
Posts: 102
Joined: Sat Dec 03, 2011 7:47 am

Re: Secure access to Virtual Host(s)

Postby ampapa » Tue Aug 29, 2017 9:00 pm

Erie,

Just curious if you got certbot going on you Qnap or if you have any update as I'm looking to do the same...

ampapa,

Erle Williams
New here
Posts: 6
Joined: Wed Jun 28, 2017 2:28 am

Re: Secure access to Virtual Host(s)

Postby Erle Williams » Sat Sep 02, 2017 12:59 am

Hi,
Yes, I was able to get certbot installed with the qpkg available here. https://www.forum-nas.fr/viewtopic.php?t=4300

After the installation I used the command line to create the certificates and let certbot configure the QNAP. ( I did not use certonly option).

However, I continue to have issues with secure access to my WordPress site on the QNAP. I'm pretty sure it's a WordPress configuration issue as it's only the home page that gives me issues. It's a little strange because when trying to access the website's homepage I get the QNAP admin login page. When I access all other pages directly (not using menu's or links) it works fine and accesses the website securely.

Hope that helps you.

Erle


Return to “Web Server & Applications (Apache + PHP + MySQL / SQLite)”

Who is online

Users browsing this forum: No registered users and 2 guests