[QSonarr] [2.0.0.5338] Smart PVR for newsgroup and bittorrent users

This is the best place for community developers to publish their genius work. Your Apps enrich the QNAP Turbo NAS.
Post Reply
User avatar
QNAP_Stephane
Experience counts
Posts: 3796
Joined: Wed Mar 27, 2013 1:00 am

Re: [ QSonarr ] [ 1.150606 ] Smart PVR for newsgroup and bit

Post by QNAP_Stephane » Wed Jul 08, 2015 4:43 pm

@ usuario945898754 and adprom

did you enable home user on your NAS ?

Control Panel > users > Home Folder

let me know, i am checking if i can set the data path in a share location but dont find the right command, using home is more convenient
--------------------------------------------------------------------------
QnapClub AppCenter - https://www.qnapclub.eu
--------------------------------------------------------------------------

usuario945898754
Know my way around
Posts: 138
Joined: Fri Aug 16, 2013 6:58 am

Re: [ QSonarr ] [ 1.150606 ] Smart PVR for newsgroup and bit

Post by usuario945898754 » Sat Jul 11, 2015 7:19 am

I did, I have home user enabled. I tried to disable and enable again just in case and problem is still happening.

sloporc
Know my way around
Posts: 114
Joined: Tue Jul 07, 2015 11:09 pm

Re: [ QSonarr ] [ 1.150606 ] Smart PVR for newsgroup and bit

Post by sloporc » Tue Jul 14, 2015 10:53 pm

Tried enabling SSL on Sonarr but now the app is unreachable. I see now from earlier in this thread that it appears that SSL is not working.

If SSL CANNOT be enabled for Sonarr, how can I reset this feature without access to the GUI?
If SSL CAN be enabled for Sonarr, what might I have done wrong?

I am fairly new to this stuff, appreciate any hand holding you can give me!
Model: TVS-463
Firmware: QTS 4.3.3.0154
Storage: RAID 5, 4 x4TB HGST Deskstar HG0S03664
RAM: Crucial 16GB Kit (8GBx2) DDR3-1600 MT/s (PC3-12800)
Networking: Port trunking balance-tlb

usuario945898754
Know my way around
Posts: 138
Joined: Fri Aug 16, 2013 6:58 am

Re: [ QSonarr ] [ 1.150606 ] Smart PVR for newsgroup and bit

Post by usuario945898754 » Wed Jul 15, 2015 9:20 pm

Just uninstall and reinstall the app.

sloporc
Know my way around
Posts: 114
Joined: Tue Jul 07, 2015 11:09 pm

Re: [ QSonarr ] [ 1.150606 ] Smart PVR for newsgroup and bit

Post by sloporc » Wed Jul 15, 2015 9:48 pm

I realize that I can do that, but I was hoping to not have to reconfigure Sonarr.

Can we confirm if Sonarr can be used with SSL?
Model: TVS-463
Firmware: QTS 4.3.3.0154
Storage: RAID 5, 4 x4TB HGST Deskstar HG0S03664
RAM: Crucial 16GB Kit (8GBx2) DDR3-1600 MT/s (PC3-12800)
Networking: Port trunking balance-tlb

sloporc
Know my way around
Posts: 114
Joined: Tue Jul 07, 2015 11:09 pm

Re: [ QSonarr ] [ 1.150606 ] Smart PVR for newsgroup and bit

Post by sloporc » Thu Jul 16, 2015 2:54 am

Hi, I have attempted to uninstall and reinstall QSonarr via QTS to resolve the SSL issue. Unfortunately, I can no longer access the UI from either 127.0.0.1:8989 from HDMI out on my TVS-563 or from ipaddress:8989 from a browser on my laptop. I can not access via 9898 (SSL) ports either. Any help on how to uninstall and reinstall to fix this issue is appreciated.
Model: TVS-463
Firmware: QTS 4.3.3.0154
Storage: RAID 5, 4 x4TB HGST Deskstar HG0S03664
RAM: Crucial 16GB Kit (8GBx2) DDR3-1600 MT/s (PC3-12800)
Networking: Port trunking balance-tlb

User avatar
QNAP_Stephane
Experience counts
Posts: 3796
Joined: Wed Mar 27, 2013 1:00 am

Re: [ QSonarr ] [ 1.150606 ] Smart PVR for newsgroup and bit

Post by QNAP_Stephane » Thu Jul 16, 2015 3:01 am

SSL is not working with Mono, you have to setup a HTTP proxy SSL in front of QSonarr
--------------------------------------------------------------------------
QnapClub AppCenter - https://www.qnapclub.eu
--------------------------------------------------------------------------

sloporc
Know my way around
Posts: 114
Joined: Tue Jul 07, 2015 11:09 pm

Re: [ QSonarr ] [ 1.150606 ] Smart PVR for newsgroup and bit

Post by sloporc » Thu Jul 16, 2015 3:04 am

QNAP_Stephane wrote:SSL is not working with Mono, you have to setup a HTTP proxy SSL in front of QSonarr


Right, I tried uninstalling and reinstalling to use without SSL. I can no longer access the UI. Not sure how to resolve this issue.
Model: TVS-463
Firmware: QTS 4.3.3.0154
Storage: RAID 5, 4 x4TB HGST Deskstar HG0S03664
RAM: Crucial 16GB Kit (8GBx2) DDR3-1600 MT/s (PC3-12800)
Networking: Port trunking balance-tlb

ziptbm
Starting out
Posts: 30
Joined: Mon Mar 09, 2015 12:41 pm

Re: [ QSonarr ] [ 1.150606 ] Smart PVR for newsgroup and bit

Post by ziptbm » Thu Jul 16, 2015 6:52 am

QNAP_Stephane wrote:SSL is not working with Mono, you have to setup a HTTP proxy SSL in front of QSonarr


Any recommendations or references on how to do this for the people still learning this platform?

User avatar
QNAP_Stephane
Experience counts
Posts: 3796
Joined: Wed Mar 27, 2013 1:00 am

Re: [ QSonarr ] [ 1.150606 ] Smart PVR for newsgroup and bit

Post by QNAP_Stephane » Thu Jul 16, 2015 2:00 pm

sloporc wrote:
QNAP_Stephane wrote:SSL is not working with Mono, you have to setup a HTTP proxy SSL in front of QSonarr


Right, I tried uninstalling and reinstalling to use without SSL. I can no longer access the UI. Not sure how to resolve this issue.


I think go in admin homes with WinSCP ( on HAL models : /share/CACHEDEV1_DATA/homes/admin/.config/NzbDrone ) and delete contents

and reinstall (or restart application)
--------------------------------------------------------------------------
QnapClub AppCenter - https://www.qnapclub.eu
--------------------------------------------------------------------------

sloporc
Know my way around
Posts: 114
Joined: Tue Jul 07, 2015 11:09 pm

Re: [ QSonarr ] [ 1.150606 ] Smart PVR for newsgroup and bit

Post by sloporc » Thu Jul 16, 2015 9:52 pm

QNAP_Stephane wrote:I think go in admin homes with WinSCP ( on HAL models : /share/CACHEDEV1_DATA/homes/admin/.config/NzbDrone ) and delete contents
and reinstall (or restart application)


This did not work for me. I did the following:

    > uninstalled qsonarr from QTS interface
    > rm -rf on all contents of the nzbdrone directory from mac terminal
    > confirm all contents of directory deleted
    > reinstalled sonar manually from QTS interface

Did I do what you expected? If not, any other ideas? I cringe at the idea of going back to Sickbeard now that I have experienced the glory of Sonarr!
Model: TVS-463
Firmware: QTS 4.3.3.0154
Storage: RAID 5, 4 x4TB HGST Deskstar HG0S03664
RAM: Crucial 16GB Kit (8GBx2) DDR3-1600 MT/s (PC3-12800)
Networking: Port trunking balance-tlb

trueimage
Getting the hang of things
Posts: 71
Joined: Sun May 16, 2010 5:11 am

Re: [ QSonarr ] [ 1.150606 ] Smart PVR for newsgroup and bit

Post by trueimage » Fri Jul 17, 2015 10:27 am

Are there any special steps required to install this (TS-651)?

1. Git
2. NZBGet
3. Qmono 3.10
4. QSonarr
Setup

is that it?
TS-651 x86 8GB RAM
FW 4.3.3.0188

User avatar
Trexx
Ask me anything
Posts: 5285
Joined: Sat Oct 01, 2011 7:50 am
Location: Minnesota

Re: [ QSonarr ] [ 1.150606 ] Smart PVR for newsgroup and bit

Post by Trexx » Sat Jul 18, 2015 5:39 am

You could use SABNzbd instead of NZBGet for #2, but otherwise looks like you have the basics down.
Paul

Model: TS-877-1600 FW: 4.4.3.x
QTS (SSD): [RAID-1] 2 x 1TB WD Blue m.2's
Data (HDD): [RAID-5] 6 x 3TB HGST DeskStar
VMs (SSD): [RAID-1] 2 x 500GB Evo 860
Ext. (HDD): TR-004 [Raid-5] 4 x 4TB HGST Ultastor
RAM: Kingston HyperX Fury 64GB DDR4-2666
GPU: EVGA GTX 1060 6GB
UPS: CP AVR1350

Model:TVS-673 32GB FW: 4.4.3.x Test/Backup Box
Model:TS-228a FW: 4.4.3.x Test/Backup Box
-----------------------------------------------------------------------------------------------------------------------------------------
NAS RAID Rebuild Times | Live QTS Videos | | QNAP NAS Guide | Information needed when you ask for HELP | QNAP Links, Tutorials, etc.
2018 Plex NAS Compatibility Guide | QNAP Plex FAQ | Moogle's QNAP Faq

sloporc
Know my way around
Posts: 114
Joined: Tue Jul 07, 2015 11:09 pm

Re: [ QSonarr ] [ 1.150606 ] Smart PVR for newsgroup and bit

Post by sloporc » Sun Jul 19, 2015 8:39 am

Went to the Sonarr forum. Investigated the logs and it appears that SQLite might be causing the issue.

Link to QSonarr log: http://hastebin.com/kilavihitu.1c

Edit: Issue closed. I uninstalled both Mono and Sonarr and installed the oldest versions of each qpkg that I could find posted on this forum. Sonarr works now, and I was then able to update to the latest version via in-app process.
Model: TVS-463
Firmware: QTS 4.3.3.0154
Storage: RAID 5, 4 x4TB HGST Deskstar HG0S03664
RAM: Crucial 16GB Kit (8GBx2) DDR3-1600 MT/s (PC3-12800)
Networking: Port trunking balance-tlb

grillba
New here
Posts: 4
Joined: Tue Jul 03, 2012 5:54 pm

Re: [ QSonarr ] [ 1.150606 ] Smart PVR for newsgroup and bit

Post by grillba » Mon Jul 20, 2015 5:21 pm

Hi all,

The Ramdisk issue is due to Sonarr using a hardcoded path to store the application data which is ~/.config/Nzbdrone - This equates to /root/.config/Nzbdrone which is on the Ramdisk. Once you start caching info for a lot of Series, it blows the Ramdisk space.

I managed to overcome the Ramdisk issue by creating a sym link for the Nzbdrone directory to a directory on /share/HDA_DATA.

There's also this solution which I haven't tried - viewtopic.php?f=128&t=87543&p=476566#p476566

Hope it helps.

Mark

Post Reply

Return to “Community Apps”