[ Emby ] [ 3.3.0.0 ] Media server

This is the best place for community developers to publish their genius work. Your Apps enrich the QNAP Turbo NAS.
Post Reply
User avatar
Spider99
Experience counts
Posts: 1928
Joined: Fri Oct 21, 2011 11:14 pm
Location: Warrington, England

Re: [ Emby ] [ 3.3.0.0 ] Media server

Post by Spider99 » Thu Mar 01, 2018 11:48 pm

You need to look a little harder :)

https://github.com/MediaBrowser/Emby/releases

scroll down a bit to 3.3.0.0

the qpkg is only for x64 Stable and is based on .net core -- NOT mono

I would strongly advise against having both Mono version and this new one on the same QNAp

Uninstall the mono version first - backup your user data before that using their backup plugin so you can restore to the new version etc

Once the new version is installed - remember after you setup the libraries it will take a long time to rebuild the database - be patient depending on the size of your library it could take more than a day

Works great on my 853A
Tim

TS-853A(16GB): - 4.3.4.0483 - Static volume - Raid5 - 8 x 4TB HGST Deskstar NAS
Windows Server + StableBit Drivepool and Scanner ~115 TB Backup Server
TS-412 & TS-459 Pro II: Retired
Clients: 3 x Windows 10 Pro(64bit)

User avatar
QNAP_Stephane
Experience counts
Posts: 2954
Joined: Wed Mar 27, 2013 1:00 am

Re: [ Emby ] [ 3.3.0.0 ] Media server

Post by QNAP_Stephane » Fri Mar 02, 2018 7:39 pm

magnus67 wrote:What is the x64 build called? cant find any qpkg on the pages referred to on page one.

Magnus


you can find the Emby official qpkg on their github page release

i am stopping the Mono version for x64 (Emby Staff request for a better support on their side)
--------------------------------------------------------------------------
QnapClub AppCenter - https://www.qnapclub.eu
--------------------------------------------------------------------------

Sparkss
Getting the hang of things
Posts: 99
Joined: Sat Sep 26, 2009 7:50 am

Re: [ Emby ] [ 3.3.0.0 ] Media server

Post by Sparkss » Wed Nov 21, 2018 4:30 am

Where can I find support for the 3.5.0.0 and 3.5.2.0 x86 qpkgs?

I get an unhandled exception error with both 3.5.x versions, but 3.4.0.0 works.

I have a TS-659 Pro II so I need to stick with x86 releases.
I am on the latest FW/QTS version for my NAS (the Oct roll up release)
I have rebooted several times, just to be sure.
I have updated QMono to 5.4.1.6 (the min required for Emby 3.5.x and the last x86 compiled Qmono release)

Code: Select all


[/share/HDA_DATA/.qpkg/Emby] # ./Emby.sh start
ln: /opt/Emby/Emby: File exists

Unhandled Exception:
System.EntryPointNotFoundException: GetNativeSystemInfo
at (wrapper managed-to-native) Interop+Kernel32:GetNativeSystemInfo (Interop/Kernel32/SYSTEM_INFO&)
at System.Runtime.InteropServices.RuntimeInformation.get_OSArchitecture () [0x0001c] in <fd6c8616c1d843f9ac17a1c48a45fda2>:0
at EmbyServer.Program.GetEnvironmentInfo (Emby.Server.Implementations.StartupOptions options) [0x00080] in <810800dc032d4ca9ae1f9cf140cbc0c4>:0
at EmbyServer.Program+<Main>d__11.MoveNext () [0x00048] in <810800dc032d4ca9ae1f9cf140cbc0c4>:0
--- End of stack trace from previous location where exception was thrown ---
at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () [0x0000c] in <58d2ed2b2c8740ac8f02ad37136e23c2>:0
at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) [0x0003e] in <58d2ed2b2c8740ac8f02ad37136e23c2>:0
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) [0x00028] in <58d2ed2b2c8740ac8f02ad37136e23c2>:0
at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) [0x00008] in <58d2ed2b2c8740ac8f02ad37136e23c2>:0
at System.Runtime.CompilerServices.TaskAwaiter.GetResult () [0x00000] in <58d2ed2b2c8740ac8f02ad37136e23c2>:0
at EmbyServer.Program.<Main> (System.String[] args) [0x0000c] in <810800dc032d4ca9ae1f9cf140cbc0c4>:0
[ERROR] FATAL UNHANDLED EXCEPTION: System.EntryPointNotFoundException: GetNativeSystemInfo
at (wrapper managed-to-native) Interop+Kernel32:GetNativeSystemInfo (Interop/Kernel32/SYSTEM_INFO&)
at System.Runtime.InteropServices.RuntimeInformation.get_OSArchitecture () [0x0001c] in <fd6c8616c1d843f9ac17a1c48a45fda2>:0
at EmbyServer.Program.GetEnvironmentInfo (Emby.Server.Implementations.StartupOptions options) [0x00080] in <810800dc032d4ca9ae1f9cf140cbc0c4>:0
at EmbyServer.Program+<Main>d__11.MoveNext () [0x00048] in <810800dc032d4ca9ae1f9cf140cbc0c4>:0
--- End of stack trace from previous location where exception was thrown ---
at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () [0x0000c] in <58d2ed2b2c8740ac8f02ad37136e23c2>:0
at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) [0x0003e] in <58d2ed2b2c8740ac8f02ad37136e23c2>:0
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) [0x00028] in <58d2ed2b2c8740ac8f02ad37136e23c2>:0
at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) [0x00008] in <58d2ed2b2c8740ac8f02ad37136e23c2>:0
at System.Runtime.CompilerServices.TaskAwaiter.GetResult () [0x00000] in <58d2ed2b2c8740ac8f02ad37136e23c2>:0
at EmbyServer.Program.<Main> (System.String[] args) [0x0000c] in <810800dc032d4ca9ae1f9cf140cbc0c4>:0

User avatar
OneCD
Ask me anything
Posts: 5839
Joined: Sun Aug 21, 2016 10:48 am
Location: "... there, behind that sofa!"

Re: [ Emby ] [ 3.3.0.0 ] Media server

Post by OneCD » Wed Nov 21, 2018 4:43 am

Sparkss wrote:
Wed Nov 21, 2018 4:30 am

Code: Select all


[/share/HDA_DATA/.qpkg/Emby] # ./Emby.sh start
ln: /opt/Emby/Emby: File exists
Have you installed SortMyQPKGs?

production NAS: TS-569 Pro with Debian 9.8 'Stretch' (power on/off times are < 1 minute).
backup NAS: TS-559 Pro+ with QTS 4.2.6 #20181227

one.cd.only@gmail.com

Image Image Image Image

Sparkss
Getting the hang of things
Posts: 99
Joined: Sat Sep 26, 2009 7:50 am

Re: [ Emby ] [ 3.3.0.0 ] Media server

Post by Sparkss » Wed Nov 21, 2018 6:27 am

OneCD wrote:
Wed Nov 21, 2018 4:43 am
Sparkss wrote:
Wed Nov 21, 2018 4:30 am

Code: Select all


[/share/HDA_DATA/.qpkg/Emby] # ./Emby.sh start
ln: /opt/Emby/Emby: File exists
Have you installed SortMyQPKGs?
As a matter of fact I just did. I had issues with Sonarr not starting due to issues with QMono. I am hoping that will resolve it. But not sure what impact that would have on Emby?

Sparkss
Getting the hang of things
Posts: 99
Joined: Sat Sep 26, 2009 7:50 am

Re: [ Emby ] [ 3.3.0.0 ] Media server

Post by Sparkss » Wed Nov 21, 2018 6:31 am

OneCD wrote:
Wed Nov 21, 2018 4:43 am
Sparkss wrote:
Wed Nov 21, 2018 4:30 am

Code: Select all


[/share/HDA_DATA/.qpkg/Emby] # ./Emby.sh start
ln: /opt/Emby/Emby: File exists
Have you installed SortMyQPKGs?
Wait, I seem to recall that was your package, right? I wanted to say a great big Thanks for that! I had been trying to adjust the start order for ages, your package was greatly appreciated. You sig has some items that interest me also, as I am bumping into limitations on my NAS currently (mainly due to the 32 bit OS, despite the 64 bit CPU). My other server is running CentOS

User avatar
OneCD
Ask me anything
Posts: 5839
Joined: Sun Aug 21, 2016 10:48 am
Location: "... there, behind that sofa!"

Re: [ Emby ] [ 3.3.0.0 ] Media server

Post by OneCD » Wed Nov 21, 2018 6:53 am

No worries, SortMyQPKGs is really a community effort. :)

I can’t promise it will fix the problem you’ve reported, but it’s designed to correct the startup order of both the Mono and Emby packages .

production NAS: TS-569 Pro with Debian 9.8 'Stretch' (power on/off times are < 1 minute).
backup NAS: TS-559 Pro+ with QTS 4.2.6 #20181227

one.cd.only@gmail.com

Image Image Image Image

Sparkss
Getting the hang of things
Posts: 99
Joined: Sat Sep 26, 2009 7:50 am

Re: [ Emby ] [ 3.3.0.0 ] Media server

Post by Sparkss » Wed Nov 21, 2018 10:08 am

OneCD wrote:
Wed Nov 21, 2018 6:53 am
No worries, SortMyQPKGs is really a community effort. :)

I can’t promise it will fix the problem you’ve reported, but it’s designed to correct the startup order of both the Mono and Emby packages .
I think that you misunderstood my post. :) That error was long after boot, trying to manually launch it from command line. The issue isn't related to startup/boot order.

EDIT: Also, Emby 3.4.0.0 launches fine, 3.5.x (two packages currently avail) both give the above error. Tested by uninstalling/installing the versions and trying to launch them.

User avatar
QNAP_Stephane
Experience counts
Posts: 2954
Joined: Wed Mar 27, 2013 1:00 am

Re: [ Emby ] [ 3.3.0.0 ] Media server

Post by QNAP_Stephane » Wed Nov 21, 2018 6:48 pm

Better use the official Emby build package at this time

the QMono version is no longer updated on time
--------------------------------------------------------------------------
QnapClub AppCenter - https://www.qnapclub.eu
--------------------------------------------------------------------------

Sparkss
Getting the hang of things
Posts: 99
Joined: Sat Sep 26, 2009 7:50 am

Re: [ Emby ] [ 3.3.0.0 ] Media server

Post by Sparkss » Wed Nov 21, 2018 10:43 pm

QNAP_Stephane wrote:
Wed Nov 21, 2018 6:48 pm
Better use the official Emby build package at this time

the QMono version is no longer updated on time
I wish I could, but again, on a TS-659-Pro II running QTS 4.2.6, so I am not able to install the the official Emby package, due to QNap abandoning us older Intel based NAS users with only a 32 bit OS (despite having a 64 bit CPU).

User avatar
teckel
Know my way around
Posts: 185
Joined: Thu Feb 05, 2015 2:57 am
Contact:

Re: [ Emby ] [ 3.3.0.0 ] Media server

Post by teckel » Wed Dec 12, 2018 12:04 am

Just looking for the link to the latest 32 bit version of Emby for QNAP. Tried searching here and on the Emby website and I can't find it. I know, I should just update to the 64 bit version of QNAP. But, I'd lose both Transmission and my VPN connection so that's not an option.

In any case, the link to the x86 (32 bit) version of Emby would be awesome, and it looks like others are looking for that as well.

Thanks!

User avatar
QNAP_Stephane
Experience counts
Posts: 2954
Joined: Wed Mar 27, 2013 1:00 am

Re: [ Emby ] [ 3.3.0.0 ] Media server

Post by QNAP_Stephane » Thu Dec 13, 2018 2:31 pm

Hi

Emby, is not open source anymore... if you wish to continue use New Emby version you need to use the version proposed by Emby on their website

Jellyfin will be a fork for Emby, but still young in devellopment

https://github.com/jellyfin/jellyfin
--------------------------------------------------------------------------
QnapClub AppCenter - https://www.qnapclub.eu
--------------------------------------------------------------------------

User avatar
Skeptical.me
Easy as a breeze
Posts: 370
Joined: Sun Jun 05, 2016 8:58 am
Location: Australia

Re: [ Emby ] [ 3.3.0.0 ] Media server

Post by Skeptical.me » Fri Dec 14, 2018 5:43 pm

I just subscribed to emby but Im not giving up on Plex, Plex is awesome. I like emby for the time when I want to use Google Home to control Emby. To do that with Plex is more difficult so I believe.
QNAP TS-253Be 8GB, 2 x WD Red 6TB, & 1 x WD Red 6TB & WD 4TB Externals, QM2-2S M.2 500GB SSD Cache Acceleration, QTS: 4.3.6.0875

ASUS RT-AX88U WRT-Merlin Firmware 384.9 (AMTM, Pixelserv, Entware, Diversion & Skynet),

2017 iMac 27" 5K i5 3.5GHz 64GB 1TB & Thunderbolt 3 500GB M.2 External Boot Drive Radeon Pro 575 4GB, Raspberry Pi (NextCloudPi) 6TB.

QVPN, Plex, Radar, Sonarr, Lidarr, NZBGet, NZBHydra 2, Download Station, QVR Pro, Duplicati, Bliss (Unlimited)

serendrewpity
Starting out
Posts: 19
Joined: Sat Mar 12, 2016 4:16 pm

Re: [ Emby ] [ 3.3.0.0 ] Media server

Post by serendrewpity » Tue Mar 12, 2019 4:07 am

Is v3+ still being maintained and updated in parallel to v4+

Is this the support thread for both? Or is there a separate support thread for v4+

User avatar
Spider99
Experience counts
Posts: 1928
Joined: Fri Oct 21, 2011 11:14 pm
Location: Warrington, England

Re: [ Emby ] [ 3.3.0.0 ] Media server

Post by Spider99 » Wed Mar 13, 2019 9:04 am

v3 is no more

For V4 go here - pick qnap from the dropdown and choose the version for your QNAP hardware

https://emby.media/nas-server.html

Support for Emby - visit the emby Forum's https://emby.media/community/
Tim

TS-853A(16GB): - 4.3.4.0483 - Static volume - Raid5 - 8 x 4TB HGST Deskstar NAS
Windows Server + StableBit Drivepool and Scanner ~115 TB Backup Server
TS-412 & TS-459 Pro II: Retired
Clients: 3 x Windows 10 Pro(64bit)

Post Reply

Return to “Community Apps”