[ QApache 2.4.39 + PHP 7.2.29 ] WebServer with PHP and PECL

This is the best place for community developers to publish their genius work. Your Apps enrich the QNAP Turbo NAS.
Post Reply
CylonCenturion

Re: [ QApache 2.4.23 + PHP 7.0.9 ] WebServer and more

Post by CylonCenturion » Sun Sep 11, 2016 8:29 pm

QNAP_Stephane wrote:x64 version added for true x64 system (or FW 4.3.x )

all libs updated + php 7.0.10

Thanks,
But i am clueless how to use it in combination with
1- phpmyadmin
2- spotweb.

Both apps requesting either a path or complaining that there is no access to whatever dir.

winniecoffee
New here
Posts: 2
Joined: Thu Sep 15, 2016 12:48 pm

Re: [ QApache 2.4.23 + PHP 7.0.9 ] WebServer and more

Post by winniecoffee » Thu Sep 15, 2016 12:58 pm

I was successfully install Qapache package (Qapache_2.4.23.0_x86.qpkg).

After editing /opt/Qapache/etc/httpd.conf and want to restart it from ssh client.

I accidentally execute command below:
/opt/Qapache/Qapache.sh restart
(error message shows up)

Now I couldn't see /opt/Qapache in my folder

(p.s. /opt folder only contains one file -- nasconfig_fs.img.tgz)

What does Qapache.sh do in QNAP system?
And what should I do right now?! (Can I reinstall package?)
Please help me out! Thank you


-------- Solution Update (2016/9/15)--------

I add back symbolic link:

Code: Select all

ln -sf /share/CACHEDEV1_DATA/.qpkg/Qapache /opt/Qapache


Start Qapache service:

Code: Select all

/opt/Qapache/bin/httpd -f /opt/Qapache/etc/httpd.conf -k start


Work again!!!

Hope this also help others if done the same thing as I did. XD

CarpeDiem
Starting out
Posts: 18
Joined: Sun Feb 01, 2009 1:12 am

Re: [ QApache 2.4.23 + PHP 7.0.9 ] WebServer and more

Post by CarpeDiem » Mon Sep 26, 2016 1:11 am

Tout dabord, merci Stéphane !!!
I installed the package and finally a version of apache and php updated on my NAS, FINALLY !
but when I try to connect using https on port 448, nothing, no error, nothing like if the server is actually not listening the port, any idea ?

User avatar
dkorbee
New here
Posts: 3
Joined: Wed Oct 31, 2007 8:22 pm
Location: Netherlands

Re: [ QApache 2.4.23 + PHP 7.0.9 ] WebServer and more

Post by dkorbee » Fri Oct 14, 2016 4:28 pm

I installed the "Apache 2.4.23 + PHP 7.0.10 + PECL Extension" on my TS-653 Pro with firmware v4.2.2 build 20160901
Unfortunately I cannot connect to the Qapache webserver after (re)starting Qapache App.

When I try to start the Qapache service from CLI I get the following error:

[~] # ln -sf /share/CACHEDEV1_DATA/.qpkg/Qapache /opt/Qapache
[~] # /opt/Qapache/bin/httpd -f /opt/Qapache/etc/httpd.conf -k start
/opt/Qapache/bin/httpd: error while loading shared libraries: librt.so.1: wrong ELF class: ELFCLASS32

I think it has something to do with files for the wrong architecture.

I installed the x64 version on my TS-653 Pro, which should be a true x64 system. Or am I wrong?

User avatar
QNAP_Stephane
Experience counts
Posts: 3841
Joined: Wed Mar 27, 2013 1:00 am

Re: [ QApache 2.4.23 + PHP 7.0.9 ] WebServer and more

Post by QNAP_Stephane » Fri Oct 14, 2016 6:08 pm

you wrong, unless you have firmware 4.3 ;)
--------------------------------------------------------------------------
QnapClub AppCenter - https://www.qnapclub.eu
--------------------------------------------------------------------------

iamklaus
New here
Posts: 8
Joined: Fri Jan 13, 2012 9:14 pm

Re: [ QApache 2.4.23 + PHP 7.0.9 ] WebServer and more

Post by iamklaus » Mon Oct 17, 2016 1:24 am

Same problem here! Exact the same messages!

dkorbee wrote:I installed the "Apache 2.4.23 + PHP 7.0.10 + PECL Extension" on my TS-653 Pro with firmware v4.2.2 build 20160901
Unfortunately I cannot connect to the Qapache webserver after (re)starting Qapache App.

When I try to start the Qapache service from CLI I get the following error:

[~] # ln -sf /share/CACHEDEV1_DATA/.qpkg/Qapache /opt/Qapache
[~] # /opt/Qapache/bin/httpd -f /opt/Qapache/etc/httpd.conf -k start
/opt/Qapache/bin/httpd: error while loading shared libraries: librt.so.1: wrong ELF class: ELFCLASS32

I think it has something to do with files for the wrong architecture.

I installed the x64 version on my TS-653 Pro, which should be a true x64 system. Or am I wrong?

User avatar
QNAP_Stephane
Experience counts
Posts: 3841
Joined: Wed Mar 27, 2013 1:00 am

Re: [ QApache 2.4.23 + PHP 7.0.9 ] WebServer and more

Post by QNAP_Stephane » Mon Oct 17, 2016 1:27 am

same problem, same answer ...

;)
--------------------------------------------------------------------------
QnapClub AppCenter - https://www.qnapclub.eu
--------------------------------------------------------------------------

User avatar
dkorbee
New here
Posts: 3
Joined: Wed Oct 31, 2007 8:22 pm
Location: Netherlands

Re: [ QApache 2.4.23 + PHP 7.0.9 ] WebServer and more

Post by dkorbee » Wed Oct 19, 2016 2:58 am

@QNAP_Stephane: So you say that 64 bit capable QNAP NAS like TS-653 PRO will be a TRUE 64 bit system only from QTS firmware 4.3, is that right ?

User avatar
QNAP_Stephane
Experience counts
Posts: 3841
Joined: Wed Mar 27, 2013 1:00 am

Re: [ QApache 2.4.23 + PHP 7.0.9 ] WebServer and more

Post by QNAP_Stephane » Thu Oct 20, 2016 12:54 am

dkorbee wrote:@QNAP_Stephane: So you say that 64 bit capable QNAP NAS like TS-653 PRO will be a TRUE 64 bit system only from QTS firmware 4.3, is that right ?


YES !!! ;)
--------------------------------------------------------------------------
QnapClub AppCenter - https://www.qnapclub.eu
--------------------------------------------------------------------------

DJCMBear
Starting out
Posts: 26
Joined: Mon Apr 14, 2014 3:42 pm

Re: [ QApache 2.4.23 + PHP 7.0.9 ] WebServer and more

Post by DJCMBear » Wed Oct 26, 2016 6:10 pm

I have finally fully switched my server over to Qapache ( thanks for the work you put in to create it ), I noticed there was a mod_http2.so file but wasn't included in the config file, after I included it and setup the correct protocols I don't see my requests being upgraded to h2 or h2c, has http2 been fully added or is that why it wasn't included due to no support currently?
Server: TVS-871-i7-16G 32TB RAID-6 QTS 4.3.3 2017/07/27
Network: ASUS RT-AC5300 5334Mbps internal network with AC wireless (Twin 5Ghz and a 2.4Ghz both with a range of 5,000 square feet), CAT7 ethernet cables with true gigabit ports, 300Mb/s super fast vivid fibre optic with unlimited bandwidth.

User avatar
QNAP_Stephane
Experience counts
Posts: 3841
Joined: Wed Mar 27, 2013 1:00 am

Re: [ QApache 2.4.23 + PHP 7.0.9 ] WebServer and more

Post by QNAP_Stephane » Wed Oct 26, 2016 6:13 pm

mmmm no idea ... dont know how setup this
--------------------------------------------------------------------------
QnapClub AppCenter - https://www.qnapclub.eu
--------------------------------------------------------------------------

DJCMBear
Starting out
Posts: 26
Joined: Mon Apr 14, 2014 3:42 pm

Re: [ QApache 2.4.23 + PHP 7.0.9 ] WebServer and more

Post by DJCMBear » Wed Oct 26, 2016 6:51 pm

QNAP_Stephane wrote:mmmm no idea ... dont know how setup this


I will do some more research into it and see what I come up with, if I do find anything that works I will post back here for a future release, however I am not sure how long it will take, hopefully you come across something yourself when you bring out a new release if I haven't responded in time.
Server: TVS-871-i7-16G 32TB RAID-6 QTS 4.3.3 2017/07/27
Network: ASUS RT-AC5300 5334Mbps internal network with AC wireless (Twin 5Ghz and a 2.4Ghz both with a range of 5,000 square feet), CAT7 ethernet cables with true gigabit ports, 300Mb/s super fast vivid fibre optic with unlimited bandwidth.

DJCMBear
Starting out
Posts: 26
Joined: Mon Apr 14, 2014 3:42 pm

Re: [ QApache 2.4.23 + PHP 7.0.9 ] WebServer and more

Post by DJCMBear » Wed Oct 26, 2016 9:07 pm

I did some research and it turns out in order to get the mod_http2 module to work with apache, the nghttp2 c library needs to be installed ( https://nghttp2.org/ ).

I myself wouldn't know where to begin with qnaps packaging system but if you could find a way to package it with the Qapache package everyone would be able to
convert their web servers to use the http2 protocol over http1.1, would it be possible to get a version of the php 7.0.9 version of the Qapache package with this included?

If this works maybe in all future releases you can include http2 for the modern web, I so can't wait for qnap to publish QTS 4.3 for the consumer so I can start using the 64bit version.
Server: TVS-871-i7-16G 32TB RAID-6 QTS 4.3.3 2017/07/27
Network: ASUS RT-AC5300 5334Mbps internal network with AC wireless (Twin 5Ghz and a 2.4Ghz both with a range of 5,000 square feet), CAT7 ethernet cables with true gigabit ports, 300Mb/s super fast vivid fibre optic with unlimited bandwidth.

User avatar
QNAP_Stephane
Experience counts
Posts: 3841
Joined: Wed Mar 27, 2013 1:00 am

Re: [ QApache 2.4.23 + PHP 7.0.9 ] WebServer and more

Post by QNAP_Stephane » Thu Oct 27, 2016 1:27 am

should be include.. look at the phpinfo() on the Curl module nghttp2 flag is set YES (fox 86 and x64 version)
--------------------------------------------------------------------------
QnapClub AppCenter - https://www.qnapclub.eu
--------------------------------------------------------------------------

DJCMBear
Starting out
Posts: 26
Joined: Mon Apr 14, 2014 3:42 pm

Re: [ QApache 2.4.23 + PHP 7.0.9 ] WebServer and more

Post by DJCMBear » Thu Oct 27, 2016 4:16 am

Can I be cheeky and ask if you could create a qpkg/ipkg/opkg for the v1.16.0 of https://nghttp2.org/ I tried myself on my server and I can't seem to make it work, I went through the configure, make and make install process using gcc and still nothing, If I can get libnghttp2 installed and working on my server, and have Qapache see it is installed I can do the rest myself, I haven't compiled many things on servers without a walkthrough, with a qnap it is much harder due to the busybox restrictions.

I have a TVS-871, not sure if that information is needed at all for you to compile it, that's if you will.
Server: TVS-871-i7-16G 32TB RAID-6 QTS 4.3.3 2017/07/27
Network: ASUS RT-AC5300 5334Mbps internal network with AC wireless (Twin 5Ghz and a 2.4Ghz both with a range of 5,000 square feet), CAT7 ethernet cables with true gigabit ports, 300Mb/s super fast vivid fibre optic with unlimited bandwidth.

Post Reply

Return to “Community Apps”