Page 1 of 50

[ QApache 2.4.39 + PHP 7.2.29 ] WebServer with PHP and PECL

Posted: Mon May 18, 2015 12:12 am
by QNAP_Stephane
Source : http://httpd.apache.org/ - http://php.net/ - http://pecl.php.net/


Download :

[ Apache 2.4.39 + PHP 7.2.21 + PECL Extension ] x64, arm-x41, arm64

due to new design in Apache 2.4.33 (remove previous Qapache install as prior and update from repo new qpkg version using Qapache as dependency)

https://qnapclub.eu/fr/qpkg/268

Known issue :

for unknown reason mod_ssl avoid Qapache Starting on x73 series

Note :

Manage in my own Webui (dont forget to restart application to make change apply )
backup your current config before update
  • httpd.conf
  • SSL.conf
  • php.ini
  • error.log
HTTP = port 88
HTTPS = port 448

Host your website in your htdocs share

added :

Mod.svn (subversion)
Mod.security2
Mod_Mono (Beta)
Mod_Python
Mod_WSGY

Also include in this package (/opt/Qapache/bin )

Code: Select all

NodeJS v12
Ruby 2.2.1
Git 2.4.3
Dovecot
Subversion 1.8.13
ImageMagick 6.9.1
Coreutil
Propc
util linux 2.22
e2fsprog

Re: [ QApache 2.4.x + PHP 5.6.x ] WebServer and more

Posted: Mon Jun 15, 2015 7:19 pm
by QNAP_Stephane

Code: Select all

php updated to 5.6.10
Sqlite updated to 3.10.8
nmap added
Go added (experimental)
OpenSSL updated to 1.0.2c
Git Updated to 2.4.3

Re: [ QApache 2.4.12 + PHP 5.6.10 ] WebServer and more

Posted: Fri Oct 09, 2015 1:39 am
by BigMacBen
Does this QPKG also work with QTS 4.2 final?

Re: [ QApache 2.4.12 + PHP 5.6.10 ] WebServer and more

Posted: Sun Dec 20, 2015 7:37 pm
by CylonCenturion
QNAP_Stephane wrote:Image
Source : http://httpd.apache.org/ - http://php.net/ - http://pecl.php.net/

Download :

[ Apache 2.4.12 + PHP 5.6.9 + PECL Extension ]

x86 version : http://www.positiv-it.fr/QNAP/APP/Qapache_2.4.12-php569_x86.qpkg.zip

[ Apache 2.4.12 + PHP 5.6.10 + PECL Extension ]

x86 version : http://www.positiv-it.fr/QNAP/APP/Qapache_2.4.12.1-php5610_x86.qpkg.zip

Note :

Before installing

Create a share called "htdocs"

Manage in my own Webui (dont forget to restart application to make change apply )

  • httpd.conf
  • SSL.conf
  • php.ini
  • error.log

HTTP = port 88
HTTPS = port 448

Host your website in your htdocs share

added :

Mod.svn (subversion)
Mod.security2
Mod_Mono (Beta)
Mod_Python
Mod_WSGY

Also include in this package (/opt/Qapache/bin )

Code: Select all

NodeJS v12
Ruby 2.2.1
Git 2.4.3
Dovecot
Subversion 1.8.13
ImageMagick 6.9.1
Coreutil
Propc
util linux 2.22
e2fsprog



PHP INFO PREVIEW : http://www.positiv-it.fr/QNAP/PAGE/php569.htm


Is this save to install on a TS-253 Pro 8Gb FW 4.2.0 B1118?
And is this a replacement for all services?

Re: [ QApache 2.4.12 + PHP 5.6.10 ] WebServer and more

Posted: Sun Dec 20, 2015 9:23 pm
by QNAP_Stephane
it will work, but run aside all services

it uses his own process

Re: [ QApache 2.4.12 + PHP 5.6.10 ] WebServer and more

Posted: Wed Feb 03, 2016 1:11 am
by wtsming
I downloaded the qpkg but failed to install through App Center GUI, it just show error

The following items could not be installed. Please see the system logs for more details.
- Qapache_2.4.12.1-php5610_x86.qpkg.zip

My QNAP is TS-251, QTS 4.2.0 public version, anything wrong with me?

Re: [ QApache 2.4.12 + PHP 5.6.10 ] WebServer and more

Posted: Wed Feb 03, 2016 1:13 am
by QNAP_Stephane
wtsming wrote:I downloaded the qpkg but failed to install through App Center GUI, it just show error

The following items could not be installed. Please see the system logs for more details.
- Qapache_2.4.12.1-php5610_x86.qpkg.zip

My QNAP is TS-251, QTS 4.2.0 public version, anything wrong with me?


unzip it first

Re: [ QApache 2.4.12 + PHP 5.6.10 ] WebServer and more

Posted: Wed Feb 03, 2016 1:25 am
by wtsming
It's working, thanks a lot.

Re: [ QApache 2.4.12 + PHP 5.6.10 ] WebServer and more

Posted: Wed Feb 03, 2016 10:17 pm
by wtsming
Can I still use the apache to connect MySQL server of QNAP ?

Re: [ QApache 2.4.12 + PHP 5.6.10 ] WebServer and more

Posted: Wed Feb 03, 2016 11:46 pm
by QNAP_Stephane
wtsming wrote:Can I still use the apache to connect MySQL server of QNAP ?


yes

Re: [ QApache 2.4.12 + PHP 5.6.10 ] WebServer and more

Posted: Sun Mar 13, 2016 6:41 pm
by Kodauk
your package looks perfect for me! Do you provide a ARM-Version too? thx

Re: [ QApache 2.4.12 + PHP 5.6.10 ] WebServer and more

Posted: Mon Mar 14, 2016 1:42 am
by QNAP_Stephane
ArmV7 , may be feasible with pain

Re: [ QApache 2.4.12 + PHP 5.6.10 ] WebServer and more

Posted: Tue Mar 22, 2016 8:44 pm
by BigMacBen
Is there an update planned to 2.4.18 with PHP 7? That would be great =)

Re: [ QApache 2.4.12 + PHP 5.6.10 ] WebServer and more

Posted: Wed Mar 23, 2016 7:35 pm
by Kodauk
QNAP_Stephane wrote:ArmV7 , may be feasible with pain


wow ArmV7 would be great! Maybe you can give it a try with the next update :) ?

Re: [ QApache 2.4.12 + PHP 5.6.10 ] WebServer and more

Posted: Wed Mar 23, 2016 8:37 pm
by QNAP_Stephane
BigMacBen wrote:Is there an update planned to 2.4.18 with PHP 7? That would be great =)


not sure last time i had issue upgrading Apache core (may be due to glibc in the toolchain), but php should be upgradable, even if i should move some extensions due to directory change

for armV7, i need a lot of time to do it ... a real pain