[Com. QPKG kodi 2-16.1.1 ALL PVR / Visu / audio] for HD_Station 3.1+

This is the best place for community developers to publish their genius work. Your Apps enrich the QNAP Turbo NAS.
Locked
drew_sav
New here
Posts: 7
Joined: Fri Oct 22, 2010 11:36 am

Re: [Com. QPKG kodi 16.1 ALL PVR] REVIVAL for HD_Station 3.1

Post by drew_sav » Sun Mar 20, 2016 10:13 am

Awesome; just what I was looking for. Installed and working on a QNAP TS-470 Pro using the DVBLink PVR plugin.

Very much appreciated, thanks.

zyb3ks
New here
Posts: 2
Joined: Sun Mar 27, 2016 7:16 am

Re: [Com. QPKG kodi 16.1 ALL PVR] REVIVAL for HD_Station 3.1

Post by zyb3ks » Sun Mar 27, 2016 7:34 am

Hi,
Why PVR IPTV simple client (from PVR add-ons) does not correctly work with this kodi? TV stream (rtmp://) not work (m3u list). Can you fix it?
Thx :)

Mfudge
Starting out
Posts: 11
Joined: Mon Mar 28, 2016 9:53 am

Re: [Com. QPKG kodi 1-16.1 ALL PVR / Visu] for HD_Station 3.1 + libs

Post by Mfudge » Tue Mar 29, 2016 3:00 am

Quick question, I figured out how to download and install it on my tvs-463 but it wont launch.

Im not familier enough with linux to track down the problem, the 15.2 that came with it opened fine.

Regards,

Matthew

zyb3ks
New here
Posts: 2
Joined: Sun Mar 27, 2016 7:16 am

Re: [Com. QPKG kodi 1-16.1 ALL PVR / Visu] for HD_Station 3.1 + libs

Post by zyb3ks » Wed Mar 30, 2016 2:18 am

father_mande wrote:
... include some libraries (not dependent) libCEC, librtmp, etc.

Philippe.


Thank You. It's worsk. Many many many thanks bro :)

Mfudge
Starting out
Posts: 11
Joined: Mon Mar 28, 2016 9:53 am

Re: [Com. QPKG kodi 1-16.1 ALL PVR / Visu] for HD_Station 3.1 + libs

Post by Mfudge » Wed Mar 30, 2016 4:18 am

Philippe

It does not start (wheel spins then stops and goes back to standard pointer)

I disabled it, waited and then re-enabled, but that did not fix the problem, it still won't open.

I installed the 1-16.1 file, should I try the other one?

Regards,

Matthew

Mfudge
Starting out
Posts: 11
Joined: Mon Mar 28, 2016 9:53 am

Re: [Com. QPKG kodi 1-16.1 ALL PVR / Visu] for HD_Station 3.1 + libs

Post by Mfudge » Thu Mar 31, 2016 8:37 am

I tried the other version and it does the same thing.

How do I check for the kodi log, can I go through the regular file manager?

Regards,

Matthew

User avatar
Lionheart74
Know my way around
Posts: 158
Joined: Fri Oct 24, 2014 7:13 pm
Location: Dreis-Tiefenbach, North Rhine-Westphalia, Germany

Re: [Com. QPKG kodi 1-16.1 ALL PVR / Visu] for HD_Station 3.1 + libs

Post by Lionheart74 » Thu Mar 31, 2016 3:12 pm

Mfudge wrote:How do I check for the kodi log, can I go through the regular file manager?


If the standard filemanager fails, you can use a comfortable tool like WinSCP to manage files.
Cheers, Lionheart
Located Dreis-Tiefenbach, North Rhine-Westphalia, Germany
QNAP TS-470 PRO | 9 GB RAM | 4 x HGST HDN724040ALE640 (RAID5) | 10.89 TB (net) Storage Pool | FW: QTS 4.3.6.1040 build 20190820 | Windows 10 version 1903 64 bit

Mfudge
Starting out
Posts: 11
Joined: Mon Mar 28, 2016 9:53 am

Re: [Com. QPKG kodi 1-16.1 ALL PVR / Visu] for HD_Station 3.1 + libs

Post by Mfudge » Fri Apr 01, 2016 1:18 am

OK, there is no .kodi folder.

I do see other hidden folders, .qsync and .oracle.jre.usage

Regards,

Matthew

Mfudge
Starting out
Posts: 11
Joined: Mon Mar 28, 2016 9:53 am

Re: [Com. QPKG kodi 1-16.1 ALL PVR / Visu] for HD_Station 3.1 + libs

Post by Mfudge » Fri Apr 01, 2016 4:58 am

No problem, I'll use the 15.2 for now until QNAP sorts it out or someone else does.

I'll open a ticket with them.

Thanks for your help.

Regards,

Matthew

Mfudge
Starting out
Posts: 11
Joined: Mon Mar 28, 2016 9:53 am

Re: [Com. QPKG kodi 1-16.1 ALL PVR / Visu] for HD_Station 3.1 + libs

Post by Mfudge » Sat Apr 02, 2016 10:53 am

Got my reply from QNAP tech support:

"The current official Kodi version is 15.2. I've tried installing a version off of the QNAP forums. It appears there are some libraries missing which is why the Kodi is not starting. This may be because it was not built on the x63 series (AMD) which may be different. You will need to contact the developer and ask him if he can fix it."

I'm not asking you to fix it, just passing along what they said/

Thanks for your help.

Regards,

Matthew

Holako123
First post
Posts: 1
Joined: Sat May 02, 2015 3:09 am

Re: [Com. QPKG kodi 1-16.1 ALL PVR / Visu] for HD_Station 3.1 + libs

Post by Holako123 » Sat Apr 30, 2016 5:30 am

Thank you very very much, it worked on my Hs-251. I don't have Linux Station on my NAS but your QPKG is what I was looking for. Great to have people like you in this forum. Glad that my first post here is to thank you for your work :)

juanca2000
Starting out
Posts: 37
Joined: Mon Jun 28, 2010 7:13 pm

Re: [Com. QPKG kodi 1-16.1 ALL PVR / Visu] for HD_Station 3.1 + libs

Post by juanca2000 » Sat Apr 30, 2016 5:11 pm

Hello

1000x thanks again for this updated version of Kodi. I know you believe more in another option but for me is the only option as I need a specific addon ( VU / Enigma ). Thanks again

I have a small question on the window mode or reduce window size mode. In other versions of Kodi you can go on small window mode (=not full screen mode) by typing on (£ or $ ) key. It seems not to work here.
I tried in the official version from qnap when i first installed long time ago and was working.

Starting Kodi is a bit heavy with the addon as he will start refreshing EPG each time while in reduced window mode (HD station multitasking) you can switch to another application like Chrome for a short moment and come back to Kodi without the pain of restarting again kodi.

Is it possible to include that feature or can anyone tell me what to do, may be it is there but I can see it...

Thanks for your help

juanca2000
Starting out
Posts: 37
Joined: Mon Jun 28, 2010 7:13 pm

Re: [Com. QPKG kodi 1-16.1 ALL PVR / Visu] for HD_Station 3.1 + libs

Post by juanca2000 » Sat Apr 30, 2016 11:23 pm

don t know what to say .. except THANKS A LOT.. it did work !!!!!

this HD station is better every day :-)

User avatar
oyvindo
Experience counts
Posts: 1145
Joined: Tue May 19, 2009 2:08 am
Location: Norway, Oslo

Re: [Com. QPKG kodi 1-16.1 ALL PVR / Visu] for HD_Station 3.1 + libs

Post by oyvindo » Mon May 02, 2016 12:11 am

Hi Philippe,
When launching YourKodi, it says "Remote Communication Server Failed to start"
Otherwise, all is good.
What should I do to fix that ?
ImageImageImageImage

User avatar
oyvindo
Experience counts
Posts: 1145
Joined: Tue May 19, 2009 2:08 am
Location: Norway, Oslo

Re: [Com. QPKG kodi 1-16.1 ALL PVR / Visu] for HD_Station 3.1 + libs

Post by oyvindo » Mon May 02, 2016 6:08 am

father_mande wrote:Hi,
oyvindo wrote:Hi Philippe,
When launching YourKodi, it says "Remote Communication Server Failed to start"


This error generally indicate that a network tcpip port used by kodi (for ex. for html connect) is already in use in your system.
Please check in the log (user home .kodi/temp/ ) for the exact reason and port.
Check the port use (netstat -lp) with the netstat of Entware not the truncated busybox version provide)
Philippe.


Hi and thanks,
This is what found in the log:

Code: Select all

ERROR: JSONRPC Server: Failed to bind ipv4 serversocket

I believe this has to do with port 9090 which is the CLI port of Logitech Media Server (LMS).
If I stop LMS , then the error goes away.
Kodi 16 has an advancedsettings.xml file here: /share/CACHEDEV1_DATA/.qpkg/KODI/root/.kodi/userdata
By inserting these lines, the problem was solved in both Kodi 15 and 16:

Code: Select all

 <jsonrpc>
       <compactoutput>false</compactoutput>
       <tcpport>9091</tcpport>
 </jsonrpc>
 

But I cannot find that xml file anywhere in YourKodi....
ImageImageImageImage

Locked

Return to “Community Apps”