Kodi17 qpkg

This is the best place for community developers to publish their genius work. Your Apps enrich the QNAP Turbo NAS.
Post Reply
sepilko
New here
Posts: 3
Joined: Mon Jul 10, 2017 3:18 am

Re: Kodi17 qpkg

Post by sepilko » Mon Jul 10, 2017 4:03 am

Good day I have this NAS TS-253B.And I would like to install KODI 17.3 from this site

https://www.qnapclub.eu/index.php?act=d ... pkg_id=405


I have a question

1.In addition to the installation, do you need to set something else? Or does everything work as automatic? Does it work without problems?Do i need to set something up? Server, etc??

So I ask because I found this video.

How to SETUP and KODI SERVER
https://www.youtube.com/watch?v=x0LdjM5ToFA


Do I have to set this up? That KODI works?.

Thank you for your response.
Sorry for my EN google translate

User avatar
Moogle Stiltzkin
Ask me anything
Posts: 8322
Joined: Thu Dec 04, 2008 12:21 am
Location: Around the world....
Contact:

Re: Kodi17 qpkg

Post by Moogle Stiltzkin » Mon Jul 10, 2017 10:20 am

sepilko wrote:So I ask because I found this video.

How to SETUP and KODI SERVER
https://www.youtube.com/watch?v=x0LdjM5ToFA


Do I have to set this up? That KODI works?.

Thank you for your response.
Sorry for my EN google translate


how do you get kodi on a qnap nas.?


Hi Nicolas, if you mean the app so that you can connect the Qnap to the tv directly, you will need to go to the app center on the NAS dashboard and install it from the list there.
RJ


i was going to update that portion in my FAQ to a different video, cause running Kodi for playback direct from qnap is a different process. I think the youtube setup is merely for synchronization purposes only for database maintenance, between other devices running Kodi.

try this
viewtopic.php?f=45&t=133965&p=625393#p625393
NAS
[Main Server] QNAP TS-877 w. 4tb [ 3x HGST Deskstar NAS (HDN724040ALE640) & 1x WD RED NAS ] EXT4 Raid5 & 2 x m.2 SATA Samsung 850 Evo raid1 + 16gb ddr4 Crucial + QWA-AC2600 wireless adapter.
[Backup] QNAP TS-653A w. 5x 2TB Samsung F3 (HD203WI) EXT4 Raid5
[^] QNAP TS-659 Pro II 1x 4TB HGST Deskstar NAS
[^] QNAP TS-509 Pro w. 4x 1TB WD RE3 (WD1002FBYS) EXT4 Raid5
[^] QNAP TS-228 w. 1x 1TB WD RE3 (WD1002FBYS)
[^] QNAP TS-128
Mobile NAS TBS-453DX w. 2x Crucial MX500 500gb EXT4 raid1

Network
Asus AC68U Router|100dl/50ul MBPS FTTH Internet | Windows 10, WC PC-Intel i7 920 Ivy bridge desktop (1x 512gb Samsung 850 Pro SSD + 1x 4tb HGST Ultrastar 7K4000)


Guides & articles
[Review] Moogle's QNAP experience
[Review] Moogle's TS-877 review

https://www.patreon.com/mooglestiltzkin

sepilko
New here
Posts: 3
Joined: Mon Jul 10, 2017 3:18 am

Re: Kodi17 qpkg

Post by sepilko » Tue Jul 11, 2017 4:07 am

I'm sorry but I did not ask how. Because of course I know.

https://www.qnapclub.eu/index.php?act=howto

Did I ask or does it work without any further adjustment?.So I ask if there is a need for another KODI setting.The NAS TS-253B is not yet purchased.And official KODI support is NOT.Just install it and that's it?

jazacoop
Starting out
Posts: 12
Joined: Tue Oct 26, 2010 3:20 pm

Re: Kodi17 qpkg

Post by jazacoop » Sun Jan 14, 2018 10:50 pm

pmcdunnough wrote:
Trexx wrote:Can you post a screenshot of your user permissions from phpmyadmin?


Whoops, just saw this. In any case I used your link to Kodi 17.3 and now everything works great. In particular, MySQL works. So something must have changed in 17.3 as previous versions just wouldn't make use of MySQL. I did nothing different so ...

Thanks


Hi pmcdunnough,

Is mySQL syncing still working for you? I purchased a TS-653B and installed Kodi 17.17.6 and have not been able to get syncing working. I append the sql parameters to the end of the advancedsettings.xml file and copy it into the qnap folder however it doesn't appear to be writing to the SQL database. As a result, I am unable to add libraries or use Kodi when pointing to the SQL server.

After looking online, I discovered you had the exact same problem I am having. It looks like you resolved your issue by installing 17.3. I would have hoped that since 17.17.6 is newer it would have worked.

Do you have any pointers/updates you can share?

pmcdunnough
Starting out
Posts: 48
Joined: Sat Mar 26, 2016 3:09 pm

Re: Kodi17 qpkg

Post by pmcdunnough » Mon Jan 15, 2018 2:29 am

Hi jazacoop,

I did resolve it by installing 17.3.1. Unfortunately, the build that used really dictates whether or not mysql works. Consequently I don’t upgrade Kodi unless I have to. In this instance newer is not necessarily better... Just maybe you should try another build. It’s a real pain as there’s no easy way to know if it will work.
philip

TS-251+ w 8gigs

jazacoop
Starting out
Posts: 12
Joined: Tue Oct 26, 2010 3:20 pm

Re: Kodi17 qpkg

Post by jazacoop » Mon Jan 15, 2018 5:55 am

pmcdunnough wrote:Hi jazacoop,

I did resolve it by installing 17.3.1. Unfortunately, the build that used really dictates whether or not mysql works. Consequently I don’t upgrade Kodi unless I have to. In this instance newer is not necessarily better... Just maybe you should try another build. It’s a real pain as there’s no easy way to know if it will work.


Thanks!

Do you happen to have a link to the build that you used?

jazacoop
Starting out
Posts: 12
Joined: Tue Oct 26, 2010 3:20 pm

Re: Kodi17 qpkg

Post by jazacoop » Mon Jan 15, 2018 7:44 pm

I solved it!

It wasn't build related but an issue with authenticating with mysql. Turns out when specifying the hostname and setting it to all hostnames (hostname %) that Kodi wasn't able to authenticate with the server. What I ended up doing in essence was creating two kodi accounts, one with all hostnames (which should work on all other devices) and a second which specifically lists the NAS server name (in my case server2). See below screenshot:

Image

It literally worked instantly after making this change. Hope this helps someone else because I literally spent hours getting to the bottom of this.

Post Reply

Return to “Community Apps”