[SCRIPT] sherpa.sh

This is the best place for community developers to publish their genius work. Your Apps enrich the QNAP Turbo NAS.
Post Reply
User avatar
OneCD
Ask me anything
Posts: 7156
Joined: Sun Aug 21, 2016 10:48 am
Location: "... there, behind that sofa!"

Re: [SCRIPT] Sherpa

Post by OneCD » Sat May 20, 2017 1:51 pm

Major update: (2017.05.20)

  • Finally got my own SABnzbd QPKG together! This one doesn't need to be patched because it's written to work as-is. Thankfully, no more of that linking to different arch utilities. ;)

    It's available via the instructions in the first post in this thread. As before, it can be used for re-installs of existing SABs.

ImageImageImageImageImageImageImageImageImageImageImageImageImageImageImageImageImage

User avatar
dirkonline
Know my way around
Posts: 244
Joined: Mon Oct 18, 2010 4:08 pm

Re: [SCRIPT] Sherpa

Post by dirkonline » Sat May 20, 2017 4:08 pm

Cheers!
I just performed the switch to your QPKG:

Code: Select all

cd /share/Public
[/share/Public] # ls
@Recycle/             SickRage@             sherpa.sh*
CouchPotato2@         autoProcessMedia.cfg  sherpa.tar.gz
SABnzbdplus@          sherpa.debug.log      sherpa.tmp/
[/share/Public] # rm -r sherpa.tmp/
[/share/Public] # /usr/bin/wget https://goo.gl/Qot9QK -qO sherpa.tar.gz && tar -zxvf sherpa.tar.gz
sherpa.sh
SABnzbdplus
SickRage
CouchPotato2
[/share/Public] # ./SABnzbdplus
sherpa.sh (2017.05.20b)

[ done ] downloaded QPKG (SABnzbdplus_170520.qpkg)
[ done ] updated 'Entware'
[ done ] downloaded & installed IPKs (various)
[ done ] downloaded & installed IPK (python-dev)
[ done ] installed (pip modules)
[ done ] daemon stopped (sabnzbd.sh)
[ done ] created SABnzbd settings backup
[ done ] uninstalled QPKG 'SABnzbdplus'
[ done ] installed QPKG (SABnzbdplus_170520.qpkg)
[ done ] daemon stopped (sabnzbd.sh)
[ done ] restored SABnzbd settings backup
[ done ] daemon started (sabnzbd.sh)

[ done ] SABnzbdplus has been successfully reinstalled!

[/share/Public] # /etc/init.d/sabnzbd.sh restart
(SABnzbdplus) is active
Stopping (SABnzbdplus) with SIGTERM: waiting for up to 60 seconds: 1, OK
(SABnzbdplus) is not active


Tried a restart:

Code: Select all

Install QNAP package on TS-NAS...
14+1 records in
14+1 records out
./
./built_info
./qinstall.sh
./package_routines
./qpkg.cfg
0+1 records in
0+1 records out
16+1 records in
16+1 records out
Firmware check is fine.
Link service start/stop script: sabnzbd.sh
Set QPKG information in /etc/config/qpkg.conf
(SABnzbdplus) is not active
Updating (SABnzbdplus): OK
Starting (SABnzbdplus): OK
[App Center] SABnzbdplus 170520 has been installed in /share/CACHEDEV1_DATA/.qpkg/SABnzbdplus successfully.
[App Center] SABnzbdplus enabled.
result=[10]



So, I am correct in assuming that this will also update itself when restarting? I mean it looks just fine, no error messages at least. Is it still checking GIT and compiling itself based on the master branch? :)
(I had a look at the install log as you can see but it seems to be less verbose than the previous version so I cannot see what happens.)

User avatar
OneCD
Ask me anything
Posts: 7156
Joined: Sun Aug 21, 2016 10:48 am
Location: "... there, behind that sofa!"

Re: [SCRIPT] Sherpa

Post by OneCD » Sat May 20, 2017 5:21 pm

dirkonline wrote:So, I am correct in assuming that this will also update itself when restarting? I mean it looks just fine, no error messages at least. Is it still checking GIT and compiling itself based on the master branch? :)

Hey dirk. Great - that all looks as expected. :)

Yep, still updates when you start or restart via the init script.

dirkonline wrote:(I had a look at the install log as you can see but it seems to be less verbose than the previous version so I cannot see what happens.)

It is less verbose as it now stores all those startup messages in [/var/log/SABnzbdplus.log]

That log is a bit of a visual shambles at the moment. I'm going to tackle that in the morning. Ran out of time today.

To check which branch you're on:

Code: Select all

cd $(getcfg SABnzbdplus Install_Path -f /etc/config/qpkg.conf)/SABnzbdplus && git branch

and you should see:

Code: Select all

  develop
* master

The one with the asterix is the current branch.

ImageImageImageImageImageImageImageImageImageImageImageImageImageImageImageImageImage

User avatar
dirkonline
Know my way around
Posts: 244
Joined: Mon Oct 18, 2010 4:08 pm

Re: [SCRIPT] Sherpa

Post by dirkonline » Sat May 20, 2017 5:27 pm

Thanks!
I wonder, what do you think about compiling a list of common things to do in the CLI like you just showed me on your GIT Wiki page? It would be a nice addition. I would gladly assist you in this.

and yes, master branch all is well :)

User avatar
dirkonline
Know my way around
Posts: 244
Joined: Mon Oct 18, 2010 4:08 pm

Re: [SCRIPT] Sherpa

Post by dirkonline » Sat May 20, 2017 6:00 pm

btw. Does your current QPKG include sabyenc for my architecture as well?

User avatar
OneCD
Ask me anything
Posts: 7156
Joined: Sun Aug 21, 2016 10:48 am
Location: "... there, behind that sofa!"

Re: [SCRIPT] Sherpa

Post by OneCD » Sun May 21, 2017 8:09 am

dirkonline wrote:I wonder, what do you think about compiling a list of common things to do in the CLI like you just showed me on your GIT Wiki page? It would be a nice addition. I would gladly assist you in this.

Thank you for your kind offer. I hadn't considered adding a wiki page as this script is meant to provide an automated installation. And wikis (much like the average NAS user-manual) are never updated as often as they should be. ;)

The steps above that show the git branch may only be of interest presently because everyone was switched to the 'develop' branch last year.

dirkonline wrote:btw. Does your current QPKG include sabyenc for my architecture as well?

Yes, it's there. But it's installed via Entware and SABnzbd searches for it on startup. It should be visible in your SAB startup log.

ImageImageImageImageImageImageImageImageImageImageImageImageImageImageImageImageImage

User avatar
dirkonline
Know my way around
Posts: 244
Joined: Mon Oct 18, 2010 4:08 pm

Re: [SCRIPT] Sherpa

Post by dirkonline » Sun May 21, 2017 3:16 pm

Thanks :)
Just a heads up, the startup log is just as sparse as what is shown via SSH

in [/var/log/SABnzbdplus.log]


Code: Select all

-------------------- stop requested --------------------
Sat May 20 10:04:55 CEST 2017
(SABnzbdplus) is active
Stopping (SABnzbdplus) with SIGTERM: stopped OK in 1 seconds
-------------------- start requested --------------------
Sat May 20 10:04:56 CEST 2017
(SABnzbdplus) is not active
Updating (SABnzbdplus): -------------------- stdout start --------------------
Already on 'master'
Your branch is up-to-date with 'origin/master'.
Already up-to-date.
-------------------- stdout end --------------------
OK
Starting (SABnzbdplus): -------------------- stdout start --------------------

-------------------- stdout end --------------------
OK


So I cannot check if SABYenc v3.0.2 is working as intended (seriously why did they remove that from the GUI?)

User avatar
OneCD
Ask me anything
Posts: 7156
Joined: Sun Aug 21, 2016 10:48 am
Location: "... there, behind that sofa!"

Re: [SCRIPT] Sherpa

Post by OneCD » Sun May 21, 2017 3:21 pm

Ah, sorry - I meant the SAB log that is downloadable via the SAB GUI. ;)

There's a button labeled 'Show Logging'.

ImageImageImageImageImageImageImageImageImageImageImageImageImageImageImageImageImage

User avatar
dirkonline
Know my way around
Posts: 244
Joined: Mon Oct 18, 2010 4:08 pm

Re: [SCRIPT] Sherpa

Post by dirkonline » Sun May 21, 2017 4:29 pm

hah! that was too easy. I was actually thinking about that but you know, since we were mucking around in the logs directly :p All is good. I think I am going to hop over to the SAB forum and ask whether things like that will show up in the GUI again like they used to and still do with other things.

Wildefadenas
Starting out
Posts: 26
Joined: Mon Jul 07, 2008 6:14 pm

Re: [SCRIPT] Sherpa

Post by Wildefadenas » Wed May 24, 2017 10:37 pm

Nice. Works perfect.

User avatar
dirkonline
Know my way around
Posts: 244
Joined: Mon Oct 18, 2010 4:08 pm

Re: [SCRIPT] Sherpa

Post by dirkonline » Thu May 25, 2017 4:05 pm

Good morning @OneCD

Soo I restarted my NAS this morning because I wanted to finally go to qnap 4.3x and SAB upgraded itself to 2.0.1
now I get the warning "SABnzbd was started with encoding ANSI_X3.4-1968, this should be UTF-8. Expect problems with Unicoded file and directory names in downloads."

Any idea where that suddenly comes from? I am a bit baffled really.
Changes since 2.0.0
- No longer change ports if the configured port is not available during startup.
- 'Proof' files also ignored when Ignore Samples is enabled.
- Redundant SFV and RAR checks no longer performed if par2 verification failed.
- More repair/unpack info is retained in the History information.
- Windows: remove option to start SABnzbd from installer, it would start the
program as administrator.

Bugfixes since 2.0.0
- Some users experienced slower download speeds.
- Revert changes to handling of missing articles introduced in 2.0.0 that
turned out to be slow for some users.
- Missing first par2-file would cause repair to be skipped.
- Better handling of 7zip unpacking.
- Log X-Forwarded-For of API calls and logins.
- Handle more URLGrabber exceptions.
- Command-line parameters were not listed correctly.
- Queue-finish-action picker in Glitter more stable.
- Custom Pause interpreter in Glitter more reliable.
- Pre-check would fail if download was on SMBv3 share.
- Windows: NZB-icon association lost sometimes.
- Windows: Unrar could fail on some archives containing very long paths.

## Upgrading from 0.7.x and older
- Finish queue
- Stop SABnzbd
- Install new version
- Start SABnzbd

## Upgrade notices
- Windows: When starting the Post-Processing script, the path to the job folder
is no longer in short-path notation but includes the full path. To support
long paths (>255), you might need to alter them to long-path notation (\\?\).
- Schedule items are converted when upgrading to 2.x.x and will break when
reverted back to pre-2.x.x releases.
- The organization of the download queue is different from 0.7.x releases.
So 2.x.x will not see the existing queue, but you can go to Status->Queue Repair
and "Repair" the old queue.


For the record my language setting in QNAP-General is set to English. I could change it to Western but I am I was under the assumption, that QNAP always works with UTF-8 in the background.

Code: Select all

[~] # cd $(getcfg SABnzbdplus Install_Path -f /etc/config/qpkg.conf)/SABnzbdplus && git branch
  develop
* master
[/share/CACHEDEV1_DATA/.qpkg/SABnzbdplus/SABnzbdplus] # locale
LANG=en_US.UTF-8
LANGUAGE=
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=en_US.UTF-8
[/share/CACHEDEV1_DATA/.qpkg/SABnzbdplus/SABnzbdplus] #



It seems that SAB does not start with the proper locale. Is there a way for you to enforce UTF-8 with your start script on QNAP OS?

User avatar
OneCD
Ask me anything
Posts: 7156
Joined: Sun Aug 21, 2016 10:48 am
Location: "... there, behind that sofa!"

Re: [SCRIPT] Sherpa

Post by OneCD » Thu May 25, 2017 4:36 pm

Hey Dirk. Good find. ;)

I've not seen this error myself but there seems to be a report of it here: https://forums.sabnzbd.org/viewtopic.php?f=11&t=22483

Can you please check your SAB GUI startup log? When viewing it in your text viewer/editor, please check for a couple of things:
OneCD wrote:2017-05-25 18:13:37,332::INFO::[SABnzbd:1167] --------------------------------
2017-05-25 18:13:37,333::INFO::[SABnzbd:1168] SABnzbd.py-2.0.1 (rev=<HASH>29248ee603e6bf1)
2017-05-25 18:13:37,334::INFO::[SABnzbd:1169] Full executable path = /share/MD0_DATA/.qpkg/SABnzbdplus/SABnzbdplus/SABnzbd.py
2017-05-25 18:13:37,334::INFO::[SABnzbd:1181] Platform = posix
2017-05-25 18:13:37,335::INFO::[SABnzbd:1182] Python-version = 2.7.13 (default, Apr 24 2017, 15:51:42)
[GCC 6.3.0]
2017-05-25 18:13:37,335::INFO::[SABnzbd:1183] Arguments = SABnzbd.py --daemon --browser 0 --config-file /share/MD0_DATA/.qpkg/SABnzbdplus/config/config.ini --pidfile /tmp/SABnzbdplus.pid
2017-05-25 18:13:37,336::INFO::[SABnzbd:1188] Preferred encoding = UTF-8
2017-05-25 18:13:37,337::INFO::[SABnzbd:1229] Read INI file /share/MD0_DATA/.qpkg/SABnzbdplus/config/config.ini

... and in the settings section at the bottom:
OneCD wrote:__version__ = 19
__encoding__ = utf-8
[misc]

ImageImageImageImageImageImageImageImageImageImageImageImageImageImageImageImageImage

User avatar
dirkonline
Know my way around
Posts: 244
Joined: Mon Oct 18, 2010 4:08 pm

Re: [SCRIPT] Sherpa

Post by dirkonline » Thu May 25, 2017 4:55 pm

OneCD wrote:Hey Dirk. Good find. ;)

I've not seen this error myself but there seems to be a report of it here: https://forums.sabnzbd.org/viewtopic.php?f=11&t=22483

Can you please check your SAB GUI startup log? When viewing it in your text viewer/editor, please check for a couple of things:
OneCD wrote:2017-05-25 18:13:37,332::INFO::[SABnzbd:1167] --------------------------------
2017-05-25 18:13:37,333::INFO::[SABnzbd:1168] SABnzbd.py-2.0.1 (rev=<HASH>29248ee603e6bf1)
2017-05-25 18:13:37,334::INFO::[SABnzbd:1169] Full executable path = /share/MD0_DATA/.qpkg/SABnzbdplus/SABnzbdplus/SABnzbd.py
2017-05-25 18:13:37,334::INFO::[SABnzbd:1181] Platform = posix
2017-05-25 18:13:37,335::INFO::[SABnzbd:1182] Python-version = 2.7.13 (default, Apr 24 2017, 15:51:42)
[GCC 6.3.0]
2017-05-25 18:13:37,335::INFO::[SABnzbd:1183] Arguments = SABnzbd.py --daemon --browser 0 --config-file /share/MD0_DATA/.qpkg/SABnzbdplus/config/config.ini --pidfile /tmp/SABnzbdplus.pid
2017-05-25 18:13:37,336::INFO::[SABnzbd:1188] Preferred encoding = UTF-8
2017-05-25 18:13:37,337::INFO::[SABnzbd:1229] Read INI file /share/MD0_DATA/.qpkg/SABnzbdplus/config/config.ini

... and in the settings section at the bottom:
OneCD wrote:__version__ = 19
__encoding__ = utf-8
[misc]



Well then, let me have a look (mind you, this just might have been QNAP having a hickup)

Startup log:

Code: Select all

2017-05-25 10:48:51,196::INFO::[SABnzbd:1168] SABnzbd.py-2.0.1 (rev=<HASH>29248ee603e6bf1)
2017-05-25 10:48:51,196::INFO::[SABnzbd:1169] Full executable path = /share/CACHEDEV1_DATA/.qpkg/SABnzbdplus/SABnzbdplus/SABnzbd.py
2017-05-25 10:48:51,197::INFO::[SABnzbd:1181] Platform = posix
2017-05-25 10:48:51,197::INFO::[SABnzbd:1182] Python-version = 2.7.13 (default, Apr 24 2017, 15:48:45)
[GCC 6.3.0]
2017-05-25 10:48:51,198::INFO::[SABnzbd:1183] Arguments = SABnzbd.py --daemon --browser 0 --config-file /share/CACHEDEV1_DATA/.qpkg/SABnzbdplus/config/config.ini --pidfile /tmp/SABnzbdplus.pid
2017-05-25 10:48:51,198::INFO::[SABnzbd:1188] Preferred encoding = UTF-8
2017-05-25 10:48:51,199::INFO::[SABnzbd:1229] Read INI file /share/CACHEDEV1_DATA/.qpkg/SABnzbdplus/config/config.ini


Settings below that

Code: Select all

__version__ = 19
__encoding__ = utf-8


You know what? Let me just do another restart of the NAS, just for completeness sake, and upgrade to 4.3.x to rule out anything related to QNAP OS. Because this all looks okay as do the locale settings themselves. It is what I wanted to do any way and I might as well get it out of the way.

User avatar
dirkonline
Know my way around
Posts: 244
Joined: Mon Oct 18, 2010 4:08 pm

Re: [SCRIPT] Sherpa

Post by dirkonline » Thu May 25, 2017 5:17 pm

dirkonline wrote:
OneCD wrote:Hey Dirk. Good find. ;)

I've not seen this error myself but there seems to be a report of it here: https://forums.sabnzbd.org/viewtopic.php?f=11&t=22483

Can you please check your SAB GUI startup log? When viewing it in your text viewer/editor, please check for a couple of things:



You know what? Let me just do another restart of the NAS, just for completeness sake, and upgrade to 4.3.x to rule out anything related to QNAP OS. Because this all looks okay as do the locale settings themselves. It is what I wanted to do any way and I might as well get it out of the way.


I am quite certain there is no causality but... after the upgrade to 4.3.x SAB in the current version 2.0.1 starts perfectly fine again:
2017-05-25 10:48:51,196::INFO::[SABnzbd:1168] SABnzbd.py-2.0.1 (rev=<HASH>29248ee603e6bf1)
2017-05-25 10:48:51,196::INFO::[SABnzbd:1169] Full executable path = /share/CACHEDEV1_DATA/.qpkg/SABnzbdplus/SABnzbdplus/SABnzbd.py
2017-05-25 10:48:51,197::INFO::[SABnzbd:1181] Platform = posix
2017-05-25 10:48:51,197::INFO::[SABnzbd:1182] Python-version = 2.7.13 (default, Apr 24 2017, 15:48:45)
[GCC 6.3.0]
2017-05-25 10:48:51,198::INFO::[SABnzbd:1183] Arguments = SABnzbd.py --daemon --browser 0 --config-file /share/CACHEDEV1_DATA/.qpkg/SABnzbdplus/config/config.ini --pidfile /tmp/SABnzbdplus.pid
2017-05-25 10:48:51,198::INFO::[SABnzbd:1188] Preferred encoding = UTF-8
2017-05-25 10:48:51,199::INFO::[SABnzbd:1229] Read INI file /share/CACHEDEV1_DATA/.qpkg/SABnzbdplus/config/config.ini
2017-05-25 10:48:51,212::INFO::[__init__:995] Loading data for rss_data.sab from /share/CACHEDEV1_DATA/.qpkg/SABnzbdplus/config/<USERNAME>/rss_data.sab
2017-05-25 10:48:51,270::INFO::[__init__:995] Loading data for totals10.sab from /share/CACHEDEV1_DATA/.qpkg/SABnzbdplus/config/<USERNAME>/totals10.sab
2017-05-25 10:48:51,287::INFO::[postproc:95] Loading postproc queue
2017-05-25 10:48:51,288::INFO::[__init__:995] Loading data for postproc2.sab from /share/CACHEDEV1_DATA/.qpkg/SABnzbdplus/config/<USERNAME>/postproc2.sab
2017-05-25 10:48:51,289::INFO::[__init__:995] Loading data for queue10.sab from /share/CACHEDEV1_DATA/.qpkg/SABnzbdplus/config/<USERNAME>/queue10.sab
2017-05-25 10:48:51,313::INFO::[__init__:995] Loading data for watched_data2.sab from /share/CACHEDEV1_DATA/.qpkg/SABnzbdplus/config/<USERNAME>/watched_data2.sab
2017-05-25 10:48:51,314::INFO::[__init__:995] Loading data for Rating.sab from /share/CACHEDEV1_DATA/.qpkg/SABnzbdplus/config/<USERNAME>/Rating.sab
2017-05-25 10:48:51,315::INFO::[__init__:998] /share/CACHEDEV1_DATA/.qpkg/SABnzbdplus/config/<USERNAME>/Rating.sab missing
2017-05-25 10:48:51,316::INFO::[scheduler:197] Setting schedule for midnight BPS reset
2017-05-25 10:48:51,317::INFO::[__init__:351] All processes started
2017-05-25 10:48:51,318::INFO::[SABnzbd:283] Web dir is /share/CACHEDEV1_DATA/.qpkg/SABnzbdplus/SABnzbdplus/interfaces/Glitter
2017-05-25 10:48:51,319::INFO::[SABnzbd:283] Web dir is /share/CACHEDEV1_DATA/.qpkg/SABnzbdplus/SABnzbdplus/interfaces/Config
2017-05-25 10:48:51,809::INFO::[SABnzbd:407] SABYenc module (v3.0.2)... found!
2017-05-25 10:48:51,810::INFO::[SABnzbd:424] Cryptography module (v1.5.1)... found!
2017-05-25 10:48:51,810::INFO::[SABnzbd:429] par2 binary... found (/usr/bin/par2)
2017-05-25 10:48:51,810::INFO::[SABnzbd:434] par2cmdline binary... found (/usr/bin/par2)
2017-05-25 10:48:51,811::INFO::[SABnzbd:437] UNRAR binary... found (/usr/local/sbin/unrar)
2017-05-25 10:48:51,811::INFO::[SABnzbd:450] unzip binary... found (/usr/bin/unzip)
2017-05-25 10:48:51,812::INFO::[SABnzbd:455] 7za binary... found (/usr/local/sbin/7z)
2017-05-25 10:48:51,812::INFO::[SABnzbd:463] nice binary... NOT found!
2017-05-25 10:48:51,812::INFO::[SABnzbd:467] ionice binary... NOT found!
2017-05-25 10:48:51,813::INFO::[SABnzbd:1274] SSL version OpenSSL 1.0.2k 26 Jan 2017
2017-05-25 10:48:51,813::INFO::[SABnzbd:1275] SSL supported protocols ['TLS v1.2', 'TLS v1.1', 'TLS v1']
2017-05-25 10:48:51,819::INFO::[SABnzbd:1386] Starting web-interface on 0.0.0.0:8800
2017-05-25 10:48:51,820::INFO::[_cplogging:219] [25/May/2017:10:48:51] ENGINE Bus STARTING
2017-05-25 10:48:51,829::INFO::[_cplogging:219] [25/May/2017:10:48:51] ENGINE Started monitor thread '_TimeoutMonitor'.
2017-05-25 10:48:52,297::INFO::[_cplogging:219] [25/May/2017:10:48:52] ENGINE Serving on http://0.0.0.0:8800
2017-05-25 10:48:52,298::INFO::[_cplogging:219] [25/May/2017:10:48:52] ENGINE Bus STARTED
2017-05-25 10:48:52,298::INFO::[zconfig:64] No Bonjour/ZeroConfig support installed
2017-05-25 10:48:52,299::INFO::[SABnzbd:1424] Starting SABnzbd.py-2.0.1
2017-05-25 10:48:52,313::INFO::[postproc:176] Completed Download Folder /share/Download/sabnzbd/complete is not on FAT
2017-05-25 10:48:52,327::INFO::[dirscanner:316] Dirscanner starting up
2017-05-25 10:48:52,342::INFO::[urlgrabber:72] URLGrabber starting up
__version__ = 19
__encoding__ = utf-8
[misc]

User avatar
OneCD
Ask me anything
Posts: 7156
Joined: Sun Aug 21, 2016 10:48 am
Location: "... there, behind that sofa!"

Re: [SCRIPT] Sherpa

Post by OneCD » Fri May 26, 2017 1:53 am

dirkonline wrote:I am quite certain there is no causality but... after the upgrade to 4.3.x SAB in the current version 2.0.1 starts perfectly fine again:
2017-05-25 10:48:51,809::INFO::[SABnzbd:407] SABYenc module (v3.0.2)... found!
2017-05-25 10:48:51,810::INFO::[SABnzbd:424] Cryptography module (v1.5.1)... found!
2017-05-25 10:48:51,810::INFO::[SABnzbd:429] par2 binary... found (/usr/bin/par2)
2017-05-25 10:48:51,810::INFO::[SABnzbd:434] par2cmdline binary... found (/usr/bin/par2)
2017-05-25 10:48:51,811::INFO::[SABnzbd:437] UNRAR binary... found (/usr/local/sbin/unrar)
2017-05-25 10:48:51,811::INFO::[SABnzbd:450] unzip binary... found (/usr/bin/unzip)
2017-05-25 10:48:51,812::INFO::[SABnzbd:455] 7za binary... found (/usr/local/sbin/7z)
2017-05-25 10:48:51,812::INFO::[SABnzbd:463] nice binary... NOT found!
2017-05-25 10:48:51,812::INFO::[SABnzbd:467] ionice binary... NOT found!

Almost. These are not right. :'

Should look like this:
OneCD wrote:2017-05-25 18:13:44,601::INFO::[SABnzbd:407] SABYenc module (v3.0.2)... found!
2017-05-25 18:13:44,603::INFO::[SABnzbd:424] Cryptography module (v1.5.1)... found!
2017-05-25 18:13:44,604::INFO::[SABnzbd:429] par2 binary... found (/usr/bin/par2)
2017-05-25 18:13:44,605::INFO::[SABnzbd:434] par2cmdline binary... found (/usr/bin/par2)
2017-05-25 18:13:44,606::INFO::[SABnzbd:437] UNRAR binary... found (/opt/bin/unrar)
2017-05-25 18:13:44,607::INFO::[SABnzbd:450] unzip binary... found (/usr/bin/unzip)
2017-05-25 18:13:44,608::INFO::[SABnzbd:455] 7za binary... found (/opt/bin/7za)
2017-05-25 18:13:44,609::INFO::[SABnzbd:461] nice binary... found (/opt/bin/nice)
2017-05-25 18:13:44,610::INFO::[SABnzbd:465] ionice binary... found (/opt/bin/ionice)

Can you please check these utilities are installed?

Code: Select all

opkg list-installed | grep 'ionice\|p7zip\|unrar'; echo -e "\n$PATH"

ImageImageImageImageImageImageImageImageImageImageImageImageImageImageImageImageImage

Post Reply

Return to “Community Apps”