[ Sonarr 3 ] [ 3.0.3.698 ] Smart PVR for newsgroup and bittorrent users

This is the best place for community developers to publish their genius work. Your Apps enrich the QNAP Turbo NAS.
Post Reply
InfoAddict
Starting out
Posts: 12
Joined: Wed Mar 21, 2018 5:46 pm

Re: [ Sonarr 3 ] [ 3.0.3.698 ] Smart PVR for newsgroup and bittorrent users

Post by InfoAddict » Thu Apr 30, 2020 6:47 am

The latest Qmono 6.8 update fixed it for me.

pracolas
New here
Posts: 4
Joined: Sat Sep 19, 2009 1:57 am

Re: [ Sonarr 3 ] [ 3.0.3.698 ] Smart PVR for newsgroup and bittorrent users

Post by pracolas » Thu Apr 30, 2020 2:15 pm

pracolas wrote:
Tue Mar 31, 2020 10:47 pm
Hi, I have a NS-251... Which version should I instal? Thank you
anybody???... :roll:

zwiep
New here
Posts: 2
Joined: Sun Sep 05, 2010 4:07 pm

Re: [ Sonarr 3 ] [ 3.0.3.698 ] Smart PVR for newsgroup and bittorrent users

Post by zwiep » Sat May 02, 2020 5:47 am

Just chiming in here.

I also get the
System.DllNotFoundException: libmediainfo.so.0
error message in my system events.

As far as I can tell I've done the best possible installation that I could, verified libmediainfo cli works in a shell.
For some reason neither the Qmono installation or the Qsonarr installation contain this and the only possible (and temporary) solution I have is to copy

Code: Select all

libmediainfo.so.0 & libmediainfo.so.0.0.0 -> sonar installation path
libmediainfo.so.0 & libmediainfo.so.0.0.0 -> Qmono installation path \ lib
some of these copies might be redundant but I didn't want to spend much effort looking for which I can drop, it works now, until the next update I suppose.
I'm just wondering if this behaviour is intended, or if it's a known bug for my combination of versions, and if there's a better fix available. I honestly couldn't find any.

- I'm running a TS-439 Pro with the latest supported firmware (4.2.6)
- I installed the most recent compatible version of Qmono (5.20.1.19)
- I installed the Media Info CLI (shared) version 18.12.1
- I installed Qsonarr 3, now running version 3.0.3.780

ta0801
New here
Posts: 4
Joined: Fri Jul 12, 2013 10:56 pm

Re: [ Sonarr 3 ] [ 3.0.3.698 ] Smart PVR for newsgroup and bittorrent users

Post by ta0801 » Wed Jun 10, 2020 10:43 pm

Is there a save and easy way to change the

AppData directory
/share/CACHEDEV1_DATA/SONARR3_CONFIG

to e.g.
/share/CACHEDEV1_DATA/.qpkg/QSonarr3/Sonarr/SONARR3_CONFIG

?

I don't like the "SONARR3_CONFIG" folder in my main share directory :-)

Ironworm
First post
Posts: 1
Joined: Wed Jul 08, 2020 9:52 am

Re: [ Sonarr 3 ] [ 3.0.3.698 ] Smart PVR for newsgroup and bittorrent users

Post by Ironworm » Wed Jul 08, 2020 10:34 am

When I attempt to download to an rclone mounted folder I get these error, any ideas?

Code: Select all

Message: Couldn't import episode /share/Download/completed/Series/The.Alienist.S01E05.iNTERNAL.720p.WEB.h264-BAMBOOZLE-xpost/the.alienist.s01e05.internal.720p.web.h264-bamboozle.mkv: Input/output error
More over on pastebin
pastebin.com/PFDyURiv

tanderson92
New here
Posts: 9
Joined: Sun Jul 26, 2020 2:18 pm

Re: [ Sonarr 3 ] [ 3.0.3.698 ] Smart PVR for newsgroup and bittorrent users

Post by tanderson92 » Mon Aug 17, 2020 11:14 am

At some point in the last 24 hours, the Sonarr config moved from from /share/CACHEDEV1_DATA/SONARR3_CONFIG to /SONARR3_CONFIG. This is causing Sonarr to report no series, no download client, no indexers, etc. Other than copying the contents of /share/CACHEDEV1_DATA/SONARR3_CONFIG to the new config location, is there a way to restore the config file to the proper location? I'm away from home but I remoted in yesterday and saw everything was ok. Today all I've done is remotely uninstall the Par2 0.8.1.0 Dev Tools and Install the Par2cmdline-MT so that SAB would see a working Par2 install. Did that somehow cause the Sonarr config to move?

tanderson92
New here
Posts: 9
Joined: Sun Jul 26, 2020 2:18 pm

Re: [ Sonarr 3 ] [ 3.0.3.698 ] Smart PVR for newsgroup and bittorrent users

Post by tanderson92 » Mon Aug 17, 2020 11:24 am

tanderson92 wrote:
Mon Aug 17, 2020 11:14 am
At some point in the last 24 hours, the Sonarr config moved from from /share/CACHEDEV1_DATA/SONARR3_CONFIG to /SONARR3_CONFIG. This is causing Sonarr to report no series, no download client, no indexers, etc. Other than copying the contents of /share/CACHEDEV1_DATA/SONARR3_CONFIG to the new config location, is there a way to restore the config file to the proper location? I'm away from home but I remoted in yesterday and saw everything was ok. Today all I've done is remotely uninstall the Par2 0.8.1.0 Dev Tools and Install the Par2cmdline-MT so that SAB would see a working Par2 install. Did that somehow cause the Sonarr config to move?
As a quick follow-up, I copied the config files to the new location so that Sonarr would work properly. Unfortunately / is the /dev/ram partition and has only 400MB space which is now mostly filled after copying 100MB+ of Sonarr config. Is there a way to force Sonarr to use the old config location so that I can delete the newly-created directory in /?

EDIT: I always forget about symbolic links! For now, ln -s /share/CACHEDEV1_DATA/SONARR3_CONFIG /SONARR3_CONFIG solved the space issue, but I'm still not sure why Sonarr moved its app data directory there. I'm willing to uninstall and re-install if that would fix it. I have the config directory saved off-site so that I can copy it back into place.

tanderson92
New here
Posts: 9
Joined: Sun Jul 26, 2020 2:18 pm

Re: [ Sonarr 3 ] [ 3.0.3.698 ] Smart PVR for newsgroup and bittorrent users

Post by tanderson92 » Fri Aug 21, 2020 12:31 am

A few days later I found out the hard way the NAS was plugged in to the "surge" side and not the "battery" side of my UPS. Anyway, after the NAS restarted, the Sonarr config is back in /share/CACHEDEV1_DATA/SONARR3_CONFIG. I'm still not sure why it temporarily moved away, but it's back in the correct location now.

pgdownload
Starting out
Posts: 14
Joined: Sun Apr 21, 2013 1:04 pm

Re: [ Sonarr 3 ] [ 3.0.3.698 ] Smart PVR for newsgroup and bittorrent users

Post by pgdownload » Sat Sep 05, 2020 5:29 am

Hi,

Just a quick query on the version. Sonar3 is working fine but it reporting about 5 months of updates available since this version. The in built update feature does everything right but just fails at the end.

Anything I'm doing wrong/missing?

3.0.3.913

Sep 5 2020
phantom-develop
Fixed
Preview rename tip wording
Update year during refresh
3.0.3.911

Aug 17 2020
phantom-develop
New
Added silent notification option to telegram
Fixed
Typo in Lost Connection modal
Series navigation buttons hidden with some titles
Links and already added icons overflowing on add series search results
Overflow of absolute episode numbers with warning
Long relative path when selecting episodes in Manual Import hiding buttons
3.0.3.907

Aug 11 2020
phantom-develop
Fixed
Include extension when calculating maximum episode title length when renaming files
Option to override max filename length with MAX_NAME environment variable
Prevent misinterpreting Season folder as anime release title
Exception when parsing Quality in release title with colon
Parsing anime with title ending in 100
3.0.3.906

Aug 5 2020
phantom-develop
Fixed
Manual Import adding empty rows after selecting series
Long paths overflowing in series history
3.0.3.905

Aug 3 2020
phantom-develop
New
Not in Last/Next for date custom filters
Fixed
Don't use language parsed from episode title during import
Edited series is reset after refresh
Multiple warnings for episode combined into one tooltip
3.0.3.904

Jul 27 2020
phantom-develop
Fixed
Deleting empty episode folders on upgrade
3.0.3.903

Jul 27 2020
phantom-develop
Fixed
Parsing of article title leading to error loading Interactive Search
Mark "BAD" Nzbget Downloads as Failed
Long titles not finding matches in UI series search
3.0.3.902

Jul 27 2020
phantom-develop
New
Filter episodes by title or number in Manual Import
3.0.3.900

Jul 27 2020
phantom-develop
New
Show updated rejection reasons in manual import after selecting series
Improved parsing of season and episode inside square brackets
Fixed
Don't create empty series folder if delete empty folders is enabled
Show more information in UI when testing SAB fails in some cases
Parsing of some absolute episode numbers over 999
3.0.3.899

Jul 11 2020
phantom-develop
Fixed
Typo in the Week Column Header example
Typo/unclear text in backup retention
"Profile" to "Indexer" on Clone Button
3.0.3.896

Jun 26 2020
phantom-develop
Fixed
TheTVDB metadata images containing html content
3.0.3.895

Jun 22 2020
phantom-develop
Fixed
Failing file copy when running in docker on synology with btrfs
3.0.3.894

Jun 22 2020
phantom-develop
New
Fast copy using reflink on btrfs volumes
Fixed
Refreshing Plex Server series in high volume systems
Performance of symbolic link detection and infinite recursion
Added glusterfs to known network drive filesystems so it shows up in System
Removed hardlink-based transactional file transfer logic (instead relying on explicit copy+delete for cifs)
Rejecting another multi-season pack format
3.0.3.892

Jun 17 2020
phantom-develop
Fixed
Twitter Connect missing (you'll have to readd it in Connect)
3.0.3.885

Jun 14 2020
phantom-develop
New
Ensure all unmapped folders are fetched when importing from a root folder
Fixed
Exception thrown when marking download as complete
Displayed root folder path getting truncated when adding a series with a long title
3.0.3.879

Jun 11 2020
phantom-develop
Fixed
Sorting of queue by series title when unknown items are included
3.0.3.874

Jun 9 2020
phantom-develop
Currently Installed

User avatar
Maggus
Starting out
Posts: 47
Joined: Thu Mar 06, 2014 5:38 pm
Location: Germany

Re: [ Sonarr 3 ] [ 3.0.3.698 ] Smart PVR for newsgroup and bittorrent users

Post by Maggus » Sat Sep 05, 2020 3:00 pm

No issues with the built in updater here. Updated a couple minutes ago without any problems.

pgdownload
Starting out
Posts: 14
Joined: Sun Apr 21, 2013 1:04 pm

Re: [ Sonarr 3 ] [ 3.0.3.698 ] Smart PVR for newsgroup and bittorrent users

Post by pgdownload » Sun Oct 04, 2020 1:55 pm

Maggus wrote:
Sat Sep 05, 2020 3:00 pm
No issues with the built in updater here. Updated a couple minutes ago without any problems.
Note, I don't have any unusual install. Just the usual. This is what the built in log file says after it fails:

[v3.0.3.874] System.ComponentModel.Win32Exception (0x80004005): ApplicationName='mono', CommandLine='--debug /share/CACHEDEV1_DATA/SONARR3_CONFIG/tmp/sonarr_update/Sonarr.Update.exe 24518 /share/CACHEDEV1_DATA/SONARR3_CONFIG/tmp/sonarr_update /share/CACHEDEV1_DATA/.qpkg/QSonarr3/Sonarr/Sonarr.exe /data=/share/CACHEDEV1_DATA/SONARR3_CONFIG', CurrentDirectory='', Native error= Cannot find the specified file
at System.Diagnostics.Process.StartWithCreateProcess (System.Diagnostics.ProcessStartInfo startInfo) [0x0029f] in <0c3b3cba6a384e83868468e2cb9eddf2>:0
at System.Diagnostics.Process.Start () [0x0003a] in <0c3b3cba6a384e83868468e2cb9eddf2>:0
at (wrapper remoting-invoke-with-check) System.Diagnostics.Process.Start()
at NzbDrone.Common.Processes.ProcessProvider.Start (System.String path, System.String args, System.Collections.Specialized.StringDictionary environmentVariables, System.Action`1[T] onOutputDataReceived, System.Action`1[T] onErrorDataReceived) [0x00187] in <65c3175355c945e9835da82876d6e502>:0
at NzbDrone.Core.Update.InstallUpdateService.InstallUpdate (NzbDrone.Core.Update.UpdatePackage updatePackage) [0x00271] in <920c1ccfc7b34650bb31b4789e3dd4f0>:0
at NzbDrone.Core.Update.InstallUpdateService.Execute (NzbDrone.Core.Update.Commands.ApplicationUpdateCommand message) [0x00013] in <920c1ccfc7b34650bb31b4789e3dd4f0>:0
at NzbDrone.Core.Messaging.Commands.CommandExecutor.ExecuteCommand[TCommand] (TCommand command, NzbDrone.Core.Messaging.Commands.CommandModel commandModel) [0x000e0] in <920c1ccfc7b34650bb31b4789e3dd4f0>:0
at (wrapper dynamic-method) System.Object.CallSite.Target(System.Runtime.CompilerServices.Closure,System.Runtime.CompilerServices.CallSite,NzbDrone.Core.Messaging.Commands.CommandExecutor,object,NzbDrone.Core.Messaging.Commands.CommandModel)
at System.Dynamic.UpdateDelegates.UpdateAndExecuteVoid3[T0,T1,T2] (System.Runtime.CompilerServices.CallSite site, T0 arg0, T1 arg1, T2 arg2) [0x00035] in <1b808d6fd64b42758ac4398853431a58>:0
at (wrapper dynamic-method) System.Object.CallSite.Target(System.Runtime.CompilerServices.Closure,System.Runtime.CompilerServices.CallSite,NzbDrone.Core.Messaging.Commands.CommandExecutor,object,NzbDrone.Core.Messaging.Commands.CommandModel)
at NzbDrone.Core.Messaging.Commands.CommandExecutor.ExecuteCommands () [0x0008c] in <920c1ccfc7b34650bb31b4789e3dd4f0>:0

doubter13
Starting out
Posts: 28
Joined: Wed Sep 09, 2009 2:08 pm

Re: [ Sonarr 3 ] [ 3.0.3.698 ] Smart PVR for newsgroup and bittorrent users

Post by doubter13 » Thu Oct 15, 2020 10:30 pm

hi, maybe someone can help me.. I just realised my Sonarr stopped working a while a go.
the last logg file is form 220-10-11 and the last entry was about a restart
in the update log I see it did an upgrade "Updating Sonarr from version 3.0.3.970 to version 3.0.3.971"
the update supposedly completed successfully but since then I didn't start
I tried to stop and restart it and the Qnap qui tells me its started again but I don't see any new logs
is there a way to start it from shell and try to see any errors there?
I also tried "upgrading" it with the latest package from the qnapclub repository but still no luck
QNAP TS-470 Pro [4.3.6.1333 (2020/06/08)]
- disks: 4xWD30EFRX-68EUZN0 3TB, ext3
- SSD: 1xSAMSUNG SSD 840 EVO 500GB

doubter13
Starting out
Posts: 28
Joined: Wed Sep 09, 2009 2:08 pm

Re: [ Sonarr 3 ] [ 3.0.3.698 ] Smart PVR for newsgroup and bittorrent users

Post by doubter13 » Thu Oct 15, 2020 10:40 pm

ok, it was a bug in 971

the trick was installing it again, I tried it via the GUI but it did not work so I downloaded the package and installed manually and updated again to the latest phantom version.
QNAP TS-470 Pro [4.3.6.1333 (2020/06/08)]
- disks: 4xWD30EFRX-68EUZN0 3TB, ext3
- SSD: 1xSAMSUNG SSD 840 EVO 500GB

Post Reply

Return to “Community Apps”