Ask community developers’ help for your most wanted Apps and also discover what the hottest and ultimate Apps are.
First post
Posts: 1
Joined: Mon May 22, 2017 8:53 am

Re: Homebridge

Post by mishakim » Mon Oct 16, 2017 8:38 am

Worked for me today. I used the container as suggested above, had some trouble, but once I changed the network from NAT to Bridge, it worked fine.

Know my way around
Posts: 100
Joined: Tue Nov 11, 2014 5:53 am

Re: Homebridge

Post by mrs4t4n » Thu Nov 16, 2017 9:44 pm

I have a homegridge running in a raspberry pi, but i will love to move it to my QNAP TS-251...
The only way to run hombebridge is through a docker?
I had container station disable... i had link aggregation with my managed switch.
If i enable container station i think i will lost the LAG...

First post
Posts: 1
Joined: Sun May 20, 2018 9:16 pm

Re: Homebridge

Post by reddyrus » Mon May 21, 2018 2:08 am

Hey guys! I have QNAP D2 (seems it's only available in Russia), here is screenshot of specs:
and it looks like:

my question is - am I able to install HomeBridge server on it via Container Station?
I tried to do it by using this manual - https://github.com/marcoraddatz/homebri ... -QNAP-(GUI)
but no luck, the reason is that I can't set Container Network setting to 'Bridge' coz I don't have it in menu, only 'Host' and 'NAT'.

If my model allow it - please help me to understand how to set it correctly?

First post
Posts: 1
Joined: Sat Sep 01, 2018 9:37 pm

Re: Homebridge

Post by Sebu! » Sat Sep 01, 2018 9:45 pm

I was able install Homebridge using container station. I’m able to connect with IOS home app to the Homebridge. The problem is that I’m not able to install any plugins. I’ve added npm and the plugin names to install.sh, but plugins don’t get loaded. I have QNAP TS-128 which is ARM based cpu. Can that influence?

New here
Posts: 2
Joined: Wed Nov 11, 2020 9:45 pm

Re: Homebridge

Post by marito158 » Wed Nov 11, 2020 10:04 pm

Hi, I'm running into the same problem of not being available to install additional plugins, homebridge is running on a docker (QNAP TS251+), i had no trouble installing plugins, until for some reason I had an issue with one of the plugins showing as duplicated so I had to delete one of then, after that i cant install any plugin, i have 8 plugins installed before this error "/bin/sh: 1: npm: not found" every time i try to install any plugin. Hope someone here can help.

Post Reply

Return to “Apps Wanted”