Can't reboot the NAS by Web GUI

Q'center app, Helpdesk app
Post Reply
damenchoy
Getting the hang of things
Posts: 74
Joined: Fri Feb 26, 2016 3:06 pm

Can't reboot the NAS by Web GUI

Post by damenchoy » Sun Oct 20, 2019 2:00 pm

I own a TS-253A and recently I have found out the NAS fails to reboot from time to time when I initiate the reboot through Web admin UI
It got stuck in the shutdown process. I have to hard press the power button to force shutdown and reboot the NAS and that is not what I want to do esp. I have to reboot it from time to time before I apply the firmware update.

I was stuck in the reboot process again yesterday in the WebUI.

I used SSH to connect to the server and issue the command

Code: Select all

/etc/init.d/services.sh stop
to try to stop the services running in the NAS.

However, the services.sh stopped when it hit the step of shutting down the service by the script Qthttpd.sh.

Here is the output of the services.sh script:

Code: Select all

 # /etc/init.d/services.sh stop &
[1] 5335
[~] # Stop services: Stop qpkg service: /etc/rcK.d/QK100QcloudSSLCertificate /etc/rcK.d/QK101LicenseCenter /etc/rcK.d/QK101opentftp /etc/rcK.d/QK102CacheMount /share/CACHEDEV1_DATA/.qpkg/CacheMount/etc/init.d/remote_mount.sh: line 55: bin/rm: No such file or directory
/etc/rcK.d/QK103MultimediaConsole stop_media_service()...
Shutting down Media Server: OK
/etc/rcK.d/QK104MalwareRemover stop
/etc/rcK.d/QK106NotificationCenter /etc/rcK.d/QK107QVPN Shutting down QVPN services:
/etc/rcK.d/QK108container-station [2019-10-20 13:52:00] /etc/rcK.d/QK108container-station (PID=9096, Command=stop Parent=/bin/sh /etc/init.d/services.sh stop ) ++
[2019-10-20 13:52:00] [stop] Container Station: 2.0.356
[2019-10-20 13:52:00] [FUNC] qts_qpkg_status_begin: (2) container-station stop
/etc/rcK.d/QK109ResilioSync resilio-sync isn't running
/etc/rcK.d/QK110Qboost Shutting down Qboost service: OK
/etc/rcK.d/QK111DownloadStation Shutting down DownloadStation services:
/etc/rcK.d/QK112HybridBackup HybridBackup stop
Stop RTRR/Rsync jobs
Stop CBS
Stopping...
pidfile /share/CACHEDEV1_DATA/.qpkg/HybridBackup/CloudConnector3/data/server/fastcgi.pid does not exist. Not running?
HybridBackup stopped
Stop Rsync
Stop RR2 server
Stop RTRR
Downgrade RTRR server
{}
Unmount the RTRR mounted CIFS
NC unregister
Stop HBS Versioning script
Restore HBS 2 incoming job config file
Start BackupStation
Enable HBS2 RSYNC Schedule
HybridBackup stop finished
/etc/rcK.d/QK113CloudLink /etc/rcK.d/QK114QsyncServer Shutting down Qsync service: Shutting down Versioning services:.
stop db server
OK
/etc/rcK.d/QK115ResourceMonitor /etc/rcK.d/QK116QKVM create link
/etc/rcK.d/QK118helpdesk .
Stop service: ldap_server.sh antivirus.sh iso_mount.sh qsnapman.sh qsyncman.sh rsyslog.sh snmp lunportman.sh iscsitrgt.sh twonkymedia.sh init_iTune.sh ImRd.sh crond.sh StartMediaService.sh mariadb.sh mysqld.sh recycled.sh Qthttpd.sh
I tried manually stop the service by

Code: Select all

/etc/init.d/Qthttpd.sh stop
and again the script cannot be completed.

I suspected this is the reason I could not shutdown and restart the NAS.

Is there any way I can force shutdown the Qthttpd.sh?

And is there any way I can investigate further the reasons of failure to reboot the NAS?

Thanks

damenchoy
Getting the hang of things
Posts: 74
Joined: Fri Feb 26, 2016 3:06 pm

Re: Can't reboot the NAS by Web GUI

Post by damenchoy » Sun Oct 20, 2019 10:46 pm

I tried a lot of ways.

Finally I use the command

Code: Select all

kill 1
to successfully shut down and reboot the NAS

I am a bit surprised this works

dmacfar1
New here
Posts: 8
Joined: Sun Oct 02, 2016 1:01 am

Re: Can't reboot the NAS by Web GUI

Post by dmacfar1 » Wed Feb 19, 2020 6:03 am

I have had a few times I have had problems rebooting my NAS. The system would hang when it was trying to shutdown services. I have tried everything to kill things gracefully, including ssh and killing processes. Your "kill 1" solution is the only thing that has ever worked without forcing a hard restart by holding down the power. Not even reboot in ssh worked.

A few things, I could never seem to kill all the Plex processes. They just wouldn't die.

It always hangs on AcousticID Chromaprint (Plex comes after in the list)

Lastly, HBS 3 seemed to be stuck.

I post here in case someone can make something of this. But "kill 1" is the only thing I have found that works.

Thanks for your idea.

Post Reply

Return to “NAS Management”