Feedback for the folks at Xopero

Post Reply
kelv1n
Starting out
Posts: 25
Joined: Sat May 11, 2019 6:01 pm

Feedback for the folks at Xopero

Post by kelv1n » Sun Sep 22, 2019 1:07 am

Hey Xopero

I know you periodically visit the QNAP forum, so I just wanted to leave some feedback on Xopero Pro - The products current layout is just unintuitive.

1) After installation of any other backup product, it usually displays the management console, with options for accessing wizards such importing Servers, creating a scheduled backup. Xopero immediately presents a convoluted "Wizard", which asks the Admin to setup a user, then select associated devices, then download the agent - None of these steps are relevant for a Server or VM backup. (At minimum, this Wizard should be intuitive enough, to ask my use case and then run through the appropriate steps)
2) The "User" I created in the step above, was configured as an "Admin", yet the user could not log into the Management Center.
3) I found it impossible to add an ESXi or vCenter server. First its not immediately clear how to add a device, but eventually when clicking around I found the "Templates", but the only option available was "Local"

After 30 minutes, I have clearly failed to understand how Xopero is meant to work and uninstalled it. As an IT Manager, I'm experienced and ugly enough figure out most software, but this I just had to give up on. Thankfully my testing was for personal use, but how many business-customers are experiencing, and your losing potential business due to this initial complexity. This isn't meant as criticism, just my honest feedback.

Post Reply

Return to “Xopero”