ESP8266 + QIoT

QIoT technology to allow you to explore potential IoT business opportunities.
Smart home/Smart building/Smart City/
Post Reply
wlad_wm
Starting out
Posts: 32
Joined: Thu Dec 31, 2009 7:26 pm

ESP8266 + QIoT

Post by wlad_wm » Tue Oct 02, 2018 9:55 pm

Hello!
I have a question on connection ESP8266 to QIoT.
What I have:
1) QNAP D4 PRO with the latest 4.3.4.0695 and QIoT 1.1.298
2) I have a relay based ob esp8266-12 and try to connect it over MQTT

I created sketch for ESP8266 and according to log - it coonected to WiFi and connected to MQTT broker.
The problem is that I can't deploy Thing on QIoT - because there is no connection over SSH to it. What I need to do to fix it?

timhsu
New here
Posts: 5
Joined: Wed Nov 15, 2017 12:12 pm

Re: ESP8266 + QIoT

Post by timhsu » Thu Oct 04, 2018 10:33 am

Hi wlad_wm
You can reference this tutorial :
https://www.qnap.com/en/how-to/tutorial ... suite-lite
ESP8266 didn't support SSH, so it can't use deploy function in QIoT. Must be manual to deploy your code to ESP8266.

Thank you.

marcello1234
First post
Posts: 1
Joined: Mon Nov 12, 2018 10:26 am

Re: ESP8266 + QIoT

Post by marcello1234 » Mon Nov 12, 2018 10:48 am

Hello,

I also tried to connect a ESP8266 to the MQTT Broker.
I used the button and led example from the tutorial.
The button state can be displayed on the dashboard without any problem, but the ESP8266 is not switching on the led.

On the serial monitor of the Arduino ide I can see the publish message for the broker, but no receive message.

I already tested the led with a very simple sketch just to make sure there is no hardware issue or a wrong connection.

What could be the problem?

Post Reply

Return to “QIoT”