QIot + ESP - Error MQTT client connection failed, rc=-4

QIoT technology to allow you to explore potential IoT business opportunities.
Smart home/Smart building/Smart City/
Post Reply
icapelli
New here
Posts: 2
Joined: Wed Nov 14, 2018 6:08 am

QIot + ESP - Error MQTT client connection failed, rc=-4

Post by icapelli » Wed Nov 14, 2018 6:12 am

I writing ESP code using your guide to connect ESP and display DHT data but always never connect

Can you help me

User avatar
OneCD
Ask me anything
Posts: 5342
Joined: Sun Aug 21, 2016 10:48 am
Location: "... there, behind that sofa!"

Re: QIot + ESP - Error MQTT client connection failed, rc=-4

Post by OneCD » Wed Nov 14, 2018 10:57 am

Hi and welcome to the forum. :)

I'm not sure what you're asking about. Are you setting-up something like this? https://thingsboard.io/docs/samples/esp ... mperature/

Is this the guide you mentioned? https://www.qnap.com/en/how-to/tutorial ... suite-lite

Debian 'Stretch' on my production NAS (TS-569 Pro), with the backup NAS (TS-559 Pro+) to eventually follow. When that happens, I'll no longer use or support any QNAP firmware. Debian powerup/poweroff times are < 1 minute.

one.cd.only@gmail.com

Image Image Image Image Image

icapelli
New here
Posts: 2
Joined: Wed Nov 14, 2018 6:08 am

Re: QIot + ESP - Error MQTT client connection failed, rc=-4

Post by icapelli » Thu Nov 15, 2018 5:56 pm

OneCD wrote:
Wed Nov 14, 2018 10:57 am
Hi and welcome to the forum. :)

I'm not sure what you're asking about. Are you setting-up something like this? https://thingsboard.io/docs/samples/esp ... mperature/

Is this the guide you mentioned? https://www.qnap.com/en/how-to/tutorial ... suite-lite
Hi,
i use this guide https://www.qnap.com/en/how-to/tutorial ... suite-lite. When ESP8266 try to connect to QIoS return error code -4 (timeout)

timhsu
New here
Posts: 5
Joined: Wed Nov 15, 2017 12:12 pm

Re: QIot + ESP - Error MQTT client connection failed, rc=-4

Post by timhsu » Tue Dec 04, 2018 6:55 pm

Hi icapelli,

Can you help check if your NAS IP has ever changed?
If you have changed your IP, go to "Setting page > Administrative Settings" renew your IP Address.
And edit your code to new IP addriss.

Thank you.
icapelli wrote:
Thu Nov 15, 2018 5:56 pm
OneCD wrote:
Wed Nov 14, 2018 10:57 am
Hi and welcome to the forum. :)

I'm not sure what you're asking about. Are you setting-up something like this? https://thingsboard.io/docs/samples/esp ... mperature/

Is this the guide you mentioned? https://www.qnap.com/en/how-to/tutorial ... suite-lite
Hi,
i use this guide https://www.qnap.com/en/how-to/tutorial ... suite-lite. When ESP8266 try to connect to QIoS return error code -4 (timeout)

Post Reply

Return to “QIoT”