Coral TPU disappears from hardware resources

QNAP now provides a groundbreaking AI computing platform based on QNAP NAS called QuAI (pronounced "Q A I" ) - QNAP's AI Developer Package.
Data Mining/Machine Learning/Deep Learning
Post Reply
starmanj
New here
Posts: 3
Joined: Fri Oct 25, 2019 10:24 pm

Coral TPU disappears from hardware resources

Post by starmanj » Wed Jan 11, 2023 2:23 am

I have a TP-431P, which I guess technically doesn't support the TPU? But it does work. For a while. Then the whole TPU disappears from hardware resources and AI reverts to CPU.
Is there a fix for this? Or is my system crashing out due to limited memory or CPU?

User avatar
dolbyman
Guru
Posts: 30483
Joined: Sat Feb 12, 2011 2:11 am
Location: Vancouver BC , Canada

Re: Coral TPU disappears from hardware resources

Post by dolbyman » Wed Jan 11, 2023 2:42 am

Not much info given, is a TPU actually connected ?

Looks like only x86 devices are supported by these USB adapters.

https://www.qnap.com/en/compatibility/? ... rand=coral

Open a ticket to clarify/complain

User avatar
Toxic17
Ask me anything
Posts: 6331
Joined: Tue Jan 25, 2011 11:41 pm
Location: Planet Earth
Contact:

Re: Coral TPU disappears from hardware resources

Post by Toxic17 » Wed Jan 11, 2023 3:37 am

yep there is no compatible AI Accelerator for this NAS

https://www.qnap.com/en/compatibility/? ... category=1

the dropdown list has no AI Accelerator in the list.
Regards Simon

Submit a Ticket
Qnap Downloads
MyQNap.Org Repository
Submit a ticket • QNAP Helpdesk
QNAP Tutorials, User Manuals, FAQs, Downloads, Wiki
When you ask a question, please include the following


NAS: TS-673A h5.0.1.2248 • TS-121 4.3.3.2211 • APC Back-UPS ES 700G
Network: VM Hub3: 350/35 • UniFi UDM Pro: 2.4.26 • UniFi Network Controller: 7.3.81 • UniFi Protect: 2.2.6/8TB Skyhawk AI
USW-Aggregation: 6.4.18 • US-16-150W: 6.4.18 • 2x USW Mini Flex 1.8.6 • UniFi AC Pro 6.5.263 • UniFi U6-LR 6.5.26 • 3x G3 Instants: 4.57.35 • 3x UniFi G3 Flex: 4.57.35

starmanj
New here
Posts: 3
Joined: Fri Oct 25, 2019 10:24 pm

Re: Coral TPU disappears from hardware resources

Post by starmanj » Wed Jan 11, 2023 9:23 pm

Well it does work after all. I see it now turning off and on within Qumagie web page.Like someone else noted, it isn't used all the time. I'm indexing 200,000 photos. It takes almost 3 months nonstop by CPU, then Qnap randomly blew away the entire database, so I bought the TPU to accelerate.
I don't know why Qnap doesn't advertise it working for my Arm chip with only 1gig ram, but it does work-- just not reliably, maybe that's why.

Post Reply

Return to “QuAI”