unknown uid 0

Introduce yourself to us and other members here, or share your own product reviews, suggestions, and tips and tricks of using QNAP products.
spheremonk
Starting out
Posts: 12
Joined: Wed Jan 04, 2017 5:58 am

unknown uid 0

Postby spheremonk » Fri Feb 17, 2017 7:18 pm

Hi all.

Out of nowhere, running "crontab -l" gives me the following error:

Code: Select all

crontab: unknown uid 0


Cron is still running, and editable in /etc/config/crontab. I'm worried about this error; seems to imply something has changed for the admin user, but I've no idea what. Has anyone come across it?

Thanks

Will

User avatar
OneCD
Experience counts
Posts: 2930
Joined: Sun Aug 21, 2016 10:48 am
Location: over there, behind that sofa...

Re: unknown uid 0

Postby OneCD » Sat Feb 18, 2017 2:32 am

Hi Will.

When asking a question, please include your NAS model, firmware version and build number.

spheremonk wrote:Out of nowhere, running "crontab -l" gives me the following error:

Code: Select all

crontab: unknown uid 0

Haven't seen this one myself. What does your id show?

Code: Select all

[/share] # id
uid=0(admin) gid=0(administrators) groups=0(administrators),100(everyone)
2017-07-15 - I've left this forum. I'm switching to a pure Debian environment for both my NAS. As a result, I'll no longer be able to use or support QNAP's firmware. This means no more QPKGs, closed-source software, "Malware Removers", etc ... so, I'm looking forward to it. ;)

To contact me, send a mail to one.cd.only@gmail.com. I'll still be a contributor on various other software-related forums so I might see you there.

Thank you to all community members who have participated in the many discussions - and to the regulars I saw here everyday (your advice has taught me a lot). I have also learned a great deal by assisting others, and hope many more members will do the same. :D

spheremonk
Starting out
Posts: 12
Joined: Wed Jan 04, 2017 5:58 am

Re: unknown uid 0

Postby spheremonk » Sat Feb 18, 2017 4:42 am

Sorry for not giving more info.

TS-251+.
Firmware version 4.2.3 Build 20170213

id: uid=0 gid=0 groups=0,100

It's very odd. I wonder if my .profile is causing it (but it's been working fine for weeks like this, so...)

Code: Select all

export PS1='[\w] # '
reset
function starttv { cd /share/old/O*/D*/b*/flex && flexget seen forget "$1" && flexget series begin "$1" "$2"; }
export -f starttv
#unset HISTFILESIZE
#export HISTSIZE=-1
#export HISTIGNORE="history*:pwd:ls*"
#export HISTCONTROL="ignoreboth"
echo "Running .profile"
alias flex='cat /share/old/OnlineSync/Drop/backups/flex/flexget.log'
export PROMPT_COMMAND="history -a;$PROMPT_COMMAND"
shopt -s histappend
#export HISTIGNORE="history*:pwd:ls*"
#export HISTSIZE=-1
alias scripts='cd /share/old/OnlineSync/Drop/backups/scripts'
alias media='cd /share/OldNAS/'
alias bill='python /share/old/OnlineSync/Drop/backups/scripts/rasp/spider/f/billgiles.py GU7'
alias devon='python /share/old/OnlineSync/Drop/backups/scripts/rasp/spider/f/devonweather.py'
alias restartplex='$(getcfg -f /etc/config/qpkg.conf PlexMediaServer Install_path)/plex.sh restart &'
source /opt/etc/profile

spheremonk
Starting out
Posts: 12
Joined: Wed Jan 04, 2017 5:58 am

Re: unknown uid 0

Postby spheremonk » Thu Feb 23, 2017 7:00 pm

I'm still at a loss. New crontab entries are no longer saving, even when I restart crond. Crontab is completely broken (or reliant on this uid, which is the broken part).

I've reinstalled QTS, without success. I can't afford to wipe everything and start over.

Any ideas, at all?

User avatar
OneCD
Experience counts
Posts: 2930
Joined: Sun Aug 21, 2016 10:48 am
Location: over there, behind that sofa...

Re: unknown uid 0

Postby OneCD » Thu Feb 23, 2017 7:37 pm

Is Entware-ng or Entware-3x installed on your NAS?
2017-07-15 - I've left this forum. I'm switching to a pure Debian environment for both my NAS. As a result, I'll no longer be able to use or support QNAP's firmware. This means no more QPKGs, closed-source software, "Malware Removers", etc ... so, I'm looking forward to it. ;)

To contact me, send a mail to one.cd.only@gmail.com. I'll still be a contributor on various other software-related forums so I might see you there.

Thank you to all community members who have participated in the many discussions - and to the regulars I saw here everyday (your advice has taught me a lot). I have also learned a great deal by assisting others, and hope many more members will do the same. :D

spheremonk
Starting out
Posts: 12
Joined: Wed Jan 04, 2017 5:58 am

Re: unknown uid 0

Postby spheremonk » Thu Feb 23, 2017 8:01 pm


User avatar
OneCD
Experience counts
Posts: 2930
Joined: Sun Aug 21, 2016 10:48 am
Location: over there, behind that sofa...

Re: unknown uid 0

Postby OneCD » Thu Feb 23, 2017 8:15 pm

Don't know - @zyxmon would be the best person to answer that. ;)

I think Entware-3x supports separate users and groups. But you are using ng and I haven't read anything that says ng does too.

You could try asking him in the Entware sub-forum: viewforum.php?f=351

You could also test this by disabling the Entware-ng package in your App Center and check if you still get that same error. You would then need to log out and back in again from any current SSH sessions to reload your environment variables.
2017-07-15 - I've left this forum. I'm switching to a pure Debian environment for both my NAS. As a result, I'll no longer be able to use or support QNAP's firmware. This means no more QPKGs, closed-source software, "Malware Removers", etc ... so, I'm looking forward to it. ;)

To contact me, send a mail to one.cd.only@gmail.com. I'll still be a contributor on various other software-related forums so I might see you there.

Thank you to all community members who have participated in the many discussions - and to the regulars I saw here everyday (your advice has taught me a lot). I have also learned a great deal by assisting others, and hope many more members will do the same. :D

TheBrad
Starting out
Posts: 26
Joined: Sun Feb 14, 2010 8:14 pm

Re: unknown uid 0

Postby TheBrad » Thu Aug 10, 2017 5:09 pm

You probably installed busybox from entware-ng, maybe on purpose or accidentially as a dependency. Renaming /opt/bin/crontab (which symlinks to /opt/bin/busybox) to /opt/bin/crontab2 did the trick. It might be useful to rename /opt/bin/wget to /opt/bin/wget2 as well to be able to download from https again.
TS 669L (v4.3.3)

User avatar
schumaku
Guru
Posts: 42472
Joined: Mon Jan 21, 2008 4:41 pm
Location: Kloten (Zurich), Switzerland -- Skype: schumaku
Contact:

Re: unknown uid 0

Postby schumaku » Thu Aug 10, 2017 5:51 pm

Installing a different Busybox or rename standard tools and utilities used by QTS is definitively a bad advise. The fact that the generic Entware-ng is available does not qualify to substitute these core features - issues are predictable.


Return to “Users' Corner”

Who is online

Users browsing this forum: No registered users and 5 guests