Unable to access various services from outside the network

Introduce yourself to us and other members here, or share your own product reviews, suggestions, and tips and tricks of using QNAP products.
Develon
New here
Posts: 3
Joined: Tue May 16, 2017 12:59 am

Unable to access various services from outside the network

Postby Develon » Tue Sep 12, 2017 3:35 am

A few days ago, a friend of mine noticed that he was no longer able to access my FTP-server from his home. This was about the same time as I upgraded my NAS (a TS-253A using 2x3TB WD Red drives in Raid 1) to the latest firmware (4.3.3.0299 Build 20170901), but I cannot confirm wether or not this was done before he tried to access the NAS.
After digging through different settings and applications on the NAS, I've come up with the following:
Around the time of the problem, the CloudLink connection was offline. This was later solved with a restart of the NAS and router.
Looking at the "Auto Router Configuration", all enabled services have their status as "Ok", except for FTP/FTPES which says "Error". However, when I look in the router admin interface, port 20-21 over TCP are forwarded to the NAS.
I can connect to FTP and to the web admin interface (port 8080) using the LAN IP, but I'm unable to connect to the web admin interface using the external IP. I can however connect using MyDevice.myqnapcloud.com and I can also connect using the secure web admin interface (port 8081) with the external IP.
When I try to open Photo Station, it says The service is not enabled.

Good to know might also be that I've recently enabled the free SSL Certificate for my NAS

What do you guys think, is this a problem with the NAS settings or is my router about to give up?
Any help with solving these issues would be much appreciated!

Develon
New here
Posts: 3
Joined: Tue May 16, 2017 12:59 am

Re: Unable to access various services from outside the network

Postby Develon » Tue Sep 12, 2017 4:35 am

Update: The FTP problem was caused on my friend's side and once he had corrected that, he was once again able to connect to the NAS over FTP. One interesting note is that FTP/FTPES stil says "Error" in the Auto Router Configuration even though it works.
The web admin interface problem was solved by manually forwarding port 8080 in the router. When I had a look, only port 8081 was forwarded, but if that's due to some error in the Auto Router Configuration, I can't really tell since I hadn't tried the external IP before.

This only leaves me with one problem left, namely when I try to open Photo Station, it says The service is not enabled. Does anyone have an idea of where to begin with troubleshooting this problem? I've tried to stop and restart the service but that didn't solve it. Does Photo Station use a web GUI with a port that needs to be forwarded as well? Might this also problem be related to the Auto Router Configuration not being able to do its job?

User avatar
schumaku
Guru
Posts: 42646
Joined: Mon Jan 21, 2008 4:41 pm
Location: Kloten (Zurich), Switzerland -- Skype: schumaku
Contact:

Re: Unable to access various services from outside the network

Postby schumaku » Wed Sep 13, 2017 4:17 am

One possible reason that the FTP port(s) - essentially only FTP control 21/TCP plus the FTP passive data ports (as configured on the NAS FTP Server Advanced settings) mandatory fro FTPES usage - are manually forwarded on the router, the ARC is not allowed to override these settings. The diagnostics output of the Automatic Router Config could shed some light.

Photo Station is not available from anywhere - not on the LAN, not from the Internet?

And no, there is no dedicated port used for Photo Station.


Return to “Users' Corner”

Who is online

Users browsing this forum: No registered users and 6 guests