SSH Key ED25519 Asks for Password

Don't miss a thing. Post your questions and discussion about other uncategorized NAS features here.
Post Reply
filovirus
Getting the hang of things
Posts: 73
Joined: Wed Oct 06, 2010 10:55 pm

SSH Key ED25519 Asks for Password

Post by filovirus » Wed Jan 25, 2023 8:28 am

Hello,

I am trying to figure out how to get my public key to be recognized when SSHing into my qnap nas from a remote host. I keep seeing a password prompt despite my public key being in authorized keys with the right permissions. I had admin inactivated, but reactivated it and have the authorized_keys file in both /etc/.config/ssh/ and ~/.ssh/

I have been stepping through the qnap ssh keys document, but it looks pretty outdated. I have set the permissions exactly as documented, still no luck. Just used the same key on a linux system and it took 30 seconds and I was in, no password, using the same public key.
Thank you
TS-870 Pro EOL - JBOD/NAS Backup Remote
TS-873 QTS 5.0.0.2055 (5/13/2022) Seagate 6tb x 8 in RAID10

User avatar
dolbyman
Guru
Posts: 30483
Joined: Sat Feb 12, 2011 2:11 am
Location: Vancouver BC , Canada

Re: SSH Key ED25519 Asks for Password

Post by dolbyman » Wed Jan 25, 2023 8:39 am

Have you tried to just upload the keys via GUI ?

Username (top right in GUI)>Options>SSH Keys>add

filovirus
Getting the hang of things
Posts: 73
Joined: Wed Oct 06, 2010 10:55 pm

Re: SSH Key ED25519 Asks for Password

Post by filovirus » Wed Jan 25, 2023 11:34 am

I hadn't tried that. I just pasted the public key in and it worked. Thank you for the help.
TS-870 Pro EOL - JBOD/NAS Backup Remote
TS-873 QTS 5.0.0.2055 (5/13/2022) Seagate 6tb x 8 in RAID10

Post Reply

Return to “Miscellaneous”