RAID0 wont mount

Questions about SNMP, Power, System, Logs, disk, & RAID.
New here
Posts: 2
Joined: Sat Sep 08, 2012 8:09 am

RAID0 wont mount

Postby khasiar » Sat Sep 08, 2012 8:34 am

Hey guys,

i tried talking to skype support but no reply, do they use it?

anyway here is my issue

I am having a problem with my QNAP TS410, fw 3.6.2 build 1126T,
for some reason my RAID0 is not showing. i had 2x2TB RAID0 setup and copied half the data to an external HDD then inserted 4x2TB HDD and created a RAID5.
this worked fine and i copied from the external HDD to my new RAID5.

but when i reinserted the 2x2TB RAID0 drives in the same order the QNAP doesnt recognise them, i know a little linux so i tried SSHing and this is what i got:

when i run a FDISK using SSH i can see the 2x2TB drives, when i check MDADM it shows MD0 as active
but MD13 and MD9 are missing 2 parts (these raids use the extra partitions it makes from the 2x2TB disks). i suspect that this is from the extra 2 disk in the RAID5 and maybe this is why i cannot see any data.

if i do MDADM -- stop and then mdadm -A it starts both the disks and the raid but fdisk still shows that MD0 is 0bytes
if i try and mount md0 i get the following error
mount: wrong fs type, bad option, bad superblock on /dev/md0,

i checked dmesg
dmesg | grep md0
md: md0 stopped.
md: md0 stopped.
md0: setting max_sectors to 128, segment boundary to 32767
md0: unknown partition table
EXT3-fs: md0: couldn't mount because of unsupported optiona

ive got no idea whats going on. i can only conclude that the nas firmware saves the previous state and therefore is expecting my 4x2TB RAID5 and doesnt actually read the superblock on the disks.

i could really use help on this, ive got 2TB of data that i really dont want to lose, and the ironic part is that i wanted to change to a RAID5 so i wouldnt lose my data and look what happened :(

thanks in advanced.


User avatar
Posts: 42614
Joined: Mon Jan 21, 2008 4:41 pm
Location: Kloten (Zurich), Switzerland -- Skype: schumaku

Re: RAID0 wont mount

Postby schumaku » Sat Sep 08, 2012 3:27 pm

Just to clarify: You removed the 4x2 TB HDD with the RAID5? Now the NAS has no place to store any config or previous config.

Plugging just the 2 x 2 TB drives with the RAID0 in the same HDD slots and sequence, should bring up the NAS as configured before with these two drives. Confirm, there are no other HDD in place internally now.

Skype (text chat only) is handled just like any other support channel on a best effort base - be aware the time window is limited to business days:

09:30–24:00 (GMT + 08:00 Taipei Time, Mon. - Fri.)
Skype : qnapskype

New here
Posts: 2
Joined: Sat Sep 08, 2012 8:09 am

Re: RAID0 wont mount

Postby khasiar » Tue Sep 11, 2012 8:22 am

yes i understand that it is best effort but i sent a message on skype and didnt get responsed its been 3 days and nothing... maybe you need to employ support engineers with a better 'best effort' i work in support and we make sure that everything is at least responded to in a day, not leaving customers to believe whether or not there is even a support team?

anyway i sorted out the problem. it was most likely due to the other RAID partitions that the QNAP makes on its own MD9 & MD13. so the answer was not use the QNAP, i plugged 2x2TB drives (RAID0) into a PC and booted with a real version of linux, installed MDADM, assembled and mounted RAID and it worked. currently copying my files across and have tested and it seems ok.

considering that i bought this QNAP at officeworks means that any home user can purchase, if this is the case how would you have expected them to sort out this issue?

quite frankly if anything should happen to my QNAP i will buy netgear and hope they have a proper support team

Return to “System & Disk Volume Management”

Who is online

Users browsing this forum: No registered users and 5 guests