QNAP Hangs on Shutdown or Reboot

Questions about SNMP, Power, System, Logs, disk, & RAID.
eneguemd
New here
Posts: 2
Joined: Thu May 29, 2014 2:29 pm

Re: QNAP Hangs on Shutdown or Reboot

Post by eneguemd » Sun Dec 24, 2017 10:06 pm

I kept on experiencing this issue when I restart remotely my QNAP TS-853A. This is a duplicate copy of our data from our main to a remote office. The problem is when a new firmware is to be updated, it hangs at the restart. This has been going on for several months and I thought it something I can deal with. Apparently, it's becoming a nuisance.

Any permanent fix or solution for this?

djwoody
New here
Posts: 5
Joined: Sat Jan 14, 2017 5:36 pm

Re: QNAP Hangs on Shutdown or Reboot

Post by djwoody » Sat Apr 06, 2019 7:26 pm

OneCD wrote:
Sat Jul 08, 2017 8:53 am
That's great. Nicely done. :D

But I've just noticed - you've hardcoded the original kill symlink name. Please note: this can change depending on what else is being loaded. That's why my original suggestion had those 3 question marks. Each one acts as a wildcard meaning "a single unknown character in this position".

The QPKG creator can specify a preferred start number (and the preferred kill number is 1000 minus the start number) from 100 to 999 but the NAS assigns the next one available. So, your 105 may end up being something else if you add/remove QPKGs.

Maybe try this instead:

Code: Select all

mv /etc/rcK.d/QK???PlexMediaServer /etc/rcK.d/QK100PlexMediaServer

I am also having a problem with reboots hanging.
Please could you tell me where to paste this command (how do I get to into/etc/init.d/plex.sh).
Is it possible to paste this into the GUI somewhere?
Sorry, just not an expert.

Post Reply

Return to “System & Disk Volume Management”