[solved] Qsync with alternative HTTPS port does not work

Post your questions about myQNAPcloud service here.
Post Reply
themole
New here
Posts: 3
Joined: Tue May 28, 2013 2:57 am

[solved] Qsync with alternative HTTPS port does not work

Post by themole » Wed Aug 16, 2017 8:13 pm

I have some Qnap TS-419P II and I'm using Qsync for quite some time now. My current problem is, that I needed to change the port for accessing it from the internet to HTTPS/444 instead the default port, since reverse proxying my QNAP through a URL path (like https://www.example.com/nas) did also not work. I need to run new services below other paths (https://www.example.com/service1, https://www.example.com/service2, ...), so switching it back to the old config is not an option.

Qsync also states, that you can enter a port to be used after the domain the nas is accessible through, but the port I enter in Qsync settings (e.g. nas.example.com:444) is always deleted when I press OK and the default port 443 is tried to be used without success.

How can I solve my problem? I can live with two different solutions:

1. Making Qsync and the web-UI work with the path-variant https://www.example.com/nas
2. Making Qsync accept the non-standard port 444

Any ideas?

Thanks in advance.

Solution: After entering the new port (444) and exiting Qsync (I think for the third time) and restarting it, it could connect to my NAS again. But the port number 444 still does not show up in the settings. Don't ask me why and how it worked now...

khaihong
Starting out
Posts: 37
Joined: Fri Jan 15, 2016 7:24 am

Re: [solved] Qsync with alternative HTTPS port does not work

Post by khaihong » Fri May 18, 2018 11:26 am

Thanks for posting your solution. I just noticed yesterday that my Qsync was sitting at "Connecting...", couldn't figure it out and forgot that I had switched the admin https port about a week ago. Saw you post and added the new port to the client connection setting, restarted and voila.

Neophear
Starting out
Posts: 11
Joined: Fri Dec 23, 2016 3:25 am

Re: [solved] Qsync with alternative HTTPS port does not work

Post by Neophear » Mon Sep 07, 2020 2:53 pm

Thank you for posting your solution! I had been having problems with using a custom port too, and tried changing settings over and over without success. After reading your solution, I restarted the client, and it worked!

Post Reply

Return to “myQNAPcloud service”