need help for file sharing links/folders for remote access

Post your questions about myQNAPcloud service here.
Post Reply
User avatar
Moogle Stiltzkin
Ask me anything
Posts: 7380
Joined: Thu Dec 04, 2008 12:21 am
Location: Around the world....

need help for file sharing links/folders for remote access

Post by Moogle Stiltzkin » Fri May 25, 2018 11:14 am

I want to share folders/files via filestation.

So i share a sub directory, but when i tried using myqnapcloud, it didn't work.

but when using the smartlink method it works, why is that? Any ideas why the myqnapcloud method using dyndns does not work? yes i already port forwarded 443 to the correct NAS lan ip on router.

does anyone have a guide for this? i tried the video guides but they don't troubleshoot these types of issues i'm having :S

Yes i did get sharing to work via smartlink method, but i want to try getting the myqnapcloud dyndns method to work as well.

also what is the recommended setting to safely share? will people you share with be able to access the link, if it's set to private? i refrain from public, i don't want my page to be searchable :?


for the smartlink, that worked when i added friend to customized access control in cloudlink.

though earlier there was a status abnormal for cloudlink, had to reconnect cloudlink and update the dyndns to myqnapcloud, and that seemed to fix it.

Wheeljack77 wrote:That's probably because your VPN is likely using the same port 443 to transfer data as myqnapcloud. Not sure if it is possible, but one way you could get around the issue is to see if you have a port triggering setting on your router and set your router to access port 443 (just add it to the rules). Port triggering is better that port forwarding because it allows multiple devices or apps to use the setting while port forwarding only forwards one specific port to one specific device.

is this the reason? :'

i did test disabling qvpn, but it still didn't work. but then again i did not reboot the qnap or router after disabling qvpn if that was required.

Port Trigger allows you to temporarily open data ports when LAN devices require unrestricted access to the Internet. There are two methods for opening incoming data ports: port forwarding and port trigger. Port forwarding opens the specified data ports all the time and devices must use static IP addresses. Port trigger only opens the incoming port when a LAN device requests access to the trigger port. Unlike port forwarding, port trigger does not require static IP addresses for LAN devices. Port forwarding allows multiple devices to share a single open port and port trigger only allows one client at a time to access the open port.

found a guide here

by the way this guide here, does not mention anything about port forwarding... which ought to be crucial for use by the myqnapcloud dynsdns for your link to even work. ... le-station
[Main Server] QNAP TS-877 w. 4tb [ 3x HGST Deskstar NAS (HDN724040ALE640) & 1x WD RED NAS ] EXT4 Raid5 & 2 x m.2 SATA Samsung 850 Evo raid1 + 16gb ddr4 Crucial + QWA-AC2600 wireless adapter.
[Backup] QNAP TS-653A w. 5x 2TB Samsung F3 (HD203WI) EXT4 Raid5
[^] QNAP TS-659 Pro II 1x 4TB HGST Deskstar NAS
[^] QNAP TS-509 Pro w. 4x 1TB WD RE3 (WD1002FBYS) EXT4 Raid5
[^] QNAP TS-228 w. 1x 1TB WD RE3 (WD1002FBYS)
[^] QNAP TS-128
Mobile NAS TBS-453DX w. 2x Crucial MX500 500gb EXT4 raid1

Asus AC68U Router|100dl/50ul MBPS FTTH Internet | Windows 10, WC PC-Intel i7 920 Ivy bridge desktop (1x 512gb Samsung 850 Pro SSD + 1x 4tb HGST Ultrastar 7K4000)

Guides & articles
[Review] Moogle's QNAP experience
[Review] Moogle's TS-877 review

User avatar
Easy as a breeze
Posts: 384
Joined: Sun Jun 05, 2016 8:58 am
Location: Australia

Re: need help for file sharing links/folders for remote access

Post by » Wed Jun 06, 2018 9:14 pm

Have you had any success?

I'm behind a double NAT :-(

I also use QVPN with ProtonVPN

One suggestion for me was to put my second router into the DMZ of the first in order for the for DynDNS to work and use MYQnapCloud, but from the sounds of things even if I do that and forward port 443 (or port trigger) I'm still going to run into troubles.
QNAP TS-253Be 8GB, 2 x WD Red 6TB, & 1 x WD Red 6TB & WD 4TB, QM2-2S M.2 500GB SSD Cache Acceleration, QTS: 4.X.X

ASUS RT-AX88U WRT-Merlin Firmware 384.x.x (AMTM, Pixelserv, Entware, Diversion & Skynet),

2017 iMac 27" 5K i5 3.5GHz 64GB 1TB & Thunderbolt 3 500GB M.2 External Boot Drive Radeon Pro 575 4GB, Raspberry Pi (NextCloudPi) 6TB.

QVPN, Plex, Radar, Sonarr, Lidarr, NZBGet, NZBHydra 2, Download Station, QVR Pro, Duplicati, Bliss (Unlimited)

Post Reply

Return to “myQNAPcloud service”