Unable to access NAS as guest following firmware update to v4.3.6.0979

FTP Server, File Server, DDNS, SAMBA, AFP, NFS
ButlerSAB49
New here
Posts: 7
Joined: Mon Jun 24, 2019 9:40 pm

Re: Unable to access NAS as guest following firmware update to v4.3.6.0979

Post by ButlerSAB49 » Fri Jul 05, 2019 5:02 pm

So support have responded and confirm they accept the issue has been introduced following the latest firmware update, still in a waiting game as the advice is wait until the next firmware release but have also state there is no definite schedule for the release of a new firmware with fix! At least they've accepted and admit the problem but no guarantee of when it will get sorted... So workaround until resolved I guess! Response attached...
You do not have the required permissions to view the files attached to this post.

zebulon-ufh
New here
Posts: 3
Joined: Fri Jun 28, 2019 2:07 am

Re: Unable to access NAS as guest following firmware update to v4.3.6.0979

Post by zebulon-ufh » Fri Jul 05, 2019 11:11 pm

Some days ago, I've contacted the german QNAP support and just now indeed got an answer:

Hallo Hr. ******
der Fehler wurde bestätigt und gelöst, in der Firmware 4.3.6.0993 wird es wieder wie gewohnt funktionieren.

My translation:
Dear Mr. *****
the bug has been confirmed and solved, within firmware 4.3.6.0993 it will work again as usual.

Let's hope that helped!

gwodus
New here
Posts: 3
Joined: Fri Dec 16, 2011 10:04 pm

Re: Unable to access NAS as guest following firmware update to v4.3.6.0979

Post by gwodus » Wed Jul 10, 2019 3:03 am

Oh wow. You guys are awesome. Thank you so much (especially BrutisNZ). I was ready to throw in the towel and then I found this thread!!

BrutisNZ
Starting out
Posts: 27
Joined: Wed Feb 07, 2018 7:12 pm
Location: New Zealand

Re: Unable to access NAS as guest following firmware update to v4.3.6.0979

Post by BrutisNZ » Thu Jul 11, 2019 12:45 pm

I can confirm that Guest access is working correctly again in the new Firmware 4.3.6.0993 build 20190704

Thanks to a QNAP programmer somewhere.
TS-453B 16GB x2 Seagate 10TB ST10000NE0004
(yes - 16GB and it works without any problems, so far)

drivie
Starting out
Posts: 14
Joined: Sun Jun 23, 2019 6:19 am

Re: Unable to access NAS as guest following firmware update to v4.3.6.0979

Post by drivie » Thu Jul 11, 2019 3:51 pm

BrutisNZ wrote:
Thu Jul 11, 2019 12:45 pm
I can confirm that Guest access is working correctly again in the new Firmware 4.3.6.0993 build 20190704

Thanks to a QNAP programmer somewhere.
Thanks for the update.

A special thanks to you for your work-around which really saved a bunch of us!

bili_vjdj
First post
Posts: 1
Joined: Fri Jul 12, 2019 1:01 am

Re: Unable to access NAS as guest following firmware update to v4.3.6.0979

Post by bili_vjdj » Fri Jul 12, 2019 1:11 am

Hello.
I have the same problem.
I found this topic and information that the new version of the software will be good.
Today I have updated to version 4.3.6.0993 and I still have this problem.

BrutisNZ
Starting out
Posts: 27
Joined: Wed Feb 07, 2018 7:12 pm
Location: New Zealand

Re: Unable to access NAS as guest following firmware update to v4.3.6.0979

Post by BrutisNZ » Fri Jul 12, 2019 8:04 am

bili_vjdj wrote:
Fri Jul 12, 2019 1:11 am
Hello.
I have the same problem.
I found this topic and information that the new version of the software will be good.
Today I have updated to version 4.3.6.0993 and I still have this problem.
The problem this Post discusses has been resolved so the information here does not relate to the problem you are having.

I would suggest you open a new POST and give details of your problem so others may help you.
TS-453B 16GB x2 Seagate 10TB ST10000NE0004
(yes - 16GB and it works without any problems, so far)

anders22
New here
Posts: 4
Joined: Fri Jul 12, 2019 9:57 pm

Re: Unable to access NAS as guest following firmware update to v4.3.6.0979

Post by anders22 » Fri Jul 12, 2019 10:07 pm

@BrutisNZ: Nope, that's not true.....I also still have the same problem...
It worked perfectly before Qnap ** it up, and still don't work.
I will create a case to them tomorrow.

megaabite
Starting out
Posts: 10
Joined: Wed Sep 26, 2018 11:22 pm

Re: Unable to access NAS as guest following firmware update to v4.3.6.0979

Post by megaabite » Fri Jul 12, 2019 10:54 pm

anders22 wrote:
Fri Jul 12, 2019 10:07 pm
@BrutisNZ: Nope, that's not true.....I also still have the same problem...
It worked perfectly before Qnap ** it up, and still don't work.
I will create a case to them tomorrow.
Try toggling permissions and settings.

After updating to 0.993:
In "Win/Mac/NFS", "Advanced Options", toggled "Restrict anonymous users from accessing SMB folders" to "Enabled(strict)" then "Disabled"
In "Edit Shared Folder Permission" for all shared folders, toggled "Guest Access Right" to "Deny Access" then "Full Access"

Guest access via SMB now seems to be working

BrutisNZ
Starting out
Posts: 27
Joined: Wed Feb 07, 2018 7:12 pm
Location: New Zealand

Re: Unable to access NAS as guest following firmware update to v4.3.6.0979

Post by BrutisNZ » Sat Jul 13, 2019 7:15 am

anders22 wrote:
Fri Jul 12, 2019 10:07 pm
@BrutisNZ: Nope, that's not true.....I also still have the same problem...
It worked perfectly before Qnap ** it up, and still don't work.
I will create a case to them tomorrow.
Huh? Sorry but it is true. The reason for the problem discussed here has been fixed. I have checked their rewritten code and it is FIXED!

I'll just repeat, if that was not clear. If you (or anyone else) is still having a problem then it is not related to what has been discussed here.

Create another POST with your problem and stop polluting this POST with nonsense about it not being fixed.
Last edited by BrutisNZ on Sat Jul 13, 2019 7:23 am, edited 1 time in total.
TS-453B 16GB x2 Seagate 10TB ST10000NE0004
(yes - 16GB and it works without any problems, so far)

BrutisNZ
Starting out
Posts: 27
Joined: Wed Feb 07, 2018 7:12 pm
Location: New Zealand

Re: Unable to access NAS as guest following firmware update to v4.3.6.0979

Post by BrutisNZ » Sat Jul 13, 2019 7:22 am

megaabite wrote:
Fri Jul 12, 2019 10:54 pm
Try toggling permissions and settings.

After updating to 0.993:
In "Win/Mac/NFS", "Advanced Options", toggled "Restrict anonymous users from accessing SMB folders" to "Enabled(strict)" then "Disabled"
In "Edit Shared Folder Permission" for all shared folders, toggled "Guest Access Right" to "Deny Access" then "Full Access"

Guest access via SMB now seems to be working
Actually that won't help. The new (fixed) code in smb.sh will ALWAYS correctly set smb.conf no matter what was previously set.
Of course it's a good idea to check that "Restrict anonymous users from accessing SMB folders" is correctly set in the first place :)
TS-453B 16GB x2 Seagate 10TB ST10000NE0004
(yes - 16GB and it works without any problems, so far)

User avatar
Don
Guru
Posts: 11956
Joined: Thu Jan 03, 2008 4:56 am
Location: Long Island, New York
Contact:

Re: Unable to access NAS as guest following firmware update to v4.3.6.0979

Post by Don » Sat Jul 13, 2019 8:06 am

Locked. If you are having similar issues then open a new topic.
Read the Online Manuals and use the forum search feature before posting.

It is a recommended to use RAID and have external backups. RAID will protect you from disk failure, keep your system running, and data accessible while the disk is replaced and the RAID rebuilt. Backups will allow you to recover data that is lost or corrupted, or from system failure. One does not replace the other.

Submit bugs and feature requests to QNAP via their Helpdesk app.

NAS: TVS-882BR | F/W: 4.3.6.0895 | 40GB | 2 x M.2 SATA RAID 1 (System/VMs) | 4 x M.2 NMVe QM2-4P-384A RAID 5 (Cache) | 5 x 4TB HDD RAID 6 (Data) | 1 x Blu-ray
NAS: TVS-663 | F/W: 4.3.6.0993 | 16GB | 2 x M.2 NMVe QM2-2P RAID 1 (Cache) | 4 x 4TB RAID 5
Apps: Boinc, Squid, DNSMasq, PLEX, iDrive, QVPN, QLMS, MP3fs, HBS, Entware, DLstation, +others

Locked

Return to “File Sharing”