Unable to reconnect iscsi target after Qnap upgrade

iSCSI related applications
Post Reply
p.bracciotti
New here
Posts: 6
Joined: Wed Aug 21, 2019 4:41 pm

Unable to reconnect iscsi target after Qnap upgrade

Post by p.bracciotti » Wed Aug 21, 2019 5:16 pm

Hello.

My Qnap model TS-453U was upgrated to the latest firmare versione 4.3.6.0993 from an older versione 4.3.3.xxx.
Before, the iscsi destination worked well in automatic reconnection on a Windows 10 client.
After this, the connection to target destination on Qnap work fine, and the status is "connected" (both on qnap and iscsi client initiator), but on "Volumes and Devices" the autoconfiguration don't do anything.

The only issue i find is a message in a "Network and Virtual Switch" configuration as shown in one attach; and in the other i attach the network configuration.

Any suggestions?
Many thanks.

Pierluigi.
You do not have the required permissions to view the files attached to this post.

User avatar
storageman
Experience counts
Posts: 4829
Joined: Thu Sep 22, 2011 10:57 pm

Re: Unable to reconnect iscsi target after Qnap upgrade

Post by storageman » Wed Aug 21, 2019 8:50 pm

So you are connecting on x.x.83.65 and can ping it from host?
What is the status of the LUN, is it connected to target?

p.bracciotti
New here
Posts: 6
Joined: Wed Aug 21, 2019 4:41 pm

Re: Unable to reconnect iscsi target after Qnap upgrade

Post by p.bracciotti » Wed Aug 21, 2019 9:52 pm

Yes i can ping the Nas IP from my Win10 client.
The status of the Lun is "connected" to my Win10 IP.

User avatar
storageman
Experience counts
Posts: 4829
Joined: Thu Sep 22, 2011 10:57 pm

Re: Unable to reconnect iscsi target after Qnap upgrade

Post by storageman » Wed Aug 21, 2019 10:47 pm

p.bracciotti wrote:
Wed Aug 21, 2019 9:52 pm
Yes i can ping the Nas IP from my Win10 client.
The status of the Lun is "connected" to my Win10 IP.
No, I mean on the NAS status, post a pic of the LUN/target screen?
I would try recreating a new target and connect the LUN again.

Firmware updates always seem to mess up ISCSI

p.bracciotti
New here
Posts: 6
Joined: Wed Aug 21, 2019 4:41 pm

Re: Unable to reconnect iscsi target after Qnap upgrade

Post by p.bracciotti » Wed Aug 21, 2019 11:20 pm

I post the target list.
There are two target: both don't work
The second is now connected with my pc.

Can target recreation lose the data contained?
You do not have the required permissions to view the files attached to this post.

User avatar
storageman
Experience counts
Posts: 4829
Joined: Thu Sep 22, 2011 10:57 pm

Re: Unable to reconnect iscsi target after Qnap upgrade

Post by storageman » Thu Aug 22, 2019 12:00 am

p.bracciotti wrote:
Wed Aug 21, 2019 11:20 pm
I post the target list.
There are two target: both don't work
The second is now connected with my pc.

Can target recreation lose the data contained?
Of course not. LUNs and targets are independent, the only way you might corrupt data is to disconnect while IO is going on.

Disconnect it at host first

I imagine iscsi.conf connections is corrupted in some way.

p.bracciotti
New here
Posts: 6
Joined: Wed Aug 21, 2019 4:41 pm

Re: Unable to reconnect iscsi target after Qnap upgrade

Post by p.bracciotti » Thu Aug 22, 2019 3:17 pm

Ok, what is the correct procedure to do?.

User avatar
storageman
Experience counts
Posts: 4829
Joined: Thu Sep 22, 2011 10:57 pm

Re: Unable to reconnect iscsi target after Qnap upgrade

Post by storageman » Thu Aug 22, 2019 4:10 pm

You should know this - you need to read the manual and familiarise yourself with all the ISCSI options
Disconnect at ISCSI Initiator host

On Qnap ISCSI Storage, Actions, Deactivate
Then create a new target, then reattach the LUN
Delete the old target
Then reconnect at host

Post Reply

Return to “iSCSI – Target & Virtual Disk”