Web Connectivity - can't access my NAS through xxx.myqnapcloud.com

Post your questions about myQNAPcloud service here.
Post Reply
godded
New here
Posts: 3
Joined: Thu Feb 13, 2020 11:05 am

Web Connectivity - can't access my NAS through xxx.myqnapcloud.com

Post by godded » Thu Feb 13, 2020 12:09 pm

Hello QNAP community,

I've had my TS-451+ (Firmware 4.4.1.1146) for almost 2 years now and am very happy with it.
However, I've been struggling for weeks with getting a direct connection to my NAS from outside my LAN.
I can successfully connect using the https://qlink.to/xxx link, but I can't get DDNS / xxx.myqnapcloud.com to work, neither can I connect using my public IP.

I've tried with uPNP and with manual port forwarding, set my NAS as the DMZ host IP on my TP-Link Archer C7 (only router in my network), but to no avail.

My router also shows failed we connectivity.

Image

I'm pretty good with databases and hardware, but I'm not really into network troubleshooting.
Can someone maybe point me into a direction in order to resolve my connectivity woes?

Best regards,
Julian

dolbyman
Guru
Posts: 19699
Joined: Sat Feb 12, 2011 2:11 am
Location: Vancouver BC , Canada

Re: Web Connectivity - can't access my NAS through xxx.myqnapcloud.com

Post by dolbyman » Thu Feb 13, 2020 12:32 pm

don't do it..

look at this thread and see what can happen
viewtopic.php?f=345&t=153044

get a good router with a built in vpn server (e.g. asus 68 or 86) and use the vpn server for remote access to your nas

godded
New here
Posts: 3
Joined: Thu Feb 13, 2020 11:05 am

Re: Web Connectivity - can't access my NAS through xxx.myqnapcloud.com

Post by godded » Thu Feb 13, 2020 12:57 pm

Considering the amount of posts you have on this forum, I might just have to assume this is one of those points in life, where I should accept good advice when it is given.

I guess I'll figure out another way for my FTP server.
Thank you.

dolbyman
Guru
Posts: 19699
Joined: Sat Feb 12, 2011 2:11 am
Location: Vancouver BC , Canada

Re: Web Connectivity - can't access my NAS through xxx.myqnapcloud.com

Post by dolbyman » Thu Feb 13, 2020 1:48 pm

sorry..it's just good practice to keep the web away from your nas

at max...look into containers or vms ..that way a hack would be contained in a virtual environment

zbryant
Starting out
Posts: 22
Joined: Sat Jul 09, 2011 9:03 pm

Re: Web Connectivity - can't access my NAS through xxx.myqnapcloud.com

Post by zbryant » Sun Mar 01, 2020 11:07 pm

I'm not sure if it will be the answer you need or not. But I found out something on my NAS.

Under Control Panel, System, Security;
In the Allow/Deny List, If I choose allow all, My system will pass the test for Web connectivity that you are talking about. However when I choose the last option, to "allow connections from the list only", the test fails. However, on mine, listed entries are only local to the network.

I don't know if this is a bug, or if it is how it is intended to work. But, if yours responds the same way, it may answer some questions about what is or isn't working.
Ethernet 1 subnet 192.168.2.*
AT&T uVerse i38HG 6MB/sec DMZ'd to D-Link DGL-4100
Drop 1: SLM2008 switch
PopcornHour C200 Media player using NFS LG BD-690 3D BluRay
Drop 2: DGS-2205 switch and Linksys WAP4410N Wifi-N AP
Sony Vaio Windows 7 64-bit Laptop 2 X 2TB WD Worldbook NAS + 2 TB WD Worldbook II NAS
Drop 3: DGS-1008G switch
Model: QNAP TS-419P+ with default shares Raid 5 (2 X 2TB Seagate ST32000542AS CC34 + 2 X 2TB WDC WD20EADS-00R6B0 01.0)
Firmware: 3.8.2 Build 20130301 Musicstation 3.1 Photostation 2.3 Optware 0.99.163 Asterisk 1.4.22.1b Surveillance Station
Ethernet 2 subnet 192.168.3.*
Linksys WRT54G Wireless Router 2 X (FI8903W-04W-05W) Security Cameras

godded
New here
Posts: 3
Joined: Thu Feb 13, 2020 11:05 am

Re: Web Connectivity - can't access my NAS through xxx.myqnapcloud.com

Post by godded » Mon Mar 02, 2020 9:16 am

Thank you for the input zbryant, it did however not work for me.
Don't worry about it. I've made other arrangements and will keep my NAS for LAN use only.

Post Reply

Return to “myQNAPcloud service”