Lets Encrypt Port 80 issue

Post your questions about myQNAPcloud service here.
User avatar
Experience counts
Posts: 1189
Joined: Tue May 19, 2009 2:08 am
Location: Norway, Oslo

Re: Lets Encrypt Port 80 issue

Post by oyvindo » Mon Jan 20, 2020 10:17 pm

This thread has been quiet for over a year now.
What has happened? Are all issues solved, or have all QNAP customers given up on trying to implement Let's Encrypt certificates?

Well, I have experimented a lot lately to try to get things working, with very mixed results. Some success, mostly failure.
The strange thing is that the Certificate&Private Key feature in the QNAP is not stable, in the sense that sometimes it works, sometimes not.
Repeating exactly the same procedure over and over again works 2-3 out of 10 times and the remaining attempts fail.
I have even been successfully able to generate a Let's Encrypt certificate with alternative names added, but only once. I could never repeat that successfully again.

The fact that this works sometimes, but fails most of the time, is quite annoying. Is this a QNAP problem or is it the Let's Encrypt service that is overloaded?

How to tell?

First post
Posts: 1
Joined: Sat Mar 28, 2020 5:49 am

Re: Lets Encrypt Port 80 issue

Post by Zo0x_ » Sat Mar 28, 2020 5:59 am


I came across this thread whilst looking into this problem myself and I can say that after much frustration I have managed to get a valid Lets Encrypt certificate using the "certificate & keys" section.

My nas has both port 80 and 443 forwarded, always has done, so I know thats not the problem. I had the UI listening on 80 and 443 with HTTPS forced, however to fix the certs I had to change that.

To get it working I had to set the built in web server (under network & file services) to run on port 80 (no need to enable SSL) then run this tool, it took a while to get the certificate the first time but eventually worked (it was likely checking for each of my aliases I presume).

I can repeat this with success, I currently have my "qnapcloud" domain as the common name, then 3 aliases separated by commas in the alt name field, works like a charm so far.

Hope this helps anyone having similar issues! :)

First post
Posts: 1
Joined: Sat Jun 20, 2020 8:50 am

Re: Lets Encrypt Port 80 issue

Post by sarrcrunners » Sat Jun 20, 2020 10:19 am

Tried the replace SSL setting for a Lets Encrypt over and over but never worked. I had my "qnapcloud" domain and 1 alias being used. Reversed them tried one or other all failed. I was able to get success using https://gethttpsforfree.com/ for a new certificate.Then use the import certificate option. But its only for 3 months..

Post Reply

Return to “myQNAPcloud service”