Allowing a new initiator to iSCSI target

iSCSI related applications
Post Reply
nico2f
First post
Posts: 1
Joined: Thu May 16, 2024 3:34 am

Allowing a new initiator to iSCSI target

Post by nico2f »

Hi everyone, I'm new to QNAP and could use some assistance.

The last admin quit, and I've inherited their role, but I'm encountering difficulty mounting a unit in my QNAP server through NFS on a Proxmox Virtual Environment. My goal is to store VM backups there, but I'm receiving this error: "create storage failed: mount error: mount.nfs: access denied by server while mounting IPADDRESS:/path/path/ (500)."

Upon inspecting the iSCSI target properties, I noticed three devices connected. However, when I checked the initiators tab, everything was grayed out, with 'Allow connections from the list only' checked, and only one initiator listed.

I disabled the iSCSI target, which allowed me to modify the properties. Yet, whenever I add an initiator to the list, save, and attempt to switch back to 'allow all connections,' it reverts to 'allow connections from list only' and turns gray again.

Since this is my first time working with QNAP, I'm uncertain if my approach is correct. My assumption is that I need to allow the IP address of the PVE to connect to QNAP, but I'm unsure where to find this option or how to proceed.

Could anyone offer assistance, please? Thanks in advance.
User avatar
dolbyman
Guru
Posts: 35634
Joined: Sat Feb 12, 2011 2:11 am
Location: Vancouver BC , Canada

Re: Allowing a new initiator to iSCSI target

Post by dolbyman »

NAS model and current firmware used would be important as QNAP has many models and several versions of ISCSI interfaces
FSC830
Experience counts
Posts: 2053
Joined: Thu Mar 03, 2016 1:11 am

Re: Allowing a new initiator to iSCSI target

Post by FSC830 »

And in addition: iSCSI is totally different from a mount with NFS? So if a mount.nfs error message appears, iSCSI is not the issue.

Regards
Post Reply

Return to “iSCSI – Target & Virtual Disk”