[ QApache 2.4.29 + PHP 7.1.11 ] WebServer with PHP and PECL

This is the best place for community developers to publish their genius work. Your Apps enrich the QNAP Turbo NAS.
User avatar
QNAP_Stephane
Experience counts
Posts: 2035
Joined: Wed Mar 27, 2013 1:00 am

[ QApache 2.4.29 + PHP 7.1.11 ] WebServer with PHP and PECL

Postby QNAP_Stephane » Mon May 18, 2015 12:12 am

Image

Source : http://httpd.apache.org/ - http://php.net/ - http://pecl.php.net/

Download :

[ Apache 2.4.27 + PHP 7.1.8 + PECL Extension ]

x64 version : http://www.positiv-it.fr/QNAP/APP/Qapache_2.4.27.718_x86_64.qpkg.zip
phpinfo sample : http://www.positiv-it.fr/QNAP/PAGE/phpinfo()_2427_718_x64.html

x41 version : http://www.positiv-it.fr/QNAP/APP/Qapache_2.4.27.718_arm-x41.qpkg.zip
phpinfo sample : http://www.positiv-it.fr/QNAP/PAGE/phpinfo()_5.4.27_7.1.8_armx41.html

[ Apache 2.4.27 + PHP 7.1.9 + PECL Extension ]

x64 version : http://www.positiv-it.fr/QNAP/APP/Qapache_2.4.27.719_x86_64.qpkg.zip
phpinfo sample : http://www.positiv-it.fr/QNAP/PAGE/phpinfo()2427_719_x64.html

[ Apache 2.4.27 + PHP 7.1.10 + PECL Extension ]

x64 version : http://www.positiv-it.fr/QNAP/APP/Qapache_2.4.277110_x86_64.qpkg.zip
phpinfo sample : http://www.positiv-it.fr/QNAP/PAGE/phpinfo()_2427_7110_x64.html

x41 version :http://www.positiv-it.fr/QNAP/APP/Qapache_2.4.277110_arm-x41.qpkg.zip
phpinfo sample : http://www.positiv-it.fr/QNAP/PAGE/phpinfo()_2427_7110_x41.html

[ Apache 2.4.28 + PHP 7.1.10 + PECL Extension ]

x64 version : http://www.positiv-it.fr/QNAP/APP/Qapache_2.4.287110_x86_64.qpkg.zip

[ Apache 2.4.29 + PHP 7.1.11 + PECL Extension ]

x64 version : https://www.qnapclub.eu/provider.php/qpkg_dwl/460713/Qapache_2.4.297111_x86_64.qpkg
phpinfo sample : http://www.positiv-it.fr/QNAP/PAGE/phpinfo()2429_7111_x64.html

x41 version : https://www.qnapclub.eu/provider.php/qpkg_dwl/460718/Qapache_2.4.297111_arm-x41.qpkg

Note :

Before installing

Manage in my own Webui (dont forget to restart application to make change apply )

  • httpd.conf
  • SSL.conf
  • php.ini
  • error.log

HTTP = port 88
HTTPS = port 448

Host your website in your htdocs share

added :

Mod.svn (subversion)
Mod.security2
Mod_Mono (Beta)
Mod_Python
Mod_WSGY

Also include in this package (/opt/Qapache/bin )

Code: Select all

NodeJS v12
Ruby 2.2.1
Git 2.4.3
Dovecot
Subversion 1.8.13
ImageMagick 6.9.1
Coreutil
Propc
util linux 2.22
e2fsprog
Last edited by QNAP_Stephane on Sun Oct 29, 2017 3:55 pm, edited 37 times in total.
--------------------------------------------------------------------------
Follow QnapClub - https://www.facebook.com/qnapclub/

User avatar
QNAP_Stephane
Experience counts
Posts: 2035
Joined: Wed Mar 27, 2013 1:00 am

Re: [ QApache 2.4.x + PHP 5.6.x ] WebServer and more

Postby QNAP_Stephane » Mon Jun 15, 2015 7:19 pm

Code: Select all

php updated to 5.6.10
Sqlite updated to 3.10.8
nmap added
Go added (experimental)
OpenSSL updated to 1.0.2c
Git Updated to 2.4.3
--------------------------------------------------------------------------
Follow QnapClub - https://www.facebook.com/qnapclub/

BigMacBen
Starting out
Posts: 20
Joined: Thu Apr 11, 2013 2:56 am

Re: [ QApache 2.4.12 + PHP 5.6.10 ] WebServer and more

Postby BigMacBen » Fri Oct 09, 2015 1:39 am

Does this QPKG also work with QTS 4.2 final?

CylonCenturion

Re: [ QApache 2.4.12 + PHP 5.6.10 ] WebServer and more

Postby CylonCenturion » Sun Dec 20, 2015 7:37 pm

QNAP_Stephane wrote:Image
Source : http://httpd.apache.org/ - http://php.net/ - http://pecl.php.net/

Download :

[ Apache 2.4.12 + PHP 5.6.9 + PECL Extension ]

x86 version : http://www.positiv-it.fr/QNAP/APP/Qapache_2.4.12-php569_x86.qpkg.zip

[ Apache 2.4.12 + PHP 5.6.10 + PECL Extension ]

x86 version : http://www.positiv-it.fr/QNAP/APP/Qapache_2.4.12.1-php5610_x86.qpkg.zip

Note :

Before installing

Create a share called "htdocs"

Manage in my own Webui (dont forget to restart application to make change apply )

  • httpd.conf
  • SSL.conf
  • php.ini
  • error.log

HTTP = port 88
HTTPS = port 448

Host your website in your htdocs share

added :

Mod.svn (subversion)
Mod.security2
Mod_Mono (Beta)
Mod_Python
Mod_WSGY

Also include in this package (/opt/Qapache/bin )

Code: Select all

NodeJS v12
Ruby 2.2.1
Git 2.4.3
Dovecot
Subversion 1.8.13
ImageMagick 6.9.1
Coreutil
Propc
util linux 2.22
e2fsprog



PHP INFO PREVIEW : http://www.positiv-it.fr/QNAP/PAGE/php569.htm


Is this save to install on a TS-253 Pro 8Gb FW 4.2.0 B1118?
And is this a replacement for all services?

User avatar
QNAP_Stephane
Experience counts
Posts: 2035
Joined: Wed Mar 27, 2013 1:00 am

Re: [ QApache 2.4.12 + PHP 5.6.10 ] WebServer and more

Postby QNAP_Stephane » Sun Dec 20, 2015 9:23 pm

it will work, but run aside all services

it uses his own process
--------------------------------------------------------------------------
Follow QnapClub - https://www.facebook.com/qnapclub/

wtsming
Starting out
Posts: 13
Joined: Sun Dec 07, 2014 11:39 pm

Re: [ QApache 2.4.12 + PHP 5.6.10 ] WebServer and more

Postby wtsming » Wed Feb 03, 2016 1:11 am

I downloaded the qpkg but failed to install through App Center GUI, it just show error

The following items could not be installed. Please see the system logs for more details.
- Qapache_2.4.12.1-php5610_x86.qpkg.zip

My QNAP is TS-251, QTS 4.2.0 public version, anything wrong with me?

User avatar
QNAP_Stephane
Experience counts
Posts: 2035
Joined: Wed Mar 27, 2013 1:00 am

Re: [ QApache 2.4.12 + PHP 5.6.10 ] WebServer and more

Postby QNAP_Stephane » Wed Feb 03, 2016 1:13 am

wtsming wrote:I downloaded the qpkg but failed to install through App Center GUI, it just show error

The following items could not be installed. Please see the system logs for more details.
- Qapache_2.4.12.1-php5610_x86.qpkg.zip

My QNAP is TS-251, QTS 4.2.0 public version, anything wrong with me?


unzip it first
--------------------------------------------------------------------------
Follow QnapClub - https://www.facebook.com/qnapclub/

wtsming
Starting out
Posts: 13
Joined: Sun Dec 07, 2014 11:39 pm

Re: [ QApache 2.4.12 + PHP 5.6.10 ] WebServer and more

Postby wtsming » Wed Feb 03, 2016 1:25 am

It's working, thanks a lot.

wtsming
Starting out
Posts: 13
Joined: Sun Dec 07, 2014 11:39 pm

Re: [ QApache 2.4.12 + PHP 5.6.10 ] WebServer and more

Postby wtsming » Wed Feb 03, 2016 10:17 pm

Can I still use the apache to connect MySQL server of QNAP ?

User avatar
QNAP_Stephane
Experience counts
Posts: 2035
Joined: Wed Mar 27, 2013 1:00 am

Re: [ QApache 2.4.12 + PHP 5.6.10 ] WebServer and more

Postby QNAP_Stephane » Wed Feb 03, 2016 11:46 pm

wtsming wrote:Can I still use the apache to connect MySQL server of QNAP ?


yes
--------------------------------------------------------------------------
Follow QnapClub - https://www.facebook.com/qnapclub/

Kodauk
New here
Posts: 7
Joined: Sun Feb 07, 2016 10:24 am

Re: [ QApache 2.4.12 + PHP 5.6.10 ] WebServer and more

Postby Kodauk » Sun Mar 13, 2016 6:41 pm

your package looks perfect for me! Do you provide a ARM-Version too? thx

User avatar
QNAP_Stephane
Experience counts
Posts: 2035
Joined: Wed Mar 27, 2013 1:00 am

Re: [ QApache 2.4.12 + PHP 5.6.10 ] WebServer and more

Postby QNAP_Stephane » Mon Mar 14, 2016 1:42 am

ArmV7 , may be feasible with pain
--------------------------------------------------------------------------
Follow QnapClub - https://www.facebook.com/qnapclub/

BigMacBen
Starting out
Posts: 20
Joined: Thu Apr 11, 2013 2:56 am

Re: [ QApache 2.4.12 + PHP 5.6.10 ] WebServer and more

Postby BigMacBen » Tue Mar 22, 2016 8:44 pm

Is there an update planned to 2.4.18 with PHP 7? That would be great =)

Kodauk
New here
Posts: 7
Joined: Sun Feb 07, 2016 10:24 am

Re: [ QApache 2.4.12 + PHP 5.6.10 ] WebServer and more

Postby Kodauk » Wed Mar 23, 2016 7:35 pm

QNAP_Stephane wrote:ArmV7 , may be feasible with pain


wow ArmV7 would be great! Maybe you can give it a try with the next update :) ?

User avatar
QNAP_Stephane
Experience counts
Posts: 2035
Joined: Wed Mar 27, 2013 1:00 am

Re: [ QApache 2.4.12 + PHP 5.6.10 ] WebServer and more

Postby QNAP_Stephane » Wed Mar 23, 2016 8:37 pm

BigMacBen wrote:Is there an update planned to 2.4.18 with PHP 7? That would be great =)


not sure last time i had issue upgrading Apache core (may be due to glibc in the toolchain), but php should be upgradable, even if i should move some extensions due to directory change

for armV7, i need a lot of time to do it ... a real pain
--------------------------------------------------------------------------
Follow QnapClub - https://www.facebook.com/qnapclub/


Return to “Community Apps”

Who is online

Users browsing this forum: No registered users and 7 guests