Fail to update RSS feeds (0x6013)

Post your questions about BT download, FTP download, HTTP download, or QGet download software here.
Locked
ficheirosecreto
New here
Posts: 2
Joined: Mon Oct 13, 2014 4:03 am

Fail to update RSS feeds (0x6013)

Post by ficheirosecreto » Tue Nov 03, 2015 7:09 am

I'am having this error: "Fail to update RSS feeds (0x6013)" on adding RSS in Download Station V4.2.0
QNAP firmware is 4.2.0 Build 20151023

RSS added before 4.2.0 upgrade (4.1.x version) are working, but now I cannot add new ones.

This was fixed on: viewtopic.php?f=151&t=113346&hilit=0x6013 in beta and https://www.qnap.com/qts/4.2-release-note/v1/ in stable version.

Anyone can help to fix this?

pvenneker
New here
Posts: 3
Joined: Tue Sep 13, 2011 4:53 pm

Re: Fail to update RSS feeds (0x6013)

Post by pvenneker » Fri Nov 06, 2015 3:21 pm

Same problem here. Downloads not starting from rss feed. Fix needed!!

alobbs
New here
Posts: 2
Joined: Tue Dec 15, 2015 11:56 pm

Re: Fail to update RSS feeds (0x6013)

Post by alobbs » Wed Dec 16, 2015 12:01 am

Just hit that exact problem. Some RSS feeds work, some don't (with that error code). When checked with wget, the RSS URL is correct and the response a valid RSS stream.
Running 4.2.0 Build 20151118 on a TS-453 Pro.

User avatar
Toxic17
Ask me anything
Posts: 5418
Joined: Tue Jan 25, 2011 11:41 pm
Location: Planet Earth
Contact:

Re: Fail to update RSS feeds (0x6013)

Post by Toxic17 » Wed Dec 16, 2015 12:04 am

if you have not already done so, please raise a ticket with QNAP, so they can be notified of the issue.
Regards Simon

QTS 4.x User Guidex

QNAP Club Repository
Submit a ticket • QNAP Helpdesk
QNAP Tutorials, User Manuals, FAQs, Downloads, Wiki
When you ask a question, please include the following


NAS: TS-473-32GB QM2-2P QXG-10G1T 4.4.2.1354 • TVS-463-16GB 4.4.2.1354 QM2-2S10G1TB • TS-459 Pro 2GB 4.2.6 • TS-121 4.3.3.1161 • APC Back-UPS ES 700G •
QPKG's: Plex 1.19.3 • Apache73 v2443.74070 • QSonarr 3.0.3.809 • QNBZGet 21.0 • phpMyAdmin 5.0.2 • Qmono 6.80.105 • McAfee 3.1.0 -6010 • HBS 3.0.200424 • LEgo v3.6.0
Network: VM Hub 3.0 <500/35> • UniFi USG Pro 4 • UniFi USW-16-150W • UniFi USW-8-60W • UniFi CloudKey Gen2+ • UniFi G3-Flex • UAP AC Pro • UAP AC Lite • SLM2008 • Dell 7050 MFF •

alobbs
New here
Posts: 2
Joined: Tue Dec 15, 2015 11:56 pm

Re: Fail to update RSS feeds (0x6013)

Post by alobbs » Wed Dec 16, 2015 12:16 am

Folks,

I've just figured out what the problem is. Download Station doesn't manage redirection (HTTP 301, for instance) properly.

The workaround is to open the RSS URL with wget or curl, and get the final URL where the request is being redirected.

Best,
Alvaro


PS: Simon, the bug ID is #MIL-825-31699

Downhall David
First post
Posts: 1
Joined: Tue Jan 05, 2016 11:59 pm

Re: Fail to update RSS feeds (0x6013)

Post by Downhall David » Wed Feb 24, 2016 11:49 pm

This problem would appear to have reared its head again. Running 4.2.1 on TS251+ - Worked perfectly up until today!

Danixu86
Starting out
Posts: 17
Joined: Sat Jan 16, 2016 7:48 pm

Re: Fail to update RSS feeds (0x6013)

Post by Danixu86 » Sun May 01, 2016 3:52 pm

Yes, because i've tried to use it today for first time and i've got that error.

illestothi
First post
Posts: 1
Joined: Thu Oct 20, 2016 2:06 am

Re: Fail to update RSS feeds (0x6013)

Post by illestothi » Thu Oct 20, 2016 2:11 am

If you have a correct content in the rss field it will works as expected (without above error code)

Check the following content in your rss (example):
<item>
<title>Kundo.Age.of.the.Rampant.2014.BDrip.Custom.HUN.x264-DenZo [Film (HUN SD)]</title>
<link>https://link/index.phpkey=09e</link>
<description>Kundo.Age.of.the.Rampant.2014.BDrip.Custom.HUN.x264-DenZo</description>
<comments>some comments</comments>
<category>Films from internet</category>
<pubDate>Wed, 19 Oct 2016 19:58:00 +0200</pubDate>
<source url="https://fake.com/rss_dl.php/id=2/key=09e">Download</source>
</item>

wakkaday
Getting the hang of things
Posts: 59
Joined: Tue Sep 15, 2015 1:00 am

Re: Fail to update RSS feeds (0x6013)

Post by wakkaday » Fri Oct 21, 2016 10:44 pm

where do you add the rss feed?

Rumik
Starting out
Posts: 24
Joined: Wed Jul 15, 2015 1:34 am

Re: Fail to update RSS feeds (0x6013)

Post by Rumik » Sun Aug 20, 2017 1:43 pm

I'm having the same problem. Is there no solution?

Wathule
First post
Posts: 1
Joined: Mon May 04, 2020 6:05 pm

Re: Fail to update RSS feeds (0x6013)

Post by Wathule » Tue Jun 23, 2020 7:26 pm

I found that I got the error only why my feed was empty. Provided the RSS feed comprised at least one item, no error was elicited.

Locked

Return to “Download Station and QGet”