SMB file transfers no longer work in QTS 4.2.1 (Build 20160601)

FTP Server, File Server, DDNS, SAMBA, AFP, NFS
sirozha
Know my way around
Posts: 129
Joined: Tue Jun 04, 2013 2:19 am

SMB file transfers no longer work in QTS 4.2.1 (Build 20160601)

Postby sirozha » Mon Jun 13, 2016 1:27 am

I recently upgraded my TS-563 to QTS 4.2.1 (Build 20160601) and noticed that I can no longer transfer files (of any size) from the MacBook Pro running OS X 10.11.15 to the QNAP using SMB. I can transfer files to the same exact NAS shares via AFP. It appears to me that before I upgraded to this QTS version, I had no issues using SMB for transferring files to the QNAP, and in fact, it seems to me that the transfer speeds over SMB were higher than those over AFP. With QTS 4.2.1 (Build 20160601), the SMB file transfer starts but never goes anywhere. It just hangs in there with the Finder box showing Copying "file_name" but the progress bar not moving at all.

The Microsoft Networking settings on the NAS are:
Standalone Server
Enable WINS server
Local Master Browser
Allow only NTLMv2 authentication
Name Resolve Priority: Try WINS then DNS
Enable Asynchronous I/O
Highest SMB version: 3.0

I upgraded from a previous version of 4.2.1 mostly because there seems to be some improvements with AFP mentioned in the Release Notes for this version. In the past, I had some issues with not being able to rename or delete directories on the NAS from the OS X Finder application, which required a reboot of the Mac to bring that functionality back until it would break down and require another reboot of the Mac. This seems to be one of the issues mentioned as fixed in the Release Notes for this QTS version, but now SMB file transfers don't seem to work at all from the Mac to the NAS. I have no problems mounting the NAS shares over SMB or navigating the directory tree on the NAS shares over SMB. It's just that the file transfers to the NAS are not working over SMB.

Any thoughts?

misterbig
New here
Posts: 2
Joined: Mon Jan 31, 2011 4:35 am

Re: SMB file transfers no longer work in QTS 4.2.1 (Build 20160601)

Postby misterbig » Tue Jun 28, 2016 7:44 pm

Hi,

After the upgrade I'm having the same problems. I can't even set Highest SMB version because it is not showing this option. On the previous build, everything was working fine with SMB. It showed my nas name together with (SMB). Now this options has disappeared from my network completely.

Hope this wil get fixed soon..

User avatar
schumaku
Guru
Posts: 42528
Joined: Mon Jan 21, 2008 4:41 pm
Location: Kloten (Zurich), Switzerland -- Skype: schumaku
Contact:

Re: SMB file transfers no longer work in QTS 4.2.1 (Build 20160601)

Postby schumaku » Wed Jun 29, 2016 5:44 pm

sirozha wrote:... With QTS 4.2.1 (Build 20160601), the SMB file transfer starts but never goes anywhere. It just hangs in there with the Finder box showing Copying "file_name" but the progress bar not moving at all. ..., but now SMB file transfers don't seem to work at all from the Mac to the NAS. I have no problems mounting the NAS shares over SMB or navigating the directory tree on the NAS shares over SMB. It's just that the file transfers to the NAS are not working over SMB.


Is SAMBA up and running, can the NAS be accessed and data transferred from other systems (ie Windows, Linux, ...) by SMB?

misterbig wrote: I can't even set Highest SMB version because it is not showing this option.
There is no UI control for the max negotiated (available) SMB protocol on "cat1" (previously "home") NAS models - which are permitting max 2.1.

The max SMB version can be checked and set from the NAS shell:

Check the current status:

[~] # smb2status
smbd (samba daemon) Version 3.6.25
smbd (samba daemon) is running.
max protocol SMB 1.0 enabled.

Enable SMB 2.1:

[~] # smb21enable
Shutting down SMB services: smbd nmbd.
Shutting down winbindd services: winbindd.
max protocol SMB 2.1 ... enabled.
locks path was set to /share/HDA_DATA/.locks
Shutting down winbindd services: winbindd.
Starting winbindd services:Starting SMB services:.

smbd (samba daemon) Version 3.6.25
smbd (samba daemon) is running.
max protocol SMB 2.1 enabled

Revert to 1.0:

[~] # smb2disable
Shutting down SMB services: smbd nmbd.
Shutting down winbindd services: winbindd.
max protocol SMB 1.0 ... enabled.
locks path was set to /share/HDA_DATA/.locks
Shutting down winbindd services: winbindd.
Starting winbindd services:Starting SMB services:.

smbd (samba daemon) Version 3.6.25
smbd (samba daemon) is running.
max protocol SMB 1.0 enabled.

misterbig wrote:On the previous build, everything was working fine with SMB. It showed my nas name together with (SMB).
The Bonjour announcement for SAMBA does no longer carry the "(SMB)" anymore - check your NAS config Control Panel -> Network Services -> Service Discovery -> [Bonjour].

misterbig wrote:After the upgrade I'm having the same problems. .... Now this options has disappeared from my network completely.
The OP has the NAS visible, and can access/mount the shared folder - but no data transferred. As you state it's not visible, hard to believe it's the same.

Don't hesitate to contact QNAP Customer Service on https://helpdesk.qnap.com/ (registration required).

Worth trying is re-applying the same firmware image again -> wiki.qnap.com/wiki/Manually_Updating_Firmware ... guess your NAS firmware image install was incomplete - thus services like the Bonjour announcements not being workable at all.

Regards,
-Kurt.

Browneye9999
Starting out
Posts: 14
Joined: Sun Jan 24, 2016 5:47 pm

Re: SMB file transfers no longer work in QTS 4.2.1 (Build 20160601)

Postby Browneye9999 » Thu Jul 21, 2016 7:34 pm

I have a similar situation.

I have two QNAP's, a newer TVS-463, and an older TS-419P.

On the TVS-463 SMB works fine. I can see the QNAP on Windows 10 PC's, and I can mount the QNAP as an SMB share on Linux. All works fine.

The same can't be said for the TS-419P. It can't be seen via SMB on anything. Windows 10 boxes show the device in the browser yet when you try to access the unit you get an error saying "The Network Address is invalid", yet you can ping and access the TS-419P via the web I/F. Trying to mount the volume on Linux results in a 'No such Device or Address' error, yet can ping the QNAP.

Both QNAP's are running SMB 2.1 (Version 3.6.25)

Would downgrading protocol to SMB 1.0 work??

User avatar
schumaku
Guru
Posts: 42528
Joined: Mon Jan 21, 2008 4:41 pm
Location: Kloten (Zurich), Switzerland -- Skype: schumaku
Contact:

Re: SMB file transfers no longer work in QTS 4.2.1 (Build 20160601)

Postby schumaku » Thu Jul 21, 2016 7:57 pm

Browneye9999 wrote:Would downgrading protocol to SMB 1.0 work??
No - check and fix the potential SMB issues on the TS-419P instead.

Browneye9999 wrote:The same can't be said for the TS-419P. It can't be seen via SMB on anything. Windows 10 boxes show the device in the browser yet when you try to access the unit you get an error saying "The Network Address is invalid", yet you can ping and access the TS-419P via the web I/F. Trying to mount the volume on Linux results in a 'No such Device or Address' error,


SAMBA processes up?

[~] # ps -ef | grep mbd
3909 admin 1600 S /usr/local/samba/sbin/nmbd -l /var/log -D -s /etc/config/smb.conf
6753 admin 2300 S /usr/local/samba/sbin/smbd -l /var/log -D -s /etc/config/smb.conf
...

Any useful stuff in the logs?

[~] # ls -als /var/log/log*
4 -rw-r--r-- 1 admin administ 2003 Jul 7 17:01 /var/log/log.nmbd
8 -rw-r--r-- 1 admin administ 5805 Jul 10 19:39 /var/log/log.smbd

Potentially some obviously borked smb.conf?

[~] # testparm
Load smb config files from /etc/config/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
WARNING: The "null passwords" option is deprecated
Processing section "[Multimedia]"
...
Server role: ROLE_STANDALONE
Press enter to see a dump of your service definitions
...
[global]
...

Browneye9999 wrote:On the TVS-463 SMB works fine. I can see the QNAP on Windows 10 PC's, and I can mount the QNAP as an SMB share on Linux. All works fine.
...
Both QNAP's are running SMB 2.1 (Version 3.6.25)
Hm, rule of thumb, at the time the TVS-x63 were released, QTS defaulted to SAMBA 4already. Suspect this NAS does hold HDD migrated from a different legacy or older NAS. Explained several times already ... QNAP decided not to force a migration from SAMBA 3.x installation to SAMBA 4 (completely odd in my opinion). You can force the migration / SAMBA upgrade on SMB (cat2) NAS installed earlier:

Code: Select all

/etc/init.d/samba4.sh reinstall_samba keep


[~] # /etc/init.d/samba4.sh reinstall_samba keep
reinstall samba!!!!
Shutting down SMB services: smbd nmbd.
Shutting down winbindd services: winbindd.
install /mnt/HDA_ROOT/update_pkg/samba4.tgz
Restarting SMB services:
Shutting down SMB services: smbd nmbd.
Shutting down winbindd services: winbindd.
Version 3.6.24 -> Version 4.0.16
locks path was set to /share/MD0_DATA/.locks
Starting winbindd services:Starting SMB services:.
done.


Now SMB 3.0 protocol should be available - can't tell you right now if a reboot is required or just a re-login get the smb3enable:

[~] # smb3enable
...

Regards,
-Kurt.

Browneye9999
Starting out
Posts: 14
Joined: Sun Jan 24, 2016 5:47 pm

Re: SMB file transfers no longer work in QTS 4.2.1 (Build 20160601)

Postby Browneye9999 » Fri Jul 22, 2016 5:19 am

Thanks Kurt,

SMB appears to be working...

[~] # ps -ef |grep mbd
5205 admin 3876 S /usr/local/samba/sbin/smbd -l /var/log -D -s /etc/config/smb.conf
5213 admin 1956 S /usr/local/samba/sbin/smbd -l /var/log -D -s /etc/config/smb.conf
11075 admin 2280 S /usr/local/samba/sbin/nmbd -l /var/log -D -s /etc/config/smb.conf
12224 admin 576 S grep mbd


then I tried to do the samba reinstall

/etc/init.d/samba4.sh reinstall_samba keep


But it appears as though there is no samba4.tgz update package available.

[/] # etc/init.d/samba4.sh reinstall_samba keep
NO /mnt/HDA_ROOT/update_pkg/samba4.tgz
[/] # cd mnt/HDA_ROOT/update_pkg
[/mnt/HDA_ROOT/update_pkg] # ls
DSv3.tgz jsLib.tgz pkg_flag
ImageMagick.tgz language.tgz printer.tgz
MARVELL_6281.e2fsprogs.tgz ldap_server.tgz qcli.tgz
Python.tgz libboost.tgz qpkg.tar.cksum
Samples.tgz mariadb5.tgz radius.tgz
antivirus.tgz medialibrary.tgz samba.tgz
apache_php5.tgz mt-daapd.tgz vaultServices.tgz
avahi0630.tgz mtpBinary.tgz vim.tgz
bluetooth.tgz musicstation.tgz vpnopenvpn.tgz
chassisView.tgz mysql5.tgz vpnpptp.tgz
ffmpeg.tgz photostation2.tgz wifi.tgz


So where can I get samba4.tgz?

I'm thinking I might have to factory reset right back to scratch and start again.....

User avatar
schumaku
Guru
Posts: 42528
Joined: Mon Jan 21, 2008 4:41 pm
Location: Kloten (Zurich), Switzerland -- Skype: schumaku
Contact:

Re: SMB file transfers no longer work in QTS 4.2.1 (Build 20160601)

Postby schumaku » Fri Jul 22, 2016 3:41 pm

Browneye9999 wrote:But it appears as though there is no samba4.tgz update package available.
I've clearly stated that this does apply to so called SMB (cat) NAS models - because you mentioned your TVS-x63 does still run on SMB 2.1 (Version 3.6.25) - check https://docs.qnap.com/ for SMB vs. home/legacy esp. cat1 vs. cat2. No AMBA4 available on the legacy NAS like the Marvell Kirkwood units.

Have an eye in the log.smbd ... check testparm ....

Browneye9999
Starting out
Posts: 14
Joined: Sun Jan 24, 2016 5:47 pm

Re: SMB file transfers no longer work in QTS 4.2.1 (Build 20160601)

Postby Browneye9999 » Sat Jul 23, 2016 12:57 pm

Fixed the SMB problem. It might have been a bit of confusion in the QNAP itself. Old files with new configurations or New files with old configurations….anyway, did a first birthday…took everything right back to scratch, had it reinstall itself and it all popped up straight away. Windows and Linux can now see the box via SMB.


Return to “File Sharing”

Who is online

Users browsing this forum: No registered users and 7 guests