Cannot Login to Manage QNAP NAS TS-451

Q'center app, Helpdesk app
GreyWullf
First post
Posts: 1
Joined: Fri Jun 05, 2015 12:01 am
Location: Edmonton, AB

Cannot Login to Manage QNAP NAS TS-451

Post by GreyWullf » Wed Feb 07, 2018 10:33 am

Hello, I usually log into my QNAP NAS by simply typing "https://10.0.1.28/" in my Chrome Browser tab and am presented with the login page. I log into my NAS to manage the NAS and to peruse system logs, etc.

Today I am having problems logging in, so far I have tried logging in with Chrome, Firefox and IE browsers, but I cant get in. The message is always the same:"The server is taking too long to respond", but the server isn't doing anything else.

I should mention I am not having any problems connecting to the folders/files contained on the NAS.

Suggestions?

User avatar
storageman
Ask me anything
Posts: 5511
Joined: Thu Sep 22, 2011 10:57 pm

Re: Cannot Login to Manage QNAP NAS TS-451

Post by storageman » Wed Feb 07, 2018 7:07 pm

Can you login via Qnap Finder?
Can you login via putty?
On latest firmware?

nimmer
New here
Posts: 2
Joined: Thu Feb 08, 2018 9:00 pm

Re: Cannot Login to Manage QNAP NAS TS-451

Post by nimmer » Fri Feb 09, 2018 5:39 pm

Hey,

did you solve your problem? I'm having the same issue with my TS-251+ :(

/nimmer

jeroenkh
First post
Posts: 1
Joined: Sat Feb 10, 2018 12:22 am

Re: Cannot Login to Manage QNAP NAS TS-451

Post by jeroenkh » Sat Feb 10, 2018 12:27 am

I have the same. Can not login with browser. qfinder find my nas with the ip adress itgets from dhcp. qsync is working but shared folders isn't. help what can i do without losing al my data.

dolbyman
Guru
Posts: 19985
Joined: Sat Feb 12, 2011 2:11 am
Location: Vancouver BC , Canada

Re: Cannot Login to Manage QNAP NAS TS-451

Post by dolbyman » Sat Feb 10, 2018 12:57 am

jeroenkh wrote:I have the same. Can not login with browser. qfinder find my nas with the ip adress itgets from dhcp. qsync is working but shared folders isn't. help what can i do without losing al my data.


please open a new thread and post info about hardware and configuration .. otherwise we need a crystal ball to troubleshoot

Simca
New here
Posts: 2
Joined: Mon Feb 12, 2018 5:04 pm

Re: Cannot Login to Manage QNAP NAS TS-451

Post by Simca » Mon Feb 12, 2018 5:19 pm

I have the same problem with my TS-251+ since yesterday:

Can't connect to Admin http://192.168.1.2xx.
Can't connect shared folders from Windows10 desktop.

Connected Qfinder, noticed that DEVICE NAME has been changed to a default, and TIME ZONE has been changed. I restored to correct values.
Tried Static IPs (as I used it before) and DHCP.

Getting
---------------------------------------
This site can’t be reached
192.168.1.205 refused to connect.
Try:
Checking the connection
Checking the proxy and the firewall
ERR_CONNECTION_REFUSED
--------------------------------------------

As far I can undestand the webserver Port 80 is not running, and Qfinder connects trough another Port.

Tried front button restart and diferent IPs.
Tried back bution (3s) restart.

User avatar
storageman
Ask me anything
Posts: 5511
Joined: Thu Sep 22, 2011 10:57 pm

Re: Cannot Login to Manage QNAP NAS TS-451

Post by storageman » Mon Feb 12, 2018 5:35 pm

Try connecting direct to PC (without switch), you need to establish whether it is a network issue or hardware fault on the box.

Simca
New here
Posts: 2
Joined: Mon Feb 12, 2018 5:04 pm

Re: Cannot Login to Manage QNAP NAS TS-451

Post by Simca » Tue Feb 13, 2018 6:07 pm

Dear friend, thanks for your tip!

Unfortunately the problem is a little bit depper. I can conncet to the QNAP TS-251+ by ssh.
I am not a Linux expert, but I khow the basics to connect to the server and to start a service.

So I tried to start de web server, but I got this error.
/etc/init.d/Qthttpd.sh start
/etc/init.d/Qthttpd.sh: line 175: 94830 - : syntax error: operand expected (error token is " ")


Then I hoticed that the apache.conf file was empy (size zero)
then I copied the backup. You can see that the apache.conf.tmp is still empty.
cp /etc/config/apache/apache.conf.bak /etc/config/apache/apache.conf

[/etc/config/apache] # ls -l
total 60
-rw-r--r-- 1 admin administrators 15571 Feb 13 10:24 apache.conf
-rw-r--r-- 1 admin administrators 15571 Apr 18 2016 apache.conf.bak
-rw-r--r-- 1 admin administrators 0 Feb 11 22:50 apache.conf.tmp
drwxr-xr-x 2 admin administrators 4096 Feb 11 19:12 extra/
-rw-r--r-- 1 admin administrators 12958 Apr 18 2016 magic
-rw-r--r-- 1 admin administrators 0 Feb 11 19:12 mime.types
drwxr-xr-x 3 admin administrators 4096 Apr 18 2016 original/
-rw-r--r-- 1 admin administrators 422 May 15 2017 php-fpm.conf


But unfortunately I continue to get:
/etc/init.d/Qthttpd.sh start
/etc/init.d/Qthttpd.sh: line 175: 95364 - : syntax error: operand expected (error token is " ")


I believe that probably there is at least one more file corrupted, but can't gess which.

Once I can start the web server, I believe that I will be able to reconfigure the NAS.
Then downloading a new version of the OS will correct any other missing file.

Can someone help me?

User avatar
storageman
Ask me anything
Posts: 5511
Joined: Thu Sep 22, 2011 10:57 pm

Re: Cannot Login to Manage QNAP NAS TS-451

Post by storageman » Tue Feb 13, 2018 10:32 pm


Rogtuf
Starting out
Posts: 31
Joined: Sun Apr 26, 2015 12:53 am

Re: Cannot Login to Manage QNAP NAS TS-451 & 253 pro

Post by Rogtuf » Sat Mar 10, 2018 1:22 am

I have the same problem, but with a TS-253 Pro, not 451.

Qfinder can see the Qnap, and my movies stored on the device are accessible with Plex, but I cannot log in. I get the log in screen, but then it simply says "Logging in" and hangs there (for hours).

I had a previous problem with what appeared to be McAfee hogging over 90% of Cpu, even though I had never installed McAfee, and presume this to be malware. I used the Malware removal tool and it appeared to be gone, only to have re-surfaced a few days ago. Contacted support, gave them access, and now left with a hung log in screen.

Is there any merit in trying the 3 second reset please?

I am once again, seriously considering selling the unit as I never seem to go more that a couple of months without some sort of problem with the unit. I don't know why Qnap don't supply a decent paid for support service, because it would be a whole lot cheaper than having to junk this unit and buy a different make. I even called Span to find out if they would repair the unit, only to be told that they will not help with a unit they didn't sell.
Roger
Hove, UK
Qnap TS253 Pro, V 4.2.5 (20170413), Single port, Disk 2x WDC WD60EZRX-00MVLB1 (SATA) Raid 1, MacBook Pro 2016, OSX High Sierra

cripp71
New here
Posts: 2
Joined: Tue Mar 13, 2018 8:15 am

Re: Cannot Login to Manage QNAP NAS TS-451

Post by cripp71 » Tue Mar 13, 2018 8:30 am

Hi Rogtuf,

I am in exactly the same boat as you except with a 251+. I can access my Plex files remotely but cannot get past the log in page - just hangs at "Logging in" like yours. Also I notice the background on the login page is just plain black and white instead of the normal pictures and graphics. I also had been infected with the virus a couple of months back which was hogging my CPU but was able to clean it out with the steps found on the forums. I fear it's back though because my Plex is constantly buffering which is the same issue that caused me to find the virus the first time. But this time I can't even get in to fix it.

I tried the 3 second reset but to no avail. In fact I'm in worse shape now because previously I could see my files on the hard drive through a share on my pc but since the reset it prompted me to log in when trying to access the share and it's blocking me there too. I'm debating the 10 second reset. Anyone have any suggestions or success stories on getting past this? All of these issues look pretty similar. I think there's a new issue out there. I'd certainly appreciate some help!

michaelj70
Starting out
Posts: 12
Joined: Tue May 24, 2011 6:07 pm

Re: Cannot Login to Manage QNAP NAS TS-451

Post by michaelj70 » Tue Mar 13, 2018 3:46 pm

Any news on this .... I have the same problem Just brought an external caddy to see if my disks are OK ???
TS-210
4.0.2

Rogtuf
Starting out
Posts: 31
Joined: Sun Apr 26, 2015 12:53 am

Re: Cannot Login to Manage QNAP NAS TS-451

Post by Rogtuf » Tue Mar 13, 2018 4:33 pm

No news. I received a message from Qnap yesterday to thank me for enabling remote access, but nothing since. I can hear the hard disk churning, so I'm guessing the malware is back. I'll give it a few more days then sadly I think it will be the 10 second erase and sell.

Update this afternoon. Qnap were able to log on (as I had opened access before I had the problem) and have fixed the access and deleted the McAfee malware. Apparently it is a new variant. I have absolutely no idea how it got on there in the first place. If anyone is still having trouble accessing, then post a support ticket on the web site and hopefully they will be able to help you.

Roger
Roger
Hove, UK
Qnap TS253 Pro, V 4.2.5 (20170413), Single port, Disk 2x WDC WD60EZRX-00MVLB1 (SATA) Raid 1, MacBook Pro 2016, OSX High Sierra

gafeta
New here
Posts: 9
Joined: Fri Sep 17, 2010 12:47 am
Location: Sweden

Re: Cannot Login to Manage QNAP NAS TS-451

Post by gafeta » Thu Mar 15, 2018 11:29 pm

Well almost the same problem for me.
My NAS : TS-259 PRO on build 4.2.6 build 20171208
Admin page: http://192.168.1.10:8080

The problem is as you described, I cannot access the admin page as usual anymore. It has been working well since the latest upgrade, but now it's gone.
One strange thing is that every time I restart the NAS I can, actually, login to the NAS admin page during the startup, also initially, just for a couple of seconds, the same with QFinder, it finds the NAS, but then disappear it again.

Tested to login with Edge, Explorer and latest Chrome.

"
This site can’t be reached
192.168.1.10 took too long to respond.
Try:

Checking the connection
Checking the proxy and the firewall
Running Windows Network Diagnostics
ERR_CONNECTION_TIMED_OUT"

tested to login with https:// but nothing.

SSH login is not working anymore. (with Putty), worked before.
UPDATE(2018-03-18): I still can establish a SSH connection with putty to port 22 during startup(around 2-3 minutes after start), and the connection remains open.But new connections are not possible. "Putty: Network error. Connection timed out"

In my case I cannot either access any folder in the NAS.

I can Ping the NAS and I get a fast response < 5 ms.
I also get, as expected, some daily messages to my mail after unsuccessfuls backup jobbs.
So the NAS is working.

I can though access the terminal directly from the NAS (with a keyboard and a monitor connected directly to the NAS) and can get in as admin but I have very little experience in Linux.
I send an email to the support team recently and I'm waiting for the answer.
So any help or idea before a hard reset is really appreciated!
Last edited by gafeta on Mon Mar 19, 2018 1:24 am, edited 2 times in total.

Rogtuf
Starting out
Posts: 31
Joined: Sun Apr 26, 2015 12:53 am

Re: Cannot Login to Manage QNAP NAS TS-451

Post by Rogtuf » Fri Mar 16, 2018 3:52 am

I don't believe a hard reset will do any good, unless you select the nuclear option of 10 seconds. I would wait for support, but how they log in when you can't get in to allow them I don't know. I was fortunate (if you can call it that), in the I had given them access before I lost the log in. Its a shame that there isn't a brute force way of getting in in a "safe mode", so that you could at least enable external access - but maybe there is.......

Roger
Roger
Hove, UK
Qnap TS253 Pro, V 4.2.5 (20170413), Single port, Disk 2x WDC WD60EZRX-00MVLB1 (SATA) Raid 1, MacBook Pro 2016, OSX High Sierra

Post Reply

Return to “NAS Management”