Web Server Virtual Hosts

Post your questions about Web Server usage and Apache + PHP + MySQL/SQLite web applications.
Post Reply
First post
Posts: 1
Joined: Sun Jun 24, 2018 6:07 am

Web Server Virtual Hosts

Post by TingC » Sun Jun 24, 2018 6:46 am

Does anyone know how to enable ssl/https on the websites being hosted? Because when i try to change the protocol from http(port 80) to https(port 443) all it does is send me to the qnap home page. However, when i use http it goes to the website like it's supposed to. Any help would be much appreciated.

New here
Posts: 2
Joined: Mon Aug 21, 2017 5:07 pm

Re: Web Server Virtual Hosts

Post by ceyeber62 » Mon Nov 12, 2018 4:27 am

Did you ever solve this? Having the same problem.

Starting out
Posts: 18
Joined: Fri Oct 05, 2012 3:03 am

Re: Web Server Virtual Hosts

Post by bl4d3 » Sun Jul 26, 2020 2:13 am

You need leave the port at 80 for HTTP. In the "ControlPanel" go to the "Web Server" and check "Enable secure connection (HTTPS)". Take the default port 8081 or another one of your desire.
If you only want to use HTTPS and not allow HTTP, then check "Force secure connection (HTTPS) only" and apply these changes. Without checking the Apache's conf files via SSH/SFTP I guess, that HTTP requests will be redirected to HTTPS.

Post Reply

Return to “Web Server & Applications (Apache + PHP + MySQL / SQLite)”