HTTPS access NAS over internet

Post your questions about myQNAPcloud service here.
pbjorkkvist
Starting out
Posts: 28
Joined: Wed Dec 31, 2014 11:06 pm

HTTPS access NAS over internet

Postby pbjorkkvist » Wed Jul 11, 2018 4:47 pm

Hi

Just installed a SSL certificate from qnap, seems to be working but i am not sure of how to access using it.
When you install the certificate it says one must use the full myqnapcloud address, when i look in the certificate i can see the following name:
kaminocloud.myqnapcloud.com. So is it correct to use https://kaminocloud.myqnapcloud.com for access ?

I have also tried to use https:www.myqnapcloud.com/KaminoCloud but neither work. I can access https://192.168.1.2 so can it be something in firewall for traffic
coming outside my network perhaps.

User avatar
OneCD
Experience counts
Posts: 4609
Joined: Sun Aug 21, 2016 10:48 am
Location: "... there, behind that sofa!"

Re: HTTPS access NAS over internet

Postby OneCD » Wed Jul 11, 2018 4:53 pm

Have you forwarded port 8080 in your router to your NAS?

Debian 'Stretch' on my production NAS (TS-569 Pro), with the backup NAS (TS-559 Pro+) to eventually follow. When that happens, I'll no longer use or support any QNAP firmware. Debian powerup/poweroff times are < 1 minute.

I'm also on GitHub
To contact me: one.cd.only@gmail.com

pbjorkkvist
Starting out
Posts: 28
Joined: Wed Dec 31, 2014 11:06 pm

Re: HTTPS access NAS over internet

Postby pbjorkkvist » Wed Jul 11, 2018 5:13 pm

I have, as in attached picture. But should not HTTPS have a different port perhaps?

For my understanding, if i only use myqnapcloud address i guess Qnapcloud must point to me in some way? or how is that
address really working ?
You do not have the required permissions to view the files attached to this post.

pbjorkkvist
Starting out
Posts: 28
Joined: Wed Dec 31, 2014 11:06 pm

Re: HTTPS access NAS over internet

Postby pbjorkkvist » Wed Jul 11, 2018 5:40 pm

I can access using https://a11a.myqnapcloud.com/cgi-bin/, but anything regarding my cloud-address is not working.

User avatar
OneCD
Experience counts
Posts: 4609
Joined: Sun Aug 21, 2016 10:48 am
Location: "... there, behind that sofa!"

Re: HTTPS access NAS over internet

Postby OneCD » Thu Jul 12, 2018 4:15 am

pbjorkkvist wrote:I have, as in attached picture.

Your picture does not show a rule for port 8080. It shows a rule for port 80. ;)

pbjorkkvist wrote:But should not HTTPS have a different port perhaps?

You're correct - I think the default for HTTPS is port 8081. Please create a port-forwarding rule in your router for this one too. Then post a new screenshot of your forwarding rules.

Debian 'Stretch' on my production NAS (TS-569 Pro), with the backup NAS (TS-559 Pro+) to eventually follow. When that happens, I'll no longer use or support any QNAP firmware. Debian powerup/poweroff times are < 1 minute.

I'm also on GitHub
To contact me: one.cd.only@gmail.com


Return to “myQNAPcloud service”

Who is online

Users browsing this forum: No registered users and 0 guests