TVS-882T: Thunderbolt networking is broken on Windows 10 Pro 1903

FTP Server, File Server, DDNS, SAMBA, AFP, NFS
buggz
Starting out
Posts: 39
Joined: Fri Jul 03, 2020 12:10 pm

TVS-872XT: TB3 networking works for me on Windows 10 Pro 1903

Post by buggz » Sat Jul 18, 2020 5:40 am

OS Name Microsoft Windows 10 Pro
Version 10.0.18363 Build 18363

Windows 10 Pro Build 18362.19h1_release.190318-1202

Processor Intel(R) Core(TM) i7-8700K CPU @ 3.70GHz, 3696 Mhz, 6 Core(s), 12 Logical Processor(s)
BIOS Version/Date American Megatrends Inc. P3.30, 12/7/2018
SMBIOS Version 2.8
BaseBoard Manufacturer ASRock
BaseBoard Product Z370 Killer SLI/ac

System Drivers
nhi Thunderbolt(TM) Controller c:\windows\system32\drivers\tbt81x.sys Kernel Driver
tbtmpdrv Thunderbolt(TM) Networking c:\windows\system32\drivers\tp2p81x.sys Kernel Driver

Loaded Modules
Thunderbolt 16.3.61.14 439.23 KB (449,768 bytes) 3/16/2017 09:59 Not Available c:\program files (x86)\intel\thunderbolt software\thunderbolt.exe

Services
Thunderbolt(TM) Service ThunderboltService Running Manual Own Process "c:\program files (x86)\intel\thunderbolt software\tbtsvc.exe" Normal LocalSystem 0

gorkme
New here
Posts: 6
Joined: Fri Jul 17, 2020 5:09 am

Re: TVS-882T: Thunderbolt networking is broken on Windows 10 Pro 1903

Post by gorkme » Sat Jul 18, 2020 8:27 pm

buggz thank you.
It's help me for 20 minutes.

I found this driver Thunderbolt 16.3.61.14
delete old versions. create thunderbolt connection. nothing change, but after I create Internet connection sharing. I recieve your speeds: ~2000\500 mb\sec (read\write)
But after that I want to try T2e connection via qfinder - and speed crashed back to 60\500 mb\sec

I'm trying to do everything back - but nothing. Happiness wasn't so long..

buggz
Starting out
Posts: 39
Joined: Fri Jul 03, 2020 12:10 pm

Re: TVS-882T: Thunderbolt networking is broken on Windows 10 Pro 1903

Post by buggz » Sat Jul 18, 2020 10:50 pm

Hi gorkme,

I have never used the T2e protocol thingy.
That is totally a Qnap implementation.
It actually makes sense that speeds would decrease,
not only are you putting TB3 data stream on the connection,
now you are putting additional Ethernet stream data.

I will have to read more about this, but the use of this additional protocol would definately decrease the speed.

gorkme
New here
Posts: 6
Joined: Fri Jul 17, 2020 5:09 am

Re: TVS-882T: Thunderbolt networking is broken on Windows 10 Pro 1903

Post by gorkme » Sun Jul 19, 2020 12:48 am

Try to reinstall to clean win 10 2004 workstation - the same situation. (try with 17 and 16 version of thunderbolt drivers)
60mb read\500 mb write

buggz
Starting out
Posts: 39
Joined: Fri Jul 03, 2020 12:10 pm

Re: TVS-882T: Thunderbolt networking is broken on Windows 10 Pro 1903

Post by buggz » Sun Jul 19, 2020 1:11 am

I am no expert, nor pretend to be...
I don’t understand fully the Qnap T2E link.
I don’t understand why this would be used?
Only to provide Ethernet connectivity to the TB3 link?
It seems to me it just introduces too much traffic and causes the physical layer to be saturated?
Or, a very inefficient protocol?

gorkme
New here
Posts: 6
Joined: Fri Jul 17, 2020 5:09 am

Re: TVS-882T: Thunderbolt networking is broken on Windows 10 Pro 1903

Post by gorkme » Sun Jul 19, 2020 7:24 pm

Minor update.

As I understand on gigabyte site there is latest driver wich supported Win10 ver.2004 v. 1‎.41.890.0 from 2‎020/06/09
I've install it.

speed come back to ~2000 read/500 write mb. after that i reboot the computer and speed is come back to ~ 60mb read\500 mb write
Interesting moment that then I change some parameters in thunderbolt adapter configuration like uncheck services like tcp ip v6 for a few seconds speed is come back.
IMG_2395.jpg
IMG_2403.jpg
You do not have the required permissions to view the files attached to this post.

gorkme
New here
Posts: 6
Joined: Fri Jul 17, 2020 5:09 am

Re: TVS-882T: Thunderbolt networking is broken on Windows 10 Pro 1903

Post by gorkme » Thu Jul 23, 2020 10:08 pm

upd.

I have to install windows 10 1803 (with off updates). Qnap support and some people says here that it could help to fix thunderbolt problem.
So. I've install it. I use 17.4.77.400 driver.
What speed I have:
1. write 2000 mb\sec (on 2004 was 500 and I do not change adapter parameters to share the internet)
2. read as in win 10 2004 it starts from 2000 mb\sec but after 2-3 seconds it slows to 65 mb\sec

I have to buy anker thunderbolt cable to test different cable from apple - this is not help me too.


Anyone resolve this problem?

Post Reply

Return to “File Sharing”