Problems with QVPN

Discussion about various official QPKG software applications. Login required to view the contents.
Post Reply
FrankChutsky
Starting out
Posts: 19
Joined: Fri Oct 21, 2016 1:14 pm

Problems with QVPN

Post by FrankChutsky » Mon Sep 30, 2019 6:18 am

Hello,
It has bee suggested that perhaps relying on myqnapcloud for remote access is not such a good idea...better I should use VPN. So, that's what I tried: I downloaded QVPN 2.2.655 on my TS-451 running QTS 4.4.1.1064. As soon as I fired it up, I got the following informative message:
vpn1.png
I looked in Control Panel --> Network and Virtual Switch and saw nothing about VPN or OpenVPN...I searched throughout the documentation for a hint as to what that message meant or how to address the problem. Anyhow, both "Confirm" and "Cancel" options on QVPN appear do the same thing: Allow me to set up a local VPN server to allow me to do more secure remote access. I tried to set up PPTP:
vpn2.png
When I clicked apply, I got the helpful message:
vpn3.png
Clearly I am missing something - I suspect that the two error messages are not unrelated. Any help would be greatly appreciated...
You do not have the required permissions to view the files attached to this post.

FrankChutsky
Starting out
Posts: 19
Joined: Fri Oct 21, 2016 1:14 pm

Re: Problems with QVPN

Post by FrankChutsky » Mon Sep 30, 2019 11:52 pm

OK, I solved the above problem: I had to ENABLE OpenVPN, then change to inteface to ALL and change the the second digit of the VPN IP Client pool. Then Apply, then disable OpenVPN and Apply and that took care of the first error message. The second error message was eliminated by changing the second digit of the VPN IP Client pool to a different value. Horray!! No errors!

03045
New here
Posts: 2
Joined: Mon Nov 23, 2015 12:44 am

Re: Problems with QVPN

Post by 03045 » Sun Oct 13, 2019 3:54 am

I had the same problem. As long as I had QVPN Service 2 app open, the dialog box would pop up telling me that “The interfaces used by the following VPN servers are not available.” This was despite the fact that I had neither of the listed VPN servers Enabled. No matter how many times I answered by clicking either Confirm or Cancel, the dialog box would go away, but then return a few minutes later.

Your solution fixed it for me as well. Thanks for sharing!

matday
Starting out
Posts: 11
Joined: Mon Mar 28, 2016 12:33 am

Re: Problems with QVPN

Post by matday » Sat May 09, 2020 8:20 pm

FrankChutsky wrote:
Mon Sep 30, 2019 11:52 pm
OK, I solved the above problem: I had to ENABLE OpenVPN, then change to inteface to ALL and change the the second digit of the VPN IP Client pool. Then Apply, then disable OpenVPN and Apply and that took care of the first error message. The second error message was eliminated by changing the second digit of the VPN IP Client pool to a different value. Horray!! No errors!
This was driving me nuts and nothing i'd tried would get rid of that stupid message 'The interfaces used by the following VPN servers are not available.' everytime i went into QnapVPN it was really annoying!

Thanks for sharing your solution Frank! :-)

Post Reply

Return to “Official Apps”