[SOLVED] Delayed Write Failed

FTP Server, File Server, DDNS, SAMBA, AFP, NFS
Post Reply
2manycables
Starting out
Posts: 47
Joined: Sat Jan 09, 2010 5:23 am
Location: Buffalo, NY

[SOLVED] Delayed Write Failed

Post by 2manycables » Sun Jul 04, 2010 1:24 am

After installing EMC Retrospect 7.7 backup software on XP Pro SP3, I was consistently getting "Delayed Write Failed" messages while trying to backup to the NAS (809-Pro fw 3.2.1):

XP Admin Tools Event Viewer entry:

Code: Select all

Event Type:   Warning
Event Source:   MRxSmb
Event Category:   None
Event ID:   50
Date:      7/3/2010
Time:      3:15:45 AM
User:      N/A
Computer:   COMPUTER_NAME
Description:
{Delayed Write Failed} Windows was unable to save all the data for the file \Device\LanmanRedirector. The data has been lost. This error may be caused by a failure of your computer hardware or network connection. Please try to save this file elsewhere.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 04 00 04 00 02 00 56 00   ......V.
0008: 00 00 00 00 32 00 04 80   ....2..€
0010: 00 00 00 00 0c 02 00 c0   .......À
0018: 00 00 00 00 00 00 00 00   ........
0020: 00 00 00 00 00 00 00 00   ........
0028: 0c 02 00 c0               ...À   

======== DATA in words ============

Data:
0000: 00040004 00560002 00000000 80040032
0010: 00000000 c000020c 00000000 00000000
0020: 00000000 00000000 c000020c

After surfing around a bit, I found this solution:

http://support.microsoft.com/kb/296264/

After creating & setting HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MRXSmb\Parameters\
OplocksDisabled to REG_DWORD = 1 on the XP client and then rebooting it, my network throughput (as reported by Retrospect) on the backup nearly doubled, and the delayed write problem disappeared.

While I probably could have played with the smb.conf file on the NAS and done something with oplocks therein, this was easier to implement.
------
TS-809 Pro
8x 2TB Hitachi HDS722020ALA330 JKAO
Raid-6, BitmapON, EncryptionON, EXT4
firmware: 3.8.3

waninae39
Know my way around
Posts: 153
Joined: Mon Jun 09, 2008 11:32 am

Re: [SOLVED] Delayed Write Failed

Post by waninae39 » Sun Jun 24, 2012 3:43 am

THANK YOU VERY much!

i have been seeing this issue recenetly after i moved Thunberbird mail files from local machines to the NAS.
Each user was seeing the same Delayed Write Failed message when mail was received or the Thunderbird client was started.

i will see if our retrospect BAckup is now faster
Current firmware version:
TS-670pro 4.3.3 6 x 3TB WB RED
TS-669pro 4.3.3 6 x 6TB WB RED
All are running etx4, and running Raid6.
The 669 has 6x 3tb WD red HD, the 439 has 4x 2TB WD black HD,

commercial hardware firewall and commercial router
VOIP hard and soft client with SIP digital and analog telco trunk
NAS & all clients: 1Gbit/s with dual trunk ports

Post Reply

Return to “File Sharing”