How to disable FFMPEG process

Please post your questions about using the web-based Photo, Music, Video Stations here.
Tim Deluxe
First post
Posts: 1
Joined: Fri Aug 16, 2013 11:54 pm

How to disable FFMPEG process

Post by Tim Deluxe » Thu Sep 26, 2013 3:11 am

Hi all,

My QNAP is consuming 100% CPU on ffmpeg. I disabled already all possible applications on the QNAP but ffmpeg keeps on running even after a reboot.
When I kill the process another ffmpeg process will launch.
I checked all my applications, all is off (all the stations, all media servers,....)

How can I disable the proceess or know what launches the process?
If I can't find a solution I will change the rights of ffmpeg or rename it so that it can't be launched.

Thanks for the info.

User avatar
pwilson
Guru
Posts: 22581
Joined: Fri Mar 06, 2009 11:20 am
Location: Victoria, BC, Canada (UTC-08:00)

Re: How to disable FFMPEG process

Post by pwilson » Thu Sep 26, 2013 3:50 am

Tim Deluxe wrote:Hi all,

My QNAP is consuming 100% CPU on ffmpeg. I disabled already all possible applications on the QNAP but ffmpeg keeps on running even after a reboot.
When I kill the process another ffmpeg process will launch.
I checked all my applications, all is off (all the stations, all media servers,....)

How can I disable the proceess or know what launches the process?
If I can't find a solution I will change the rights of ffmpeg or rename it so that it can't be launched.

Thanks for the info.


Contact QNAP Customer Service for assistance. Disabling the MediaScanner (by setting it to "manual scan") in your unidentified :roll: Firmware version will deal with some of it, but it will continue to be used by File Station.

Image

Changing the file permissions on /usr/bin/ffmpeg will not work permanently, as the original one will be re-installed at every reboot, as the Firmware is loaded into a RAMDisk at every boot, and is then run from the RAMDisk.

Patrick M. Wilson
Victoria, BC Canada
QNAP TS-470 Pro w/ 4 * Western Digital WD30EFRX WD Reds (RAID5) - - Single 8.1TB Storage Pool FW: QTS 4.2.0 Build 20151023 - Kali Linux v1.06 (64bit)
Forums: View My Profile - Search My Posts - View My Photo - View My Location - Top Community Posters
QNAP: Turbo NAS User Manual - QNAP Wiki - QNAP Tutorials - QNAP FAQs

Please review: When you're asking a question, please include the following.

fifields
First post
Posts: 1
Joined: Tue May 28, 2013 2:49 am

Re: How to disable FFMPEG process

Post by fifields » Sat Nov 02, 2013 8:50 am

Hi,

This is driving me nuts.

I have disabled Multimedia Station and Rescan Media Library which appeared to be re-enabled when I installed 4.0.2, but still find many instances of ffmpeg running if I use top.

I use rsync to make mirror backups of my shares, but something keeps 'touching' directories, so that many need to be updated even though I have made no use of them. Is file manager creating thumbnail files in folders just because I'm browsing the file system via the QNAP UI?

I there any way to just use the QNAP for plain old file storage (which is all I want) without it wanting to take control all the time?

Cheers, Steve.

User avatar
schumaku
Guru
Posts: 43672
Joined: Mon Jan 21, 2008 4:41 pm
Location: Kloten (Zurich), Switzerland -- Skype: schumaku
Contact:

Re: How to disable FFMPEG process

Post by schumaku » Sun Nov 03, 2013 11:51 pm

You might have to disable the Media Library with every firmware update - the default is actually set very unlucky.

User avatar
teracow
Easy as a breeze
Posts: 348
Joined: Thu Jun 23, 2011 8:17 am

Re: How to disable FFMPEG process

Post by teracow » Wed Nov 06, 2013 12:36 pm

.
Last edited by teracow on Sat Nov 29, 2014 1:03 pm, edited 1 time in total.
I (like many others) have left this forum due to the incompetence of QNAP staff.

I have now completed deletion of all my posts (how-to's, images, hand-written instructions, on-the-fly user manuals, etc..). These are now gone.

I am not interested in assisting QNAP any further when they won't assist me. Anyone unlucky enough to have dealt with Adong Lin (QNAP Systems Inc.) or the blundering incompetence of the 'live chat' specialist AJ Lee will know what I mean. Adong doesn't understand the first thing about basic computer interoperability and AJ disconnects you from live chat when he doesn't want to deal with your problem.

I will not support QNAP any further. Far from it - I will now be recommending a competitor's hardware instead. I'm done.

pacco
Starting out
Posts: 11
Joined: Mon Jul 30, 2012 7:36 pm

Re: How to disable FFMPEG process

Post by pacco » Sat Nov 09, 2013 2:47 am

Changing permission of ffmpeg might do the trick only for the next run of the parent-caller of ffmpeg.
If the parent is still running and you try to get rid of ffmpeg (

Code: Select all

chmod -x /usr/local/medialibrary/bin/ffmpeg
and

Code: Select all

killall -9 ffmpeg
) you see still popping up new ffmpeg-processes in nearly endless manner. All of them have a shell-script as parent and this shell-script's origin is a php-process.

Code: Select all

grep "^PPid:" /proc/<pid>/status"
unveils that there is a:

Code: Select all

/mnt/ext/opt/apache/bin/php -q /share/MD0_DATA/WEb/videsostation/actions/video_convert_loop.php

which is still running although you have disabled videostation in Station Manager.
After killing the php-process the QNAP resettles to silence since more than 4 weeks.

Unbelievable "feature" that QNAP has introduced with the last firmware-upgrade. :-0

User avatar
schumaku
Guru
Posts: 43672
Joined: Mon Jan 21, 2008 4:41 pm
Location: Kloten (Zurich), Switzerland -- Skype: schumaku
Contact:

Re: How to disable FFMPEG process

Post by schumaku » Sat Nov 09, 2013 11:25 pm

pacco wrote:Unbelievable "feature" that QNAP has introduced with the last firmware-upgrade. :-0
Wrong conclusion in this case: QNAP has not installed Video Station on your NAS. Neither with an older nor with any firmware upgrade.

If you don't want Video Station (with it's automatic conversion process required to make all your videos available in a YouTube-like way - without any access rights management) uninstall Video Station from the Application Centre.

Might happen stopping a service does only stop the access to the service - not it's mandatory background jobs.

No need of any shell aerobatics.

Regards,
-Kurt.

pacco
Starting out
Posts: 11
Joined: Mon Jul 30, 2012 7:36 pm

Re: How to disable FFMPEG process

Post by pacco » Sun Nov 10, 2013 12:26 am

You mean it was me who has enabled/installed the VideoStation? Would be embarassing, wouldn't it? But perhaps true, I cannot remember. At least I only remember that after last upgrade to FIrmware 4.0.2 (14.09.2013) the problem with the never-ending actions on NAS started. I have now uninstalled VideoStation completely. And I read again the description of the VideoStation-application - unfortunately not any pre-warning that enabling might result in week-long actions on the NAS due to converting all available Video/Multimedia to the destined formats. In future I will have to look much more deeper into the details when installing new apps on the NAS. I do not want to end up the same way again.

User avatar
schumaku
Guru
Posts: 43672
Joined: Mon Jan 21, 2008 4:41 pm
Location: Kloten (Zurich), Switzerland -- Skype: schumaku
Contact:

Re: How to disable FFMPEG process

Post by schumaku » Sun Nov 10, 2013 12:35 am

You will see more processing - independent of Video Station - caused by the Media Library scan and thumbnail creation. That's the more commonly reported issue leading to higher load I'm afraid. If you intend using the Photo Station / Music Station / or the coming up Video Station 2 or Pro, log with it's DLNA server -the Media Library is required.

Afraid: No simple (official) way to disable it - QNAP has pushed this to QTS 4.1 following community pressure and customer complaints. Some ideas are around in the forum however.

pacco
Starting out
Posts: 11
Joined: Mon Jul 30, 2012 7:36 pm

Re: How to disable FFMPEG process

Post by pacco » Sun Nov 10, 2013 12:50 am

Sounds to be stucked between a rock and a hard place. I still have the Photo Station enabled although I regularly access the files by NFS/CIFS. I will check the NAS-actions after next reboot and eventually remove the Photo-Station, too. Thanks for your supportive information.

User avatar
teracow
Easy as a breeze
Posts: 348
Joined: Thu Jun 23, 2011 8:17 am

Re: How to disable FFMPEG process

Post by teracow » Sun Nov 10, 2013 3:06 am

.
Last edited by teracow on Sat Nov 29, 2014 1:04 pm, edited 1 time in total.
I (like many others) have left this forum due to the incompetence of QNAP staff.

I have now completed deletion of all my posts (how-to's, images, hand-written instructions, on-the-fly user manuals, etc..). These are now gone.

I am not interested in assisting QNAP any further when they won't assist me. Anyone unlucky enough to have dealt with Adong Lin (QNAP Systems Inc.) or the blundering incompetence of the 'live chat' specialist AJ Lee will know what I mean. Adong doesn't understand the first thing about basic computer interoperability and AJ disconnects you from live chat when he doesn't want to deal with your problem.

I will not support QNAP any further. Far from it - I will now be recommending a competitor's hardware instead. I'm done.

peppebytes
Starting out
Posts: 23
Joined: Wed Apr 02, 2014 7:46 pm

Re: How to disable FFMPEG process

Post by peppebytes » Wed Apr 02, 2014 8:14 pm

Hi to all,

i fixed ffmpeg at any boot in this way that remove execution right after 60 seconds after boot:

a. scripts building

1. create script dir

Code: Select all

mkdir /share/HDA_DATA/.qpkg/autorun


2. move to script dir

Code: Select all

cd /share/HDA_DATA/.qpkg/autorun


3. create script autorun.sh:

Code: Select all

vi autorun.sh


and insert this:

Code: Select all

#!/bin/sh
/share/HDA_DATA/.qpkg/autorun/ffmpeg-x.sh &


4. save and exit

Code: Select all

:wq!


6. create script ffmpeg-x.sh

Code: Select all

vi ffmpeg-x.sh


and insert this:

Code: Select all

#!/bin/sh
sleep 60
chmod -x /usr/local/medialibrary/bin/ffmpeg


7. save and exit

Code: Select all

:wq!


8. change permission to scripts:

Code: Select all

chmod 744 autorun.sh
   chmod 744 ffmpeg-x.sh


b. enabling auto start in init.d

1. edit qpkg.conf file:

Code: Select all

 vi /etc/config/qpkg.conf


at the end of file add the follow section:

Code: Select all

[autorun]
Name = autorun
Version = 0.1
Author = peppebytes
Date = 2014-03-31
Shell = /share/HDA_DATA/.qpkg/autorun/autorun.sh
Install_Path = /share/HDA_DATA/.qpkg/autorun
QPKG_File = autorun.qpkg
Enable = TRUE


2. save and exit

Code: Select all

:wq!


reboot and enjoy!!

BunnyBomb
Starting out
Posts: 11
Joined: Thu Apr 17, 2014 10:43 pm

Re: How to disable FFMPEG process

Post by BunnyBomb » Mon Apr 28, 2014 5:58 am

Help!

After updating to the most recent firmware beta 4.1.0 a week ago, I cannot get rid of the ffmpeg process.

It is taking 100% of my CPU for over an entire week now. I do not have Media Library enabled. I don't have Video Station installed. I don't have DLNA or Twonky media server enabled. Basically I've turned off everything that is useful about the QNAP, but the ffmpeg process will not go away. It just sits there taking 100% of the CPU and if I restart it simply comes back. I've checked, double checked, and triple checked that all the Media related options are turned off wherever I can, there is nothing left to disable.

From what I can see in this post, the problem is over a year old - is there still no solution to this that doesn't involve shell commands?

Bunny

User avatar
schumaku
Guru
Posts: 43672
Joined: Mon Jan 21, 2008 4:41 pm
Location: Kloten (Zurich), Switzerland -- Skype: schumaku
Contact:

Re: How to disable FFMPEG process

Post by schumaku » Tue Apr 29, 2014 1:08 am

Up front, I'm aware the small NAS were becoming pretty much unresponsive on QTS 4.0.x before.

BunnyBomb wrote:After updating to the most recent firmware beta 4.1.0 a week ago, I cannot get rid of the ffmpeg process. It is taking 100% of my CPU for over an entire week now.
Does it impact the other services heavily?

BunnyBomb wrote:I don't have DLNA or Twonky media server enabled. Basically I've turned off everything that is useful about the QNAP, but the ffmpeg process will not go away.
That much about the (non?)sense going on in this thread - as-is your NAS does not serve any purpose.

BunnyBomb wrote:It just sits there taking 100% of the CPU and if I restart it simply comes back.
And what is the problem when it comes to your NAS operations now?

While the indications you made are good, we still need a crystal ball here ... or at least a shell access.

User avatar
schumaku
Guru
Posts: 43672
Joined: Mon Jan 21, 2008 4:41 pm
Location: Kloten (Zurich), Switzerland -- Skype: schumaku
Contact:

Re: How to disable FFMPEG process

Post by schumaku » Tue Apr 29, 2014 1:09 am

Up front, I'm aware the small NAS were becoming pretty much unresponsive on QTS 4.0.x before.

BunnyBomb wrote:After updating to the most recent firmware beta 4.1.0 a week ago, I cannot get rid of the ffmpeg process. It is taking 100% of my CPU for over an entire week now.
Does it impact the other services heavily?

BunnyBomb wrote:I don't have DLNA or Twonky media server enabled. Basically I've turned off everything that is useful about the QNAP, but the ffmpeg process will not go away.
That much about the (non?)sense going on in this thread - as-is your NAS does not serve any purpose.

BunnyBomb wrote:It just sits there taking 100% of the CPU and if I restart it simply comes back.
And what is the problem when it comes to your NAS operations now?

While the indications you made are good, we still need a crystal ball here ... or at least a shell access.

Post Reply

Return to “Photo Station, Music Station, Video Station”