[QPKG] openHAB - The open Home Automation Bus

This is the best place for community developers to publish their genius work. Your Apps enrich the QNAP Turbo NAS.
Post Reply
kristo
New here
Posts: 3
Joined: Wed Nov 25, 2015 8:10 pm

Re: [QPKG] openHAB - The open Home Automation Bus

Post by kristo » Sun Apr 10, 2016 1:49 pm

Hi,
please find QPKG with version 1.8.2 genereted on TS-231

https://drive.google.com/open?id=0B_xyX9vj6SkqLTBhNE9aNExjTkU

Thank's Christophe - files and short tutorial are working!

gaertner
First post
Posts: 1
Joined: Thu Jan 07, 2016 2:54 am

Re: [QPKG] openHAB - The open Home Automation Bus

Post by gaertner » Fri Apr 15, 2016 10:14 pm

Hi all,
thank you very much for building the qpkg files.
I am also interested in a qpkg file with openHAB2.

Maybe any expert could build and upload a version of the last snapshot :-)

Mikypan81
New here
Posts: 6
Joined: Sun Apr 12, 2015 3:32 am

Re: [QPKG] openHAB - The open Home Automation Bus

Post by Mikypan81 » Fri May 13, 2016 12:25 am

Hello, Can anyone tell me if there is a version of openhab 2 properly functioning on a QNAP Arm?

In first page I've found a link to a qpkg of OpenHAB2, I've downloaded and installed but I can not make it work.
Anyone can help me?

dremanbook
First post
Posts: 1
Joined: Sat Oct 04, 2014 2:49 am

Re: [QPKG] openHAB - The open Home Automation Bus

Post by dremanbook » Mon May 16, 2016 12:20 am

Thanks for this.
Is there a dependency? I can't get it to run properly. I'm getting...

HTTP ERROR 500

Problem accessing /openhab.app. Reason:

Sitemap 'demo' could not be found
Caused by:

org.openhab.ui.webapp.render.RenderException: Sitemap 'demo' could not be found
at org.openhab.ui.webapp.internal.servlet.WebAppServlet.service(WebAppServlet.java:115)
at org.eclipse.equinox.http.servlet.internal.ServletRegistration.service(ServletRegistration.java:61)
at org.eclipse.equinox.http.servlet.internal.ProxyServlet.processAlias(ProxyServlet.java:128)
at org.eclipse.equinox.http.servlet.internal.ProxyServlet.service(ProxyServlet.java:60)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:848)
at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:598)
...and more lines like this

kasper_b
Starting out
Posts: 29
Joined: Sun Jul 12, 2009 2:24 am

Re: [QPKG] openHAB - The open Home Automation Bus

Post by kasper_b » Sun Sep 04, 2016 6:33 pm

dremanbook wrote:Thanks for this.
Is there a dependency? I can't get it to run properly. I'm getting...

HTTP ERROR 500

Problem accessing /openhab.app. Reason:

Sitemap 'demo' could not be found
Caused by:

org.openhab.ui.webapp.render.RenderException: Sitemap 'demo' could not be found
at org.openhab.ui.webapp.internal.servlet.WebAppServlet.service(WebAppServlet.java:115)
at org.eclipse.equinox.http.servlet.internal.ServletRegistration.service(ServletRegistration.java:61)
at org.eclipse.equinox.http.servlet.internal.ProxyServlet.processAlias(ProxyServlet.java:128)
at org.eclipse.equinox.http.servlet.internal.ProxyServlet.service(ProxyServlet.java:60)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:848)
at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:598)
...and more lines like this

I get the same.... did you figure out how to get it working dremanbook?

elysiandc
Starting out
Posts: 10
Joined: Tue Nov 09, 2010 7:34 am
Location: Melbourne, Australia

Re: [QPKG] openHAB - The open Home Automation Bus

Post by elysiandc » Wed Sep 14, 2016 12:37 pm

For those interested, there is a QPKG for 2.0 (currently beta 3) available here...
https://github.com/openhab/openhab-qnap-qpkg/releases

mrs4t4n
Know my way around
Posts: 100
Joined: Tue Nov 11, 2014 5:53 am

Re: [QPKG] openHAB - The open Home Automation Bus

Post by mrs4t4n » Wed Sep 14, 2016 2:27 pm

Thanks!

User avatar
parkerc
Easy as a breeze
Posts: 294
Joined: Thu Oct 16, 2014 7:36 am
Location: Near London, England
Contact:

Re: [QPKG] openHAB - The open Home Automation Bus

Post by parkerc » Sat Dec 17, 2016 7:35 pm

Is anyone running OpenHab in a Docker container ?

https://hub.docker.com/r/openhab/openhab/
Model Name : QNAP TS-253be (16GB) & TS-453 Pro (8GB)
Firmware Version:: QTS Latest
OS Version : Apple iOS (iPad/Safari Browser)
Number & Type of HDDs : 2 WD Reds, 3TB each, in Raid 1
Website (When I have time) : http://www.nodecentral.co.uk

iamklaus
New here
Posts: 8
Joined: Fri Jan 13, 2012 9:14 pm

Re: [QPKG] openHAB - The open Home Automation Bus

Post by iamklaus » Wed Dec 28, 2016 7:05 pm

I just download an installed your version. Experienced some problems after installation. "/tmp" was running out of space. Some "fileinstall-45345345*" directories were created. It seems it is coming from openhab. I modified openhab.sh and added an environment variable before firing up openhab:

_JAVA_OPTIONS=-Djava.io.tmpdir=/share/CACHEDEV1_DATA/.qpkg/openHAB/tmp/

Now it seems to run stable. Am I the only one having that problem? Is my solution correct or is there some better?


kristo wrote:Hi,
please find QPKG with version 1.8.2 genereted on TS-231

https://drive.google.com/open?id=0B_xyX9vj6SkqLTBhNE9aNExjTkU

Thank's Christophe - files and short tutorial are working!

goodelyfe
Know my way around
Posts: 122
Joined: Tue Jul 01, 2014 5:50 pm

Re: [QPKG] openHAB - The open Home Automation Bus

Post by goodelyfe » Fri Dec 30, 2016 6:14 pm

openHAB 2.0 b4 works no problem

BryceWilkins
Know my way around
Posts: 126
Joined: Mon Jun 21, 2010 5:39 am

Re: [QPKG] openHAB - The open Home Automation Bus

Post by BryceWilkins » Fri Jan 13, 2017 4:00 pm

Hey folks, just a shout out to those interested:

openHAB 2.0 beta5 was released Dec 24th 2016, and Kai mentions aiming for general availability of openHAB 2.0 on Jan 22nd 2017! :D

So, stay tuned for some good stuff in the near future!!

giopas
Been there, done that
Posts: 848
Joined: Thu Mar 26, 2015 12:36 am
Location: somewhere in EU

Re: [QPKG] openHAB - The open Home Automation Bus

Post by giopas » Fri Jan 13, 2017 6:38 pm

Hi, I am just discovering openHAB (yes, I am in late... ) and I wanted to have some advice on how to use it: i.e. what could I do with it from my NAS :)

Can someone tell me more about it with some example?

Thanks!
Qnap TS-253Pro 16Gb RAM - Single Storage Pool: 2 WRed 4TB (RAID 1)
Qnap TS-453A 16Gb RAM - Single Storage Pool: 4 WRed 4TB (RAID 5)

big_cent
New here
Posts: 8
Joined: Mon Oct 12, 2015 12:36 pm

Re: [QPKG] openHAB - The open Home Automation Bus

Post by big_cent » Fri Jan 13, 2017 7:34 pm

guys, I'm new to linux and maybe missing something obvious but I don't see how one can even make z-stick work with NAS. I have entry level home server TS431 (arm v7) and I had successfully installed openHab package (it works okay except when I try to initialize zwave controller). But where do you get those drivers from? Sorry if its dumb question, but I googled and tried to build drivers from Aeotec (I have z-stick gen5), than googled some more and no luck so far. I even upgraded to latest firmware (4.2.3 beta), but those drivers are nowhere to be found. If anyone knows how to make z-stick work with ts431, please help.
Thanks!
QNAP TS431, firmware 4.3.4, kernel 3.2.26, arm7, Raid0

BryceWilkins
Know my way around
Posts: 126
Joined: Mon Jun 21, 2010 5:39 am

Re: [QPKG] openHAB - The open Home Automation Bus

Post by BryceWilkins » Tue Jan 24, 2017 2:39 pm

openHAB 2.0.0 is officially released! :DD

Keep an eye on github for official QNAP qpkg, hopefully in the very near future.

Slickums
Know my way around
Posts: 115
Joined: Fri Nov 25, 2016 6:51 am

Re: [QPKG] openHAB - The open Home Automation Bus

Post by Slickums » Wed Feb 15, 2017 5:09 am

big_cent wrote:guys, I'm new to linux and maybe missing something obvious but I don't see how one can even make z-stick work with NAS. I have entry level home server TS431 (arm v7) and I had successfully installed openHab package (it works okay except when I try to initialize zwave controller). But where do you get those drivers from? Sorry if its dumb question, but I googled and tried to build drivers from Aeotec (I have z-stick gen5), than googled some more and no luck so far. I even upgraded to latest firmware (4.2.3 beta), but those drivers are nowhere to be found. If anyone knows how to make z-stick work with ts431, please help.
Thanks!


I too am looking for info on a z-wave stick that works on the qnap nas. In my case it is a TS-251 (x86). Loaded new V2.0 of OpenHab, and it all looks good, but really need to use z-wave to make things happen.

Not going to invest in a stick only to not have it work on the QNAP and OpenHab!

Post Reply

Return to “Community Apps”